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ETAS はじめに
1 はじめに

LABCAR-PINCONTROL V2.1 は、ES4440.1/.2 コンパクト故障シミュレーションモ
ジュールに付属するソフトウェアです。ES4440.1/.2 コンパクト故障シミュレーショ
ンモジュールを操作してリアルタイムエラーシミュレーションを行い、ECU の診断
機能のテストを行うことができます。

LABCAR-PINCONTROL V2.1 には、ES4440.1/.2 の設定や操作を行うためのユーザー
インターフェースと、自動テストのための COM コントローラが含まれています。

LABCAR-PINCONTROL V2.1 には以下の機能があります。

• マニュアル操作によるエラーシミュレーションの実行

－ “Failure Set"（本書では「故障セット」と記します）の作成と管理

「故障セット」とは、ある特定の機能に関連する ECU シグナルのグループ
（例：ラムダセンサ関連の全シグナル）を定義したものです。

－ エラーシミュレーションを行うシグナルとエラー種別の選択

－ 接点不良エラーのパラメータ（周波数、デューティサイクル）の設定

－ マウスクリックによるエラーシミュレーションの実行

• ES4440.1/.2 コンパクト故障シミュレーションモジュールのコンフィギュ
レーション設定

－ モジュールの IP アドレスと CAN アドレスの設定

－ 3 種類のシステムステータス（スタンドアロン、マスタ、スレーブ）の選
択

－ ES4440.1/.2 のセルフテスト（自己診断テスト）とヒューズテストの実行

• テストの自動実行のための COM-API

1.1 本書について

本書では、以下の事柄について説明しています。

• 第 1 章 「はじめに」 （5 ページ）

本章です。

• 第 2 章 「LABCAR-PINCONTROL V2.1 の操作方法」 （8 ページ）

LABCAR-PINCONTROL V2.1 の設定方法と操作方法について説明します。

• 第 3 章 「API」 （31 ページ）

ES4440.1/.2 コンパクト故障シミュレーションモジュールの自動テストを行
うための情報です。自動テストには、LABCAR-PINCONTROL V2.1 の COM
コントローラ、または CAN を使用します。

1.2 本書の使用法

1.2.1 表現について

ユーザーが実行するすべてのアクションは、いわゆる “Use-Case” 形式で記述され
ています。つまり以下に示すように、操作を行う目標がタイトルとして最初に簡潔
に定義され、その下に、その目標を実現するために必要な操作手順が列挙されてい
ます。
5LABCAR-PINCONTROL V2.1 - ユーザーズガイド



6

はじめに ETAS
目標の定義：

前置き ...

• 手順 1

手順 1 についての説明 ...

• 手順 2

手順 2 についての説明 ...

• 手順 3

手順 3 についての説明 ...

まとめ ...

具体例：

新しいファイルを作成する：

新しいファイルを作成する際は、他のファイルをすべて閉じておきます。

• File → New コマンドを選択します。

“Create file” ダイアログボックスが開きます。

• 新しいファイルの名前を、“File name” フィールドに
入力します。

ファイル名は 8 文字以内でなければなりません。

• OK をクリックします。

新しいファイルが作成され、ユーザーが指定した名前で保存されます。このファイ
ルを使用して以降の操作を行います。

1.2.2 表記上の規則

本書は以下の規則に従って表記されています。

その他、重要な語や新出の語は太字または斜体、または「 」で囲んで示されていて、
特に重要な注意事項は、以下のように表記されています。

表記例 説明

File → Exit コマンドを選択して、... メニューコマンドは、青の太字で表記し
ます。

OK をクリックして、... ユーザーインターフェース上のボタン名
は、青の太字で表記します。

<Ctrl> を押して、... キーボードの各キーは、< > で囲んで表
記します。

“Open File” ダイアログボックスが
開きます。

プログラムウィンドウ、ダイアログボッ
クス、入力フィールド等のタイトル
は、“ ” で囲んで表記します。

setup.exeファイルを選択します。 リストボックス、プログラムコード、
ファイル名、パス名等のテキスト文字列
は、Courierフォントで表記します。

注記

ユーザー向けの重要な注意事項
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ETAS はじめに
また PDF 文書において、索引、および他の部分を参照する個所（例：「xxxx を参照
してください」と記述された箇所の「xxxx」の部分）については、その参照先への
リンクが設けられているので、必要な参照個所を素早く見つけることができます。
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LABCAR-PINCONTROL V2.1 の操作方法 ETAS
2 LABCAR-PINCONTROL V2.1 の操作方法

本章では、LABCAR-PINCONTROL V2.1 の設定と操作について説明します。

• LABCAR-PINCONTROL V2.1 の設定（8 ページ）

LABCAR-PINCONTROL V2.1 を操作するための準備作業について説明します。

• ワイヤハーネスファイル（12 ページ）

プロジェクトの中核となる「ワイヤハーネスファイル」の作成方法について
説明します。

• LABCAR-PINCONTROL V2.1 の操作（17 ページ）

ユーザーインターフェースを操作してエラーをシミュレートする方法を説明
します。

• メインメニュー（29 ページ）

LABCAR-PINCONTROL V2.1 のメニューコマンドについて説明します。

2.1 LABCAR-PINCONTROL V2.1 の設定

PINCONTROL での作業を始める前に、イーサネット接続と ES4440.1/.2 システムに
ついての設定を行う必要があります。

2.1.1 PC のネットワークインターフェースカードの設定

ES4440.1/.2 コンパクト故障シミュレーションモジュールの操作に使用するネット
ワークインターフェースカードについて、以下の設定を行ってください。

TCP/IP を設定する：

• Windows のスタートメニューから 設定 → コント
ロールパネル を選択します。

• “ コントロールパネル ” ウィンドウの ネットワーク接
続 をダブルクリックします。

• 使用する接続／デバイスを選択します。

• そのエントリを右クリックして プロパティ を選択し
ます。

“ ローカルエリア接続プロパティ ” ダイアログボック
スが開きます。

• “ インターネットプロトコル (TCP/IP)” というコン
ポーネントを選択します。
LABCAR-PINCONTROL V2.1 - ユーザーズガイド
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• プロパティ をクリックします。

“ インターネットプロトコル (TCP/IP) のプロパティ ”
ダイアログボックスが開きます。

• 以下の値を、上図のように設定します。

IP アドレス：192.168.40.240
サブネットマスク：255.255.255.0

IP アドレスは、任意の有効なアドレスを設定すること
ができます。

• OK をクリックしてすべてのウィンドウを閉じます。

2.1.2 イーサネットの設定

本項では、ES4440.1/.2 コンパクト故障シミュレーションモジュールにイーサネット
アドレスを割り当てる方法について説明します。

イーサネットについて設定する：

• LABCAR-PINCONTROL V2.1 のメインメニューから 
Tools → ES4440 Ethernet Configuration を選択し
ます。

• 設定時には設定を行うデバイスしかオンにできないの
で、その旨を通知するメッセージが表示されます。

• OK をクリックします。
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LABCAR-PINCONTROL V2.1 の操作方法 ETAS
• “ES4440 Ethernet Configuration” ダイアログボック
スが開きます。

このダイアログボックスには、イーサネット接続に関
する設定情報（使用する IP アドレスとサブネットマ
スクなど）が表示されます。

• アドレスを変更する場合は “New IP Configuration”
フィールドに新しい値を入力します。

• Download をクリックすると、設定内容がハード
ウェアにダウンロードされます。

または 

• Cancel をクリックすると、変更操作が取り消されて
ダイアログボックスが閉じます。

2.1.3 ES4440.1 のシステム設定

システム設定では、各ハードウェアのステータス（スタンドアロン、マスタ、ス
レーブ）を指定し、さらに、CAN を使用して制御を行う場合は CAN インター
フェースについて設定します。

注記

本項で説明する方法でシステムを設定するには、設定対象のハードウェアがイー
サネット接続されている必要があります。
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• LABCAR-PINCONTROL V2.1 のメインメニューから、

Tools → ES4440 System Configuration を選択しま
す。

“ES4440 System Configuration” ダイアログボックス
が開きます。

ここでは以下の設定を行うことができます。

デバイスを設定する：

• “Devices found” フィールドから、設定の対象とする

ES4440.1/.2 を選択します。

• “Device Configuration” フィールドで、モジュールの
ステータス（Standalone、Master、Slave1、

...Slave14）を選択します。

• 上記以外の項目を変更する必要がない場合は、

Download をクリックします。

ハードウェアの設定変更が実行され、ダイアログボッ
クスが閉じます。

• 他に変更する項目がある場合は、それらを変更し、最
後に上述のように設定変更を実行します。

IP 設定を確認する：

“IP Configuration” フィールドに、現在選択されてい
るハードウェアの IP アドレスとサブネットマスクが
表示されます。

CAN インターフェースを設定する：

• ES4440.1/.2 の制御を CAN インターフェース経由で
行う場合は、“CAN Configuration” の各フィールドで

CAN インターフェースの設定を行います。

－ CAN ID (Transmit to ES4440) dec.

ES4440.1 への送信メッセージにセットするデバ
イス ID を指定します。
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LABCAR-PINCONTROL V2.1 の操作方法 ETAS
－ CAN ID (Receive from ES4440) dec.

ES4440.1 からの送信メッセージにセットするデ
バイス ID を指定します。

－ Baud Rate:

転送速度を指定します。“500 kBaud” から “1 
Mbaud” までの値を選択できます。

－ CAN Termination:

デバイスに CAN ターミネータが取り付けられて
いるかどうかを指定します。

抵抗カスケードについての情報を確認する：

内部抵抗カスケードの実際の抵抗値は “Resistor 
Cascade” フィールドに表示されます。

リレー接点のクリーニングとセルフテストを実行する：

• “Device Tests” フィールドで、モジュールテスト用の
アクションを実行できます。各アクションについての
詳細は、「リレー接点をクリーニングする：」（26
ページ）、「ヒューズをテストする：」（27 ページ）、

「セルフテストを実行する：」（27 ページ）を参照し
てください。

2.2 ワイヤハーネスファイル

ワイヤハーネスファイルは、プロジェクトの中核となる重要なファイルです。この
ファイルには、ES4440.1/.2 コンパクト故障シミュレーションモジュールの各チャン
ネルに接続される ECU シグナルについての情報が設定されます。

つまりこのファイルは、各 ECU チャンネルについて以下のデータが定義されたもの
です。

• ECU Name （ECU の名前）

• Pin Number （ピン番号）

• ES4440 Name （ES4440 の名前）

• Channel Number （チャンネル番号）

上記以外に Pin Name（ピンの名前）も定義されますが、これはピン番号に対する注
釈なので、一意である必要はありません。
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以下の図に示される配線例を用いて、ワイヤハーネスファイルの作成方法を説明し
ます。

この例では、2 台の ECU が 2 台の ES4440.1/.2 に接続されています。

• ECU Name：ECU1/ECU2

• Pin Number：A58/B1

• Pin Name：Engine Temperature / Injector 1

• ES4440 Name：Master / Slave 1

• ES4440 Connector：ECU/LOAD CH43-CH63 / ECU/LOAD CH0-CH42

• ES4440 Pin：G（チャンネル 49） / p（チャンネル 39）

2.2.1 ワイヤハーネスファイルの作成

本項では、製品に付属しているサンプルファイルを使用して、各テーブル（Excel
シート）内に保存されたワイヤハーネスデータをもとに LABCAR-PINCONTROL 
V2.1 用プロジェクトのワイヤハーネスファイルを作成する方法を紹介します。

まず始めに、C:\Documents and Settings\All Users\
Application Data\ETAS\LABCAR-PINCONTROL\2.1\Excel\
LABCAR-PINCONTROLV2.0_Example.xlsというサンプルファイルを開いてく
ださい。

この Excel ファイルは以下の 3 つのテーブル（Excel シート）で構成されています。

• WireHarnessData 

ECU のポートと ES4440 のポートとのマッピングデータを定義します。

• ES4440WireHarnessSignals 

“WireHarnessData” テーブルに定義されたデータを評価するための詳細な情
報を定義します。

• Execute_Example 

このテーブルからマクロを実行して、ES4440 に単純な “Open Load” エラーを発
行させることができます（サンプルプロジェクトでのみ実行可能です）。

b`rO

負荷

E温度センサ） b`rN

負荷

（インジェクタN）
_N（fåÖÉÅíçê=N）

^RU
EbåÖáåÉ=qÉãéÉê~íìêÉF

bpQQQMKN（j~ëíÉê）

bpQQQMKN（pä~îÉ=N）

ピン=d=Z=チャンネル=QV

il^a=
`eQPJ`eSP

b`r
`eQPJ`eSP

il^a
=`eMJ`eQO

b`r
=`eM=J `eQO

il^a=
`eQPJ`eSP

b`r
`eQPJ`eSP

il^a
=`eMJ`eQO

b`r
=`eM=J `eQO

ピン=é=Z=チャンネル=PV
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“WireHarnessData” テーブル

このテーブルに、ECU のポートと ES4440 のポートの割り当てを定義します。

各列に以下の情報を設定します。

• ECU Name 

ECU の名前
（一意の名前を使用してください。）

• Pin Number 

ECU のピン番号
（一意の名前を使用してください。数字以外の文字も使用できます。）

• Pin Name 

接続されるシグナルの名前などの、ECU のピンについての詳細な説明
（一意である必要はありません。）

• ES4440 Name 

ECU のピンに接続される ES4440 の名前
（“ES4440WireHarnessSignals” テーブルの “ES4440 Device Names” に定義
されているデバイス名から選択します。）

• ES4440 Connector 

ECU シグナルを接続する ES4440 のコネクタ
（“ES4440WireHarnessSignals” テーブルの “Connector/Pin/Channel/Electric 
Type” に定義されているコネクタ名から選択します。）

• ES4440 Pin 

ECU シグナルを接続する ES4440 のピンを定義します。
（“ES4440WireHarnessSignals” テーブルの “Connector/Pin/Channel/Electric 
Type” に定義されているピン名から選択します。）

上記の項目を定義すると、このテーブルの各行は以下のマッピングを表すことにな
ります。

<ECU Name> + <Pin Number> (+ <Pin Name>) =
<ES4440 Name> + <ES4440 Connector> + <ES4440 Pin>

この式に示されるように、“Pin Name” は “Pin Number” のコメントとして使用され
るだけなので、必ずしも一意である必要はありません。

ECU のすべてのピンを ES4440.1/.2 に接続したら、ワイヤハーネスファイルのシグ
ナル定義はすべて完了です。
LABCAR-PINCONTROL V2.1 - ユーザーズガイド
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最後に、定義したデータを LABCAR-PINCONTROL V2.1 用の XML ファイルに変換す
るための設定を行います。

データの調整

データを XML ファイルに変換するための設定を行うためには、まず

“ES4440WireHarnessSignals” テーブルを選択します。このテーブルには、マクロを
使用して定義済みワイヤハーネスデータから XML ファイルを生成する際に必要な
データが含まれています。

このテーブルで以下の情報を設定します。

General Settings:

• TableName 

“ECU Name”、“Pin Number”、“Pin Name”、“ES4440 Name”、“ES4440 
Connector”、“ES4440 Pin” のデータが含まれているテーブルの名前

• Start Row 

“WireHarnessData” テーブルの評価開始行

• End Row 

“WireHarnessData” テーブルの評価終了行

Wire Harness Settings:

“WireHarnessData” テーブル内で以下の各情報が定義される列を指定します。

• ECU Name 

ECU の名前

• Pin Number 

ECU のピン番号

• ECU Pin Name 

ECU のピン名
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• ES4440 Name 

ES4440.1/.2 の名前

－ “ES4440 Device Names” グループ（下記参照）に表示されている名前の
いずれかが使用されます。

• ES4440 Connector 

ES4440.1/.2 のコネクタ

－ “Connector/Pin/Channel/Electric Type” グループ（下記参照）に定義され
ているコネクタのいずれかが使用されます。

• ES4440 Pin 

ES4440.1/.2 のコネクタ内のピン

－ “ES4440 Pin” はいずれかの “ES4440 Connector” に属します。

“Connector/Pin/Channel/Electric Type” グループに定義されているピンの
いずれかが使用されます。

XML:

• Full Path 

マクロで生成するワイヤハーネスファイルの名前とパス

ES4440 Device Names:

使用するすべての ES4440.1/.2 の名前

Connector/Pin/Channel/Electric Type:

ES4440.1/.2 のすべてのポートについての定義

ワイヤハーネスファイルの作成

すべての設定が終了したら、以下のようにしてワイヤハーネスファイルを生成しま
す。

ワイヤハーネスファイルを作成する：

• “Execute_Example“ テーブルを選択します。

• Create WireHarnessFile for ES4440 ボタンをク
リックします。

または 

• ツール → マクロ → マクロ ... を選択します。

• “CreateXML” というマクロを選択し、実行 をクリッ
クします。

マクロが正常に実行されると、以下のダイアログボッ
クスが開きます。

注記

背景色が灰色のフィールドの内容は変更しないでください。変更すると、生成さ
れるファイルに不具合が生じたり、ファイルが生成されなくなる可能性がありま
す。
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2.3 LABCAR-PINCONTROL V2.1 の操作 

本項では、LABCAR-PINCONTROL V2.1 のユーザーインターフェースから ES4440.1/
.2 コンパクト故障シミュレーションモジュールを操作する方法を説明します。

• 「LABCAR-PINCONTROL V2.1 を起動する：」（17 ページ）

• 「ワイヤハーネスファイルからシグナルをインポートする：」（18 ページ）

• 「新しい故障セットを作成する：」（19 ページ）

• 「シグナルを追加する：」（20 ページ）

• 「シグナルを削除する：」（21 ページ）

• 「マルチエラーをシミュレートする：」（22 ページ）

• 「接点不良をシミュレートする：」（23 ページ）

• 「接触抵抗をシミュレートする：」（24 ページ）

• 「電流を測定する：」（25 ページ）

• 「リレー接点をクリーニングする：」（26 ページ）

• 「ヒューズをテストする：」（27 ページ）

• 「セルフテストを実行する：」（27 ページ）

• 「表示オプションを設定する：」（27 ページ）

LABCAR-PINCONTROL V2.1 を起動する：

• Windows のスタートメニューから、 プログラム → 
ETAS → LABCAR-PINCONTROL V2.1 → 
PinControl.exe を選択します。

LABCAR-PINCONTROL V2.1 のウィンドウが開きま
す。

LABCAR-PINCONTROL V2.1 のユーザーインターフェースは以下のセクションに分
かれています。
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• Signals

プロジェクト用のワイヤハーネスファイルに定義されたシグナルの一覧が表
示されます（18 ページの「ワイヤハーネスファイルからシグナルをインポー
トする：」を参照してください）。

• Failure Sets

シグナルが割り当てられた「故障セット」（“Failure Set”）の一覧が表示され
ます（19 ページの「新しい故障セットを作成する：」を参照してください）。

• Failure Set

このセクションには、さまざまなタイプのエラーが分類されたタブが含まれ
ます。故障セットを選択し、シグナルをこのセクションに割り当てることよ
り、故障セットのシグナル構成が定義されます。いずれかのタブ上で、シ
ミュレートしたいエラーを設定し、最後にボタンをクリックしてエラーシ
ミュレーションを実行します（22 ページの「マルチエラーをシミュレートす
る：」を参照してください）。

• Application Log

処理ステータスやシステムメッセージが表示されます。

まず始めに、ワイヤハーネスファイルに保存されているシグナルをインポートしま
す。

ワイヤハーネスファイルからシグナルをインポートする：

• “Signals” ウィンドウを右クリックします。

• ショートカットメニューから、Import Signals from 
Wire Harness... を選択します。

ファイル選択ウィンドウが開きます。

• ワイヤハーネス仕様が定義されている XML ファイル
を選択します。ここでは、下図に示されるサンプル
ファイル Standalone.xmlを使用します。

シグナルがインポートされ、“Signals” ウィンドウに
表示されます。
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• Save as コマンドでプロジェクトを保存します。

これで、ECU と ES4440.1/.2 コンパクト故障シミュレーションモジュールの接続に
関する情報がすべてプロジェクトにインポートされました。

次に、1 つ（または複数）の故障セット（“Failure Set”）を作成し、実際に使用するシグ
ナルを定義します。

新しい故障セットを作成する：

• “Failure Sets” ウィンドウを右クリックします。

• ショートカットメニューから Create failure set... を
選択します。

• 作成する故障セットの名前を、下図の例のように入力
します。
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• OK をクリックします。

上図のように入力した場合、“OBDII” という故障セッ
トが作成されます。

• 新しく作成された故障セットをクリックします。

シミュレートできるエラーが、ユーザーインター
フェースの右側の各タブに分類されて表示されます。

次に、シグナルを割り当てて故障セット “OBDII” を完成させます。

シグナルを追加する：

• “Signals” ウィンドウからシグナルを選択します。

• シグナルをタブ上にドラッグ（マウスでクリックし、
ボタンを押し下げたまま移動）します。この際、どの
タブが選択されていてもかまいません。
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• 同じ方法で、必要なシグナルをすべて故障セットに割
り当てます。

• プロジェクトを保存します。

これで、故障セットが定義されたプロジェクトが完成
しました。

同じプロジェクト内に複数の故障セットが必要な場
合、上記の操作を繰り返して故障セットを追加しま
す。

故障セットに割り当てたシグナルを削除するには、以下のように操作します。

シグナルを削除する：

• 不要なシグナルを右クリックします。
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• Remove Signal を選択します。

そのシグナルが故障セットから削除されます。

つまり故障セット内の複数のシグナルについて、異なる種類のエラー1 を同時に発生
させるには、以下のように操作します。このようにして発生させるエラーは「マル
チエラー」と呼ばれます。

マルチエラーをシミュレートする：

• ここでは例として、シグナル “Signal A12”、“Signal 
A48”、“Signal A64” について、断線をシミュレート
する “Open Load” 列のチェックボックスをオンにし
ます。

• シグナル “Signal A55” には +UBatt_A への短絡

“Short against +UBatt_A” を選択します。また、エ
ラー発生時に負荷が接続されたままになるよう
に、“with LOAD (S1)“ をオンにします。

• さらに、シグナル “Signal A9” についても +UBatt_A
への短絡を選択します。

1. 各種エラーについての詳細は、ES4440.1/.2 コンパクト故障シミュレーションモジュー
ルのユーザーズガイドを参照してください。
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• このタブの最下部の “Error Active Time” フィールド
に、エラーの持続時間（エラーをアクティブ状態にし
ておく時間）を入力します。

“-1” を入力すると、Activate Error が再度クリック
されるまでエラー状態が持続されます。

• Activate Error をクリックします。

エラーシミュレーションが実行され、エラーがアク
ティブ状態になります。エラーがアクティブである間
は、タブ上のシグナルの背景色が緑色になります。

“Fast Switch I Errors” タブと “Fast Switch II Errors” タブでは、接点不良によるシグ
ナルのチャタリングをシミュレートすることもできます。この場合、指定された持続
時間にわたってエラーがアクティブのままになるのではなく、所定の周波数とデュー
ティサイクルでアクティブ／非アクティブが切り替わります。

接点不良をシミュレートする：

• ここでは例として “Fast Switch I Errors” タブに切り替
えます。

• エラーを選択します。

• タブの下部にある “Loose Contact” フィールドの

“Activate” オプションをオンにします。

• “Duty Cycle” フィールドにデューティサイクル [%]
を入力します。

• “Frequency” フィールドに周波数 [Hz] を入力します。

注記

タブを切り替えると、切り替える前のタブ上でのエ
ラー設定は解除されます。
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• “Error Active Time” フィールドに接点不良シミュレー
ションの持続時間 [ms] を入力します。

• Activate Error をクリックしてエラーシミュレーショ
ンを実行します。

接触抵抗のエラー（ライン抵抗、ピン間抵抗、バッテリ電圧へのリーク電流）
は、“Fast Switch II Errors” タブを使用します。

接触抵抗をシミュレートする：

• “Fast Switch II Errors” タブでエラーを選択します（図
の例ではライン抵抗）。

• “Resistor Value” フィールドに抵抗値 [Ohm] を入力し
ます。

注記

ピン間エラーをシミュレートする場合は、2 つのシグ
ナルを割り当てる必要があります。
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• “Error Active Time” フィールドにエラーシミュレー
ションの持続時間 [ms] を入力します。

• Activate Error をクリックしてエラーシミュレーショ
ンを実行します。

シグナル線を流れる電流を測定する必要がある場合、“Fast Switch II Errors” タブで、
シグナルをフロントパネルの “Current” コネクタにルーティングすることができま
す。

電流を測定する：

• シグナルを選択します。

• “Error Active Time” フィールドに測定時間 [ms] を入
力します。

• Activate Error をクリックしてエラーシミュレーショ
ンを実行します。
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• 選択されたシグナルが ES4440.1/.2 コンパクト故障シ
ミュレーションモジュールのフロントパネルの

“Current” ポートに接続されるので、このコネクタか
らチャンネルの電流を測定することができます。

酸化したリレー接点のクリーニングを行うには、以下のように操作します。

リレー接点をクリーニングする：

• Tools → ES4440 System Configuration を選択しま
す。

“ES4440 System Configuration” ダイアログボックス
が開きます。

• “Devices found” フィールドから、クリーニングを行
うモジュールを選択します。

• “Device Tests” フィールドの Clean Up Relays をク
リックします。

「クリーニングを行う前には必ずすべての “LOAD” コ
ネクタと “ECU” コネクタからケーブルを取り外して
ください」という旨のワーニングメッセージが表示さ
れるので、その指示に従ってください。

• 次のダイアログボックスで、個々のチャンネルのリ
レー、またはすべてのリレーをクリーニングすること
ができます。

注記

1 回のクリーニングにおいて 10 回のスイッチングが行
われるので、すべてのリレーをクリーニングするには
数分かかる可能性があります。
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エラーレール上の 5 個のヒューズの状態をテストするには、以下のように操作して
ください。

ヒューズをテストする：

• Tools → ES4440 System Configuration を選択しま
す。

“ES4440 System Configuration” ダイアログボックス
が開きます。

• “Devices found” フィールドから、ヒューズテストを
行うモジュールを選択します。

• “Device Tests” フィールドの Check Fuses をクリック
します。

ヒューズテストが実行され、結果が表示されます。

ES4440.1/.2 に内蔵されている PLD、CAN コントローラ、EEPROM の状態を、セルフ
テストによってチェックすることができます。セルフテストを実行するには、以下の
ように操作してください。

セルフテストを実行する：

• Tools → ES4440 System Configuration を選択しま
す。

“ES4440 System Configuration” ダイアログボックス
が開きます。

• “Devices found” フィールドから、以下のアクション
の対象にするモジュールを選択します。

• “Device Tests” フィールドの Self Test をクリックし
ます。

セルフテストが実行され、結果がログウィンドウに表
示されます。

LABCAR-PINCONTROL V2.1 起動時のユーザーインターフェースの表示スタイルや

“Signals” ウィンドウ内のシグナル表示順序は、以下のようにして変更することがで
きます。

表示オプションを設定する：

• Tools  Options... を選択します。

注記

デバイス内のヒューズの位置と仕様については、

ES4440.1/.2 コンパクト故障シミュレーションモ
ジュールのマニュアルを参照してください。
27LABCAR-PINCONTROL V2.1 - ユーザーズガイド



28

LABCAR-PINCONTROL V2.1 の操作方法 ETAS
• “Options” ウィンドウの左側のリストボックスから

“Main Window” オプションを選択します。

• “Startup Mode” フィールドから、メインウィンドウ
の表示スタイルを選択します。

• “normal” を選択した場合は、ウィンドウの幅と高さ
をそれぞれ “Width” と “Height” に設定します。

• “Signal Order” オプションでは、“Signals” ウィンド
ウに表示されるシグナルの表示順（シグナル名、また
はピン番号の順）を指定します。
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2.4 メインメニュー

本項では、PINCONTROL メインメニューについて説明します。

“File” メニュー

• File → New Project 

新しいプロジェクトを作成します。

• File → Open Project... 

保存されているプロジェクトを開きます。

• File → Save Project 

現在ロードされているプロジェクトを保存します。ES4440.1/.2 の設定デー
タ（システム設定とイーサネット設定）や故障セットのデータ（ECU 名、ピ
ン名、ピン番号、）が保存されます。

• File → Save Project As... 

現在ロードされているプロジェクトを新しい名前で保存します。

• File → Exit 

LABCAR-PINCONTROL V2.1 を終了します。

“View” メニュー

• View → Failure Sets Pad

プロジェクトの故障セットが表示されるセクションの表示／非表示を切り替
えます。

• View → Signals Pad

プロジェクトにインポートされたワイヤハーネスファイルのシグナルが表示
されるセクションの表示／非表示を切り替えます。

• View → Application Log

ログウィンドウの表示／非表示を切り替えます。

“Signals” メニュー

• Signals → Import Signals from Wire Harness... 

シグナルデータをワイヤハーネスファイルからインポートします。
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“Tools” メニュー

• Tools → ES4440 System Configuration 

ES4440.1/.2 のシステム設定を行うためのダイアログボックスを開きます。

• Tools → ES4440 Ethernet Configuration 

ES4440.1/.2 のイーサネットインターフェースの設定を行うためのダイアロ
グボックスを開きます。

• Tools → Options... 

表示オプションを定義するためのダイアログボックスを開きます。

“Help” メニュー

• Help → About 

バージョン情報と ETAS の連絡先アドレスを表示するウィンドウを開きます。
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3 API

本章では、LABCAR-PINCONTROL V2.1 の COM コントローラまたは CAN 経由で

ES4440.1/.2 コンパクト故障シミュレーションモジュールを自動的に操作する方法に
ついて説明します。

本章は以下の項に分かれています。

• 「概要」（31 ページ）

• 「CAN メッセージの設定とシーケンス」（32 ページ）

• 「初期設定」（38 ページ）

• 「コマンドの詳細説明」（38 ページ）

3.1 概要

ES4440.1/.2 コンパクト故障シミュレーションモジュールの自動操作は、イーサネッ
トまたは CAN 経由で行えます。イーサネットプロトコルは付属の COM コントロー
ラでサポートされています。CAN プロトコルは、リアルタイムシミュレーション
ターゲットを CAN ボード経由で 1 台または複数の ES4440.1/.2 に接続する場合に使
用されます。

本章には、COM コントローラのメソッド呼び出しと CAN メッセージのデータ構造
が定義されています。

3.1.1 COM コントローラの機能

下図は、システム全体の中での COM コントローラの働きを示しています。

COM コントローラの入力値は、ECU の名前とピンの名前です。COM コントローラ
は、ワイヤハーネスファイルを用いて、これらの名前に ES4440.1/.2 とピン番号を
割り当てます。

さらに、COM コントローラは COM メソッドをイーサネットプロトコルに転送しま
す。また、複数の ES4440 をマスタ／スレーブ構成で使用する場合、COM コント
ローラはコマンドを各モジュールに振り分ける役割も果たします。

bpQQQM ファームウェア

i^_`^oJ
^rqlj^qflk

i^_`^oJ
mfk`lkqoli=sOKM

サードパーティ製ツール

bpQQQM コントローラ

`lj

bpQQQM ファームウェア bpQQQM=ファームウェア

イーサネット
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3.1.2 CAN-API の使用

CAN メッセージは、各 ES4440 モジュールに直接送信されます。ES4440 モジュー
ルが相互に通信することはできないので、ユーザーは以下のことを確実に行う必要
があります。

• ECU の名前およびピンの、ES4440 モジュールへのマッピング

• マスタ／スレーブ操作の場合は、ES4440 モジュールへのコマンド配信

3.1.3 COM-API および CAN-API のデータ内容

COM コントローラへの入力データとして ECU の名前とピン名が必要ですが、CAN-
API の場合は ES4440 モジュールのピン番号が必要です。この点を除けば、COM-
API と CAN-API のデータ内容はまったく同じです。

3.2 CAN メッセージの設定とシーケンス

本項では、各 ES4440 モジュールへの CAN メッセージ配信について説明します。

ES4440 でさまざまなタイプのエラーをミュレートする際のコマンドシーケンスを紹
介し、さらに複数の ES4440 モジュールに CAN メッセージを送信する手順について
も紹介します。

エラーシミュレーションの実行には、一般に、以下のルールが適用されます。

• リレー（メカニカルリレー）を用いてシミュレートされるエラーの場合、エ
ラーのアクティブ化は常にマスタモジュールにより行われます。このため、
全 ES4440 モジュールにおいてエラーのオン／オフ切り替えが確実に同期し
て行われます。

• MOSFET（半導体リレー）を用いるエラーの場合は、そのエラーをシミュ
レートするモジュール自身によってエラーがアクティブ化されます。

• エラーを発生させるコマンドを ES4440 モジュールに送信した後は、エラー
のリセットコマンドを発行してエラー状態を解除する必要があります。

• ピン間エラーは例外的なエラーなので、他のエラーとは別に扱われます。

注記

マスタ／スレーブ構成について紹介しているシナリオの内容は、一例です。ここ
で “Slave 1” 上で実行されるものとして示されているコマンドは、実際にはマス
タや他のスレーブでも同じように実行できます。
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3.2.1 スタンドアロン構成におけるシングルエラーのシミュレーション

まず始めに、1 台の ES4440.1/.2 コンパクト故障シミュレーションモジュール上で
シングルエラー（単一のエラー）を発生させるためコマンドシーケンスの例を紹介
します。

リレーを用いたエラーを発生させるシーケンス

1. エラー設定 
高電流エラー：

以下のいずれかのコマンドを発行します。

－ Open_Load 

－ ShortCut_xUBATTy_20A 

－ Pin2PinFirstChWithoutLoad / 
Pin2PinSecondChWithoutLoad 

高電圧エラー：

以下のいずれかのコマンドを発行します。

－ Open_Load_400V 

－ ShortCut_xUBATTy_400V 

－ Pin_2_Pin_400V 

2. エラーのアクティブ化

－ Activate_relay 

3. エラーのリセット

－ Reset_all_errors  

MOSFET を用いたエラーを発生させるシーケンス

1. エラー設定 
以下のいずれかのコマンドを発行します。

－ Open_Load_realtime 

－ ShortCut_xUBATTy_20A_realtime 

－ Pin2PinFirstChRelatimeWithLoad 

－ Pin2PinSecondChRealtimeWithLoad 

－ RInline_realtime 

－ Pullup_Pulldown_xUBATTy_20A_realtime 

2. エラーのアクティブ化

－ Activate_realtime_switch 

3. エラーのリセット

－ Reset_all_errors

ホストm`

bpQQQM
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3.2.2 スタンドアロン構成におけるマルチエラーのシミュレーション

1 台の ES4440.1/.2 コンパクト故障シミュレーションモジュール上でマルチエラー
（複数のエラー）を発生させるためのコマンドシーケンスの例をあげます。

リレーを用いたエラーを発生させるシーケンス

1. エラー設定 
以下のコマンド（高電流エラーの設定）を、任意に組み合わせて最大 10 個
まで ES4440.1/.2 に送信できます。

－ Open_Load 

－ ShortCut_xUBATTy_20A 

2. エラーのアクティブ化

－ Activate_relay 

3. エラーのリセット

－ Reset_all_errors 

3.2.3 マスタ／スレーブ構成におけるシングルエラーのシミュレーション

マスタ／スレーブシステム上でシングルエラー（単一のエラー）をシミュレートす
るためのコマンドシーケンスの例を紹介します。

リレーを用いたエラーを発生させるシーケンス

1. エラー設定（スレーブ 1）

以下のコマンド（高電流エラーの設定）を、任意に組み合わせて最大 10 個
まで ES4440.1/.2 に送信できます。

－ Open_Load 

－ ShortCut_xUBATTy_20A 

2. エラーのアクティブ化（マスタ）

－ Activate_relay

ホストm`

bpQQQM

bpQQQM
マスタ

bpQQQM
スレーブ N

bpQQQM
スレーブ O

標準スイッチ ／ bpSMM

ホストm`
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3. エラーのリセット（スレーブ 1）*
－ Reset_all_errors 

4. エラーのリセット（マスタ）**
－ Reset_all_errors

* スレーブに “Reset_all_errors” コマンドを送信すると、スレーブ上ではコマンドの
セーブのみが行われます。

** マスタへの “Reset_all_errors” コマンドにより、マスタ上のエラーと、リセット
コマンドがセーブされているすべてのスレーブ上のエラーが、同期してリセットさ
れます。

MOSFET を用いたエラーを発生させるシーケンス

1. エラー設定

以下のいずれかのコマンドを発行します。

－ Open_Load_realtime 

－ ShortCut_xUBATTy_20A_realtime 

－ RInline_realtime 

－ Pullup_Pulldown_xUBATTy_20A_realtime 

2. エラーのアクティブ化

－ Activate_realtime_switch 

3. エラーのリセット 
－ Reset_all_errors

bpQQQM
マスタ

bpQQQM
スレーブ N

bpQQQM
スレーブ O

標準スイッチ ／ bpSMM

ホストm`
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特殊なケース：ピン間エラー（負荷あり）

1. 第 1 のピンのエラー設定（スレーブ 1）

－ Pin2PinFirstChRelatimeWithLoad 

2. 第 2 のピンのエラー設定（スレーブ 2）

－ Pin2PinSecondChRealtimeWithLoad 

3. エラーのアクティブ化（スレーブ 1）

－ Activate_realtime_switch 

4. エラーのリセット（スレーブ 1）

－ Reset_all_errors 

5. エラーのリセット（スレーブ 2）

－ Reset_all_errors 

特殊なケース：ピン間エラー（負荷なし）

1. 第 1 のピンのエラー設定（スレーブ 1）

－ Pin2PinFirstChWithoutLoad  

2. 第 2 のピンのエラー設定（スレーブ 2）

－ Pin2PinSecondChWithoutLoad 

3. エラーのアクティブ化（マスタ）

－ Activate_relay 

4. エラーのリセット（スレーブ 1）

－ Reset_all_errors 

5. エラーのリセット（スレーブ 2）

－ Reset_all_errors 

bpQQQM
マスタ

bpQQQM
スレーブ N

bpQQQM
スレーブ O

標準スイッチ ／ bpSMM

ホストm`
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スレーブ N

bpQQQM
スレーブ O

標準スイッチ ／ bpSMM

ホストm`
LABCAR-PINCONTROL V2.1 - ユーザーズガイド



ETAS API
6. エラーのリセット（マスタ）

－ Reset_all_errors 

3.2.4 マスタ／スレーブ構成におけるマルチエラーのシミュレーション

マスタ／スレーブシステム上でマルチエラー（複数のエラー）をシミュレートする
ためのコマンドシーケンスの例を紹介します。

リレーを用いたエラーを発生させるシーケンス

1. エラー設定（スレーブ 1）

以下のコマンド（高電流エラーの設定）を、任意に組み合わせて最大 10 個
まで ES4440.1/.2 に送信できます。

－ Open_Load 

－ ShortCut_xUBATTy_20A 

2. エラー設定（スレーブ 2）

スレーブ 1 と同様に高電流エラーを設定します。

－ Open_Load 

－ ShortCut_xUBATTy_20A 

3. エラーのアクティブ化（マスタ）

－ Activate_relay 

4. エラーのリセット（スレーブ 1）

－ Reset_all_errors 

5. エラーのリセット（スレーブ 2）

－ Reset_all_errors 

6. エラーのリセット（マスタ）

－ Reset_all_errors 

注記

ピン間エラーのオン／オフ切り替えはリレーにより行われます。第 1 のピンと第

2 のピンの間のエラー経路にはヒューズはありません。

bpQQQM
マスタ

bpQQQM
スレーブ N

bpQQQM
スレーブ O

標準スイッチ ／ bpSMM

ホストm`
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3.3 初期設定

3.3.1 COM コントローラの初期設定

COM コントローラの初期設定は以下のように行います。

Dim returnValue As Integer

Dim WireharnessPath As String

'access CommCtrlAccess

Set ctrla = CreateObject

("ETAS.PTS.PINCONTROLV2.CommCtrl.CommCtrlAccess")

'using CommCtrlAccess class you can try to access the 
singleton instance

Set ctrl = ctrla.CommCtrlInstanceinstance

Set ctrl = ctrla.CommCtrlInstance

returnValue = 
ctrl.InitErrorSimulationUsingFile(WireharnessPath)

“Exit” は以下のように行います。

'free CommCtrl Singleton instance

    Call ctrla.FreeCommCtrlInstance

3.3.2 CAN を使用する場合の初期設定

CAN については初期設定は必要ありません。

3.4 コマンドの詳細説明

本項では、以下の全コマンドについて、機能と構文を説明します。

• IDN コマンド（42 ページ）

• Open_Load（43 ページ）

• Open_Load_realtime（44 ページ）

• ShortCut_xUBATTy_20A（45 ページ）

• ShortCut_xUBATTy_20A_realtime（46 ページ）

• Pin2PinFirstChWithoutLoad（47 ページ）

• Pin2PinSecondChannelWithoutLoad（48 ページ）

• Pin2PinFirstChRealtimeWithLoad（49 ページ）

• Pin2PinSecondChRealtimeWithLoad（50 ページ）

• RInline_realtime（51 ページ）

• Pullup_Pulldown_xUBATTy_20A_realtime（53 ページ）

• Open_Load_400V（54 ページ）

• ShortCut_xUBATTy_400V（55 ページ）

• ShortCut_xUBATTy_400V_Ex（56 ページ）

• Pin_2_Pin_400V（57 ページ）

注記

COM コントローラは、一度に 1 つのアプリケーションでしか使用できません。
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• Pin_2_Pin_400V_Ex（58 ページ）

• Reset_all_errors（59 ページ）

• Activate_relay（60 ページ）

• Activate_realtime_switch（62 ページ）

• TestFuses（64 ページ）

• CurrentMeasurement（65 ページ）

3.4.1 CAN コマンドの構造

本項の各コマンドの説明においては、CAN 送信メッセージと CAN 受信メッセージ
の構造が以下の形式で示されています。

CAN 送信メッセージ

表 3-1 送信メッセージの構造

CAN 受信メッセージ

表 3-2 受信メッセージの構造

COM コマンド（引数 )

第 1 バイト コマンド ID 値

第 2 バイト パラメータ 0 値

第 3 バイト パラメータ 1 値

第 4 バイト パラメータ 2 値

第 5 バイト パラメータ 3 値

第 6 バイト パラメータ 4 値

第 7 バイト パラメータ 5 値

第 8 バイト パラメータ 6 値

応答

第 1 バイト コマンド ID 値

第 2 バイト パラメータ 0 値

第 3 バイト パラメータ 1 値

第 4 バイト パラメータ 2 値

第 5 バイト パラメータ 3 値

第 6 バイト パラメータ 4 値

第 7 バイト パラメータ 5 値

第 8 バイト パラメータ 6 値

注記

ES4440.1/.2 でバッファオーバフローが発生するのを防ぐため、CAN メッセージ
はシングルショットモードでのみ送信するようにしてください。
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3.4.2 全コマンドに共通する情報

以下に全コマンドに共通する情報について説明します。

チャンネル番号

高電流チャンネルには 0 ～ 63 の番号が付き、高電圧チャンネルには 0 ～ 15 の番号
が付きます。

CAN 送信メッセージのパラメータ 1 の定義

パラメータ 1（第 3 バイト）は以下のビット構成です。コマンドに応じて必要な
ビットを設定します。

3.4.3 エラーコード

下記のエラーコードは受信メッセージの第 8 バイトで転送されます。また API コマ
ンド GetLastErrorSimulationAnswer()の場合も第 8 バイトでエラーコー
ドが転送されます。

ビット 0 load 1：負荷ありのエラーシミュレーション

0：負荷なしのエラーシミュレーション

ビット 1
ビット 2
ビット 3

xUBatty 0：+UBatt_A
1：-UBatt_A
2：+UBatt_B
3：-UBatt_B
4：+UBatt_C
5：-UBatt_C

ビット 4 current 0：電流測定オフ

1：電流測定オン

ビット 5 set 1：エラーセット（エラーをアクティブにする）

0：エラーリセット

ビット 6 duration_flag 0：エラー状態を無期限に（リセットされるまで）持続
します。

1：エラーの持続時間は “duration_time” で指定されま
す。

ビット 7 不使用

結果 意味

0x0 コマンド OK
0x21 スレーブアドレス用パラメータが不正（> 16）

0x22 未定義コマンド

0x23 フラッシュ書き込み時に不正なデータ型を検出

0x24 LED テスト用パラメータが不正

0x25 IP アドレスの値が不正（正しい値： < 256）

0x26 CAN ボーレート用パラメータが不正

0x27 CAN ターミネータ用パラメータが不正

0x28 CAN 識別子タイプ用パラメータが不正

0x29 カスケードチャンネル用パラメータの値が大き過ぎる（正しい値： < 15）

0x2a レジスタカスケード用パラメータが不正

0x2b （未使用）
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0x2c フラッシュリードアクセスのアドレスが不正（正しいアドレス： < 513）

0x2d フラッシュリードアクセスのデータ長が不正（正しいデータ長： < 17）

0x2e フラッシュライトアクセスのアドレスが不正（正しいアドレス： < 513）

0x2f フラッシュライトアクセスのデータ長が不正（正しいデータ長： < 17）

0x30 PLD エラー

0x31 EEPROM チェックサムエラー

0x32 CAN コントローラにアクセスできない

0x41 シミュレーションコマンドから妥当性エラーが返った

0x42 リファレンスリレーが検出できない

0x43 無期限のエラー発生が要求されているのに関わらず "duration_time" の
値が "0xFFFF" でない

0x44 シミュレーションコマンドが認識できない

0x45 PLD エラー： コマンドが実行できない

0x46 "duration time“ の値が有効範囲を超えている（正しい値： 1 ～ 5000, 
0xFFFF)

0x47 別のエラーシミュレーションがまだアクティブになっているので、
Reset_all_errors で終了させる必要がある

0x48 リレーの最大数に達している

0x49 マルチエラーフラグのエラー

0x4a 指定のチャンネル番号が有効範囲を超えている

0x4b 周波数または周期が有効範囲を超えている

0x4c システム温度 > 60 ℃

0x4d レジスタカスケードの温度 > 60 ℃

0x4e MOSFET の温度 > 60 ℃

0x4f システム温度センサの故障

0x50 レジスタカスケード温度センサの故障

0x51 MOSFET 温度センサの故障

0x52 レール電圧異常（短絡の可能性あり）

0x53 抵抗値が無効

結果 意味
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3.4.4 IDN コマンド

ES4440.1/.2 を識別するためのコマンドです。

COM コントローラへのコマンド 送信

int ctrl.CommandIDN(string deviceKey);

“deviceKey” の値：Standalone, Master, Slave1, ..., Slave14

COM コントローラからの応答の取得

byte[] Answer =

ctrl.GetLastSystemConfigurationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

* Device Config” の値：

• Standalone：255

• Master：0

• Slave 1 ～ Slave 14：1 ～ 14

IDN コマンド

第 1 バイト コマンド ID 0x0

第 2 バイト パラメータ 0 不使用

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x0

第 2 バイト パラメータ 0 Device Config - バイト 1 *

第 3 バイト パラメータ 1 Device Config - バイト 0 *

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.5 Open_Load 

ECU と負荷の間のラインを遮断するエラーを設定します。このエラーは、リレーに
よりオン／オフ切り替えが行われます。最大 10 個のエラーを同時にオン／オフする
ことができ、コマンド応答内の “channels left” の値によって、あといくつのチャン
ネルが使用可能であるかがわかります。

COM コントローラへのコマンド 送信

int ctrl.OpenLoad(string ecu, string ecuPin,

int durationType, int set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Open_Load (channel_nr, duration_flag, set)

第 1 バイト コマンド ID 0x1

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 set, duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x1

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 channels left

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.6 Open_Load_realtime

ECU と負荷の間のラインを遮断するエラーを設定します。このエラーは MOSFET に
よりオン／オフ切り替えが行われ、シングルエラーとしてのみシミュレートできま
す。

COM コントローラへのコマンド 送信

int ctrl.OpenLoad_RealTime(string ecu,

string ecuPin, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Open_Load_realtime (channel_nr, duration_flag)

第 1 バイト コマンド ID 0x2

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x2

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.7 ShortCut_xUBATTy_20A

高電流チャンネルについて、バッテリ電圧へのラインの短絡について設定します。
このエラーは、リレーによりオン／オフ切り替えが行われ、複数のチャンネルで同
時にシミュレートすることができます。

COM コントローラへのコマンド 送信 

int ctrl.Shortcut_xUBATTy_20A(string ecu, 

string ecuPin, int load, int xUBATTy,

int durationType, int set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

ShortCut_xUBATTy_20A (channel_nr, load, xUBATTy, duration_flag, set)

第 1 バイト コマンド ID 0x3

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 load, xUBatty, set, duration_flag（40 ページ参
照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x3

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 channels left

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.8 ShortCut_xUBATTy_20A_realtime 

高電流チャンネルについて、バッテリ電圧へのラインの短絡について設定します。こ
のエラーは MOSFET によりオン／オフ切り替えが行われ、シングルエラーとしてのみ
シミュレートできます。

COM コントローラへのコマンド 送信

int ctrl.Shortcut_xUBATTy_20A_RealTime 

(string ecu, string ecuPin, int load, 

int xUBATTy, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

ShortCut_xUBATTy_20A_realtime (channel_nr, load, xUBATTy, 
duration_flag)

第 1 バイト コマンド ID 0x4

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 load, xUBatty, duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x4

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.9 Pin2PinFirstChWithoutLoad 

2 本のライン間の短絡について、第 1 のラインを定義します。第 2 のライン
は、“Pin2PinSecondChannelWithoutLoad” コマンドで定義します（48 ページを参照し
てください）。

COM コントローラへのコマンド 送信

int ctrl.Pin2PinChannel1_WithoutLoad(string ecu,

string ecuPin, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

注記

このエラーはリレーによってオン／オフ切り替えが行われ、負荷や抵抗なしでシ
ミュレートされます。2 本のピン間にはヒューズはありません。

Pin2PinFirstChWithoutLoad (channel_nr1, duration_flag)

第 1 バイト コマンド ID 0x5

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x5

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.10 Pin2PinSecondChannelWithoutLoad 

ライン間短絡の第 2 のラインを定義します。

COM コントローラへのコマンド 送信

int ctrl.Pin2PinChannel2_WithoutLoad(string ecu,

string ecuPin, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

注記

このエラーはリレーによってオン／オフ切り替えが行われ、負荷や抵抗なしでシ
ミュレートされます。2 本のピンの間にはヒューズはありません。

Pin2PinSecondChannelWithoutLoad (channel_nr1, duration_flag)

第 1 バイト コマンド ID 0x6

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 2

第 3 バイト パラメータ 1 duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x6

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 2

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.11 Pin2PinFirstChRealtimeWithLoad 

2 本のライン間で発生する、負荷と有限抵抗を伴う短絡について、第 1 のラインを
定義します。

このエラーは、MOSFET によってオン／オフ切り替えが行われます。

COM コントローラへのコマンド 送信 

int ctrl.Pin2PinChannel1_RealTime_WithLoad

(string ecu, string ecuPin, int resistor, 

int current, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Pin2PinFirstChRealtimeWithLoad (channel_nr1, duration_flag)

第 1 バイト コマンド ID 0x7

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 current, duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 抵抗値 - バイト 0

第 6 バイト パラメータ 4 抵抗値 - バイト 1

第 7 バイト パラメータ 5 抵抗値 - バイト 2

第 8 バイト パラメータ 6 抵抗値 - バイト 3

応答

第 1 バイト コマンド ID 0x7

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.12 Pin2PinSecondChRealtimeWithLoad 

ライン間の負荷と有限抵抗を伴う短絡について、第 2 のラインを定義します。

このエラーは、MOSFET によってオン／オフ切り替えが行われます。

COM コントローラへのコマンド 送信 

int ctrl.Pin2PinChannel2_RealTime_WithLoad

(string ecu, string ecuPin, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Pin2PinSecondChRealtimeWithLoad (channel_nr2, duration_flag)

第 1 バイト コマンド ID 0x8

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 2

第 3 バイト パラメータ 1 duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x8

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 2

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用
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3.4.13 RInline_realtime

MOSFET を用いたライン抵抗の切り替えについて設定します。

COM コントローラへのコマンド 送信 

int ctrl.RInline_RealTime(string ecu1, 

string ecuPin1, int resistor,

int current, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

* バイトオーダーは Motorola フォーマットに対応しています。

Byte n (LSB)

Byte n+1

Byte n+2

Byte n+3 (MSB)

したがって、抵抗値が 0x1234 である場合は以下のように設定します。

Byte n 0x34 (LSB)

Byte n+1 0x12

Byte n+2

Byte n+3 (MSB)

CAN 受信メッセージ

RInline_realtime (channel_nr1, resistor, duration_flag, current)

第 1 バイト コマンド ID 0x9

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 current, duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 抵抗値 - バイト 0 * （LSB）

第 6 バイト パラメータ 4 抵抗値 - バイト 1 *

第 7 バイト パラメータ 5 抵抗値 - バイト 2 *

第 8 バイト パラメータ 6 抵抗値 - バイト 3 * （MSB）

応答

第 1 バイト コマンド ID 0x9

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用
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第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果

応答
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3.4.14 Pullup_Pulldown_xUBATTy_20A_realtime 

チャンネルを抵抗（プルアップ／プルダウン）経由でバッテリ電圧に接続します。

COM コントローラへのコマンド 送信 

int ctrl.PullUp_PullDown_20A_RealTime

(string ecu, string ecuPin, int load, int xUBATTy,

int resistor, int current, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

* バイトオーダーについては、51 ページの「RInline_realtime」の項を参照してくだ
さい。

CAN 受信メッセージ

Pullup_Pulldown_xUBATTy_20A_realtime (channel_nr, load, xUBATTy, 
resistor, duration_flag, current)

第 1 バイト コマンド ID 0xB

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 xUBatty, current, duration_flag, load（40 ペー
ジ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 抵抗値 - バイト 0 *（LSB）

第 6 バイト パラメータ 4 抵抗値 - バイト 1 *

第 7 バイト パラメータ 5 抵抗値 - バイト 2 *

第 8 バイト パラメータ 6 抵抗値 - バイト 3 *（MSB）

応答

第 1 バイト コマンド ID 0xB

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.15 Open_Load_400V 

ECU と負荷の間の高電圧ラインの遮断について設定します。

このエラーは、リレーによってオン／オフ切り替えが行われ、シングルエラーとし
てのみシミュレートできます。

COM コントローラへのコマンド 送信 

int ctrl.OpenLoad_400V(string ecu, string ecuPin,

int durationType, int set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Open_Load_400V (channel_nr, set, duration_flag)

第 1 バイト コマンド ID 0xD

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 duration_flag, set（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0xD

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.16 ShortCut_xUBATTy_400V 

高電圧チャネルのバッテリ電圧への短絡を設定します。このエラーは、リレーに
よってオン／オフ切り替えが行われ、負荷なしのシングルエラーとしてのみシミュ
レートできます。

COM コントローラへのコマンド 送信 

int ctrl.ShortCut_xUBATTy_400V 

(string ecu, string ecuPin, int xUBATTy,  

int durationType, int set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

ShortCut_xUBATTy_400V (channel_nr,  xUBATTy, set, duration_flag)

第 1 バイト コマンド ID 0xE

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 xUBATTy, duration_flag, set（40 ページ参照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0xE

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
55LABCAR-PINCONTROL V2.1 - ユーザーズガイド



56

API ETAS
3.4.17 ShortCut_xUBATTy_400V_Ex 

高電圧チャネルのバッテリ電圧への短絡を設定します。このエラーは、リレーに
よってオン／オフ切り替えが行われ、シングルエラーとしてのみシミュレートでき
ます。負荷あり／負荷なしを選択できます。

COM コントローラへのコマンド 送信 

int ctrl.ShortCut_xUBATTy_400V_Ex

(string ecu, string ecuPin, int xUBATTy, 

int load, int durationType, int set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

ShortCut_xUBATTy_400V_Ex (channel_nr,  load, xUBATTy, set, 
duration_flag)

第 1 バイト コマンド ID 0xE

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 load, xUBATTy, duration_flag, set（40 ページ参
照）

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0xE

第 2 バイト パラメータ 0 ES4440 のチャンネル番号

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.18 Pin_2_Pin_400V 

2 つの高電圧チャンネル間の短絡（負荷なし）を設定します。

このエラーは、リレーによってオン／オフ切り替えが行われ、負荷なしのシングル
エラーとしてのみシミュレートできます。

COM コントローラへのコマンド 送信 

int ctrl.Pin2Pin_400V

  (string ecu1, string ecuPin1, string ecu2, 

string ecuPin2, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Pin_2_Pin_400V (channel_nr1,  channel_nr2, duration_flag)

第 1 バイト コマンド ID 0xF

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 ES4440 のチャンネル番号 2

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0xF

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 ES4440 のチャンネル番号 2

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
57LABCAR-PINCONTROL V2.1 - ユーザーズガイド



58

API ETAS
3.4.19 Pin_2_Pin_400V_Ex 

2 つの高電圧チャンネル間の短絡を設定します。

このエラーは、リレーによってオン／オフ切り替えが行われ、シングルエラーとし
てのみシミュレートできます。負荷あり／負荷なしを選択できます。

COM コントローラへのコマンド 送信 

int ctrl.Pin2Pin_400V_Ex

 (string ecu1, string ecuPin1, string ecu2, 

string ecuPin2, int load, int durationType);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Pin_2_Pin_400V (channel_nr1,  channel_nr2, duration_flag)

第 1 バイト コマンド ID 0xF

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 load, duration_flag（40 ページ参照）

第 4 バイト パラメータ 2 ES4440 のチャンネル番号 2

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0xF

第 2 バイト パラメータ 0 ES4440 のチャンネル番号 1

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 ES4440 のチャンネル番号 2

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.20 Reset_all_errors 

ES4440.1/.2 コンパクト故障シミュレーションモジュール上のすべてのエラーをリ
セットします。

COM コントローラへのコマンド 送信 

int ctrl.ResetAllErrors();

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

Reset_all_errors ()

第 1 バイト コマンド ID 0x10

第 2 バイト パラメータ 0 不使用

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x10

第 2 バイト パラメータ 0 不使用

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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3.4.21 Activate_relay 

所定の時間だけリレーをクローズさせ、設定済みエラーをアクティブにします。

すでに発行されているエラー設定用コマンドで “duration_flag”（第 3 バイトのビット

6）がセットされている場合（“duration_flag”= 1）は、“duration_time” に 20ms ～

5s の範囲内の値を設定します。“duration_flag” = 0 の場合は、“duration_time” の値
を -1 または 65535（0xFFFF）に設定する必要があります。

リファレンスリレーで測定されたスイッチング遅延時間が、コマンド応答として返
信されます。

COM コントローラへのコマンド 送信 

int ctrl.ActivateRelay(int durationTime);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

“duration_time” パラメータには、20ms ～ 5000ms の範囲内の値（ただし 20ms の
倍数）を設定します。

値を 0xFFFF にすると、エラーが無期限でアクティブになります。

“channel_type” パラメータには以下のいずれかの値を設定します。

• 0：高電流チャンネル

• 1：高電圧チャンネル

CAN 受信メッセージ

注記

マルチエラーを設定する場合は、必ず、すべてのエラーの “duration_flag” パラ
メータの値を同じにしてください。

Activate_relay (duration_ time)

第 1 バイト コマンド ID 0x12

第 2 バイト パラメータ 0 不使用

第 3 バイト パラメータ 1 duration_time [ms] - バイト 0

第 4 バイト パラメータ 2 duration_time [ms] - バイト 1

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x12

第 2 バイト パラメータ 0 delay_time0 
20A の NO リレー * のクローズ時間（100 μs 単位）

第 3 バイト パラメータ 1 delay_time1 
20A の NO リレー * のクローズ時間（100 μs 単位）
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第 4 バイト パラメータ 2 delay_time0 
20A の NC リレー ** のオープン時間（100 μs 単位）

第 5 バイト パラメータ 3 delay_time1 
20A の NC リレー ** のオープン時間（100 μs 単位）

第 6 バイト パラメータ 4 delay_time0 
400V の NC リレー ** のクローズ時間（100 μs 単位）

第 7 バイト パラメータ 5 delay_time1 
400V の NC リレー ** のクローズ時間（100 μs 単位）

第 8 バイト パラメータ 6 コマンドの実行結果

* NO = Normally Open（ノーマリーオープン）

** NC = Normally Closed（ノーマリークローズ）

応答
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3.4.22 Activate_realtime_switch 

MOSFET によるエラースイッチをクローズさせ、設定済みエラーをアクティブにし
ます。

すでに発行されているエラー設定用コマンドで “duration_flag”（第 3 バイトのビット

6）がセットされている場合（“duration_flag”= 1）は、“duration_time” に 1ms ～

5s の範囲内の値を設定します。“duration_flag” = 0 の場合は、“duration_time” の値
を -1 または 65535（0xFFFF）に設定する必要があります。

COM コントローラへのコマンド 送信 

int ctrl.ActivateRealTimeSwitch(int mode, 

int durationTime, int dutyCycle, int frequency);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

“duration_time” パラメータには、1ms ～ 5000ms の範囲内で 1ms 単位の値を指定
します。値を 0xFFFF にすると、エラーが無期限にアクティブ状態となります。

接点不良シミュレーションを行わない場合は、パラメータ 4、5、6 の値を 0xFF に
してください。

“mode” パラメータには以下のいずれかの値を設定します。

• 0：静的エラー。エラー持続時間は “duration_time” により定義されます。

• 1：接点不良シミュレーション。

デューティサイクルの値には、周波数に応じて以下の制限があります。
周波数 3Hz ～ 100Hz の場合：1 ～ 99％、2Hz の場合： 50％

CAN 受信メッセージ

Activate_realtime_switch (mode, duration_time, dutycycle, frequency)

第 1 バイト コマンド ID 0x13

第 2 バイト パラメータ 0 mode

第 3 バイト パラメータ 1 duration_time - バイト 0

第 4 バイト パラメータ 2 duration_time - バイト 1

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 接点不良発生のデューティサイクル

第 7 バイト パラメータ 5 接点不良発生の周波数 - バイト 0

第 8 バイト パラメータ 6 接点不良発生の周波数 - バイト 1

応答

第 1 バイト コマンド ID 0x13

第 2 バイト パラメータ 0 mode

第 3 バイト パラメータ 1 duration_time - バイト 0

第 4 バイト パラメータ 2 duration_time - バイト 1

第 5 バイト パラメータ 3 duration_time - バイト 2
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第 6 バイト パラメータ 4 duration_time - バイト 3

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果

応答
63LABCAR-PINCONTROL V2.1 - ユーザーズガイド



64

API ETAS
3.4.23 TestFuses

エラーレール用のヒューズのステータスを取得します。

COM コントローラへのコマンド 送信 

int ctrl.TestFuses(string deviceKey, 
out int[] fuses);

ヒューズのステータスは、fuses という配列に格納されます。fuses[n] にヒューズ

n+1（n = 0 ～ 4）のステータスが格納され、ステータスが 1 なら「ヒューズは正
常」、0 なら「ヒューズは不良」です。

“deviceKey” には、Standalone, Master, Slave1, ..., Slave14 のいずれかの値を設定
します。

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

各ヒューズのステータスは、Fuse_status の下記の各ビットに格納されます。

（各ビットの値 = 0： 不良、1：正常）

IDN コマンド

第 1 バイト コマンド ID 0x14

第 2 バイト パラメータ 0 不使用

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x14

第 2 バイト パラメータ 0 Fuse_status

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果

MSB LSB

ビット 8 ビット 7 ビット 6 ビット 5 ビット 4 ビット 3 ビット 2 ビット 1
- - - E5 E1 E3 E4 E2
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3.4.24 CurrentMeasurement 

ES4440.1/.2 コンパクト故障シミュレーションモジュールのフロントパネルにある

“Current” コネクタにチャンネルを接続し、電流を測定できるようにします。

COM コントローラへのコマンド 送信 

int ctrl.CurrentMeasurement

(string ecu, string ecuPin, byte set);

COM コントローラからの応答の取得

byte[] Answer = ctrl.GetLastErrorSimulationAnswer();

CAN 送信メッセージ

CAN 受信メッセージ

CurrentMeasurement (channel_nr)

第 1 バイト コマンド ID 0x15

第 2 バイト パラメータ 0 channel_nr

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 不使用

応答

第 1 バイト コマンド ID 0x15

第 2 バイト パラメータ 0 channel_nr

第 3 バイト パラメータ 1 不使用

第 4 バイト パラメータ 2 不使用

第 5 バイト パラメータ 3 不使用

第 6 バイト パラメータ 4 不使用

第 7 バイト パラメータ 5 不使用

第 8 バイト パラメータ 6 コマンドの実行結果
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4 お問い合わせ先

製品に関するご質問等は、各地域の ETAS 支社までお問い合わせください。

ETAS 本社

ETAS GmbH

日本支社

イータス株式会社

その他の支社

上記以外の各国支社につきましては、ETAS ホームページをご覧ください。

Borsigstrasse 14 Phone: +49 711 89661-0

70469 Stuttgart Fax: +49 711 89661-106

Germany WWW: www.etas.com/

〒 220-6217 Phone: (045) 222-0900

神奈川県横浜市西区 Fax: (045) 222-0956

みなとみらい 2-3-5 E-mail: sales.jp@etas.com （営業窓口）

クイーンズタワー C 17F WWW: www.etas.com/

各国支社 WWW: www.etas.com/ja/contact.php

技術サポート WWW: www.etas.com/ja/hotlines.php

http://www.etas.com/
http://www.etas.com/ja/contact.php
http://www.etas.com/ja/hotlines.php
http://www.etas.com/
http://www.etas.com/
http://www.etas.com/
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