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ETAS はじめに
1 はじめに

本書は、自動車用 ECU の開発とテストに従事されているユーザーの方を対象として
います。本書をお読みになる際は、計測、および ECU テクノロジーの分野に関する
専門知識が必要となります。

1.1 本書について

本書には LABCAR-OPERATOR V5.4.0 を初めて使用する際に必要な情報が含まれて
います。

本書は以下の章で構成されています。

• 第 1 章 「はじめに」 （5 ページ）

本章です。

• 第 2 章 「LABCAR-OPERATOR V5.4.0 の概要」 （8 ページ）

この章では、自動車制御用コントローラのテストに求められる一般的な要件、
およびその要件に応えて開発された LABCAR-OPERATOR V5.4.0 のアーキテ
クチャとそのコンポーネントについて概説します。

• 第 3 章 「プログラムのインストール」 （20 ページ）

この章では、製品の内容や、インストールに必要なハードウェアとソフト
ウェアの要件、さらにインストールの準備作業について説明します。

• 第 4 章 「チュートリアル」 （36 ページ）

ここでは、簡単な例を使用して LABCAR-OPERATOR プロジェクトを作成して
実験を行う方法を具体的に説明します。

• 第 5 章 「ETAS ネットワークマネージャ」 （71 ページ）

この章には、社内のネットワーク環境内で ETAS ハードウェアにアクセスす
る際に役立つ情報がまとめられています。

1.2 本書の使用法

表記について

ユーザーが実行するすべてのアクションは、いわゆる “Use-Case” 形式で記述され
ています。つまり以下に示すように、操作を行う目標がタイトルとして最初に簡潔
に定義され、その下に、その目標を実現するために必要な操作手順が列挙されてい
ます。

目標の定義：

前置き ...

• 手順 1

手順 1 についての説明 ...

• 手順 2

手順 2 についての説明 ...

• 手順 3

手順 3 についての説明 ...

まとめ ...

具体例：
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はじめに ETAS
新しいファイルを作成する：

新しいファイルを作成する際は、他のファイルをすべて閉じておきます。

• File → New を選択します。

“Create file” ダイアログボックスが開きます。

• 新しいファイルの名前を、“File name” フィールドに
入力します。

ファイル名は 8 文字以内でなければなりません。

• OK をクリックします。

新しいファイルが作成され、ユーザーが指定した名前で保存されます。このファイ
ルを使用して以降の作業を行います。

表記上の規則

本書は以下の規則に従って表記されています。

その他、重要な語や新出の語は太字または斜体、または「 」で囲んで示されていて、
特に重要な注意事項は、以下のように表記されています。

また PDF 文書において、索引、および他の部分を参照する個所（例：「xxxx」を参照
してください」という文の「xxxx」の部分）については、その参照先へのリンクが
設けられているので、必要な参照個所を素早く見つけることができます。

1.3 LABCAR-OPERATOR V5.4.0 のマニュアル構成

LABCAR-OPERATOR V5.4.0 には、以下のマニュアルが用意されています。

• 『LABCAR-OPERATOR V5.4.0 - Getting Started（入門ガイド）』（本書）

• 『LABCAR-OPERATOR V5.4.0 - User’s Guide（ユーザーズガイド）』

LABCAR-OPERATOR V5.4.0 のすべての機能の説明と、それらの使用方法が
記載されています。

• 『LABCAR-RTC V5.4.0 - User’s Guide（ユーザーズガイド）』

HIL テストシステム用のハードウェアコンフィギュレーションの作成と設定
方法について説明されています。

表記例 説明

File → Exit を選択して、... メニューコマンドは、青の太字で表記し
ます。

OK をクリックして、... ユーザーインターフェース上のボタン名
は、青の太字で表記します。

<Ctrl> を押して、... キーボードの各キーは、< > で囲んで表記
します。

“Open File” ダイアログボックスが
開きます。

プログラムウィンドウ、ダイアログボッ
クス、入力フィールド等のタイトルは、“ 
” で囲んで表記します。

setup.exeファイルを選択します。 リストボックス、プログラムコード、
ファイル名、パス名等のテキスト文字列
は、Courier フォントで表記します。

注記

ユーザー向けの重要な注意事項
LABCAR-OPERATOR V5.4.0 - 入門ガイド



ETAS はじめに
これらのマニュアルは、すべて LABCAR-OPERATOR V5.4.0 の製品 DVD に PDF ファ
イルとして納められています。これらのマニュアルには、Help メニューからもアク
セスできます。

注記

上記の日本語マニュアルは、ETAS のダウンロードセンター（http://
www.etas.com/ja/products/download_center.php）からご入手いただけます。た
だし、一般的に日本語版マニュアルは製品リリースよりも遅れて作成され、また
製品やバージョンによっては日本語版のご用意がないものもあります。ご了承く
ださい。
7LABCAR-OPERATOR V5.4.0 - 入門ガイド
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
2 LABCAR-OPERATOR V5.4.0 の概要

この章では、自動車制御用コントローラのテストに求められる一般的な要件、およ
びその要件に応えて開発された LABCAR-OPERATOR のアーキテクチャとそのコン
ポーネントについて概説します。

また LABCAR-OPERATOR V5.4.0 の新しい機能もご紹介します。

2.1 テストシステムに求められること

本項ではまず、テストシステムに求められる要件と、それを実現するシステムの
アーキテクチャについて説明します。ここで「テストシステム」とは、「コントロー
ラ」と呼ばれる ECU（自動車用電子制御ユニット）の動作検証や評価（妥当性の確
認）を行うために使用されるシステムを指します。

2.1.1 コントローラ機能の開発と検証

図 2-1 に示される全体モデルは、車両に組み込まれたコントローラ（ECU）と車両
との相関関係と、車両とドライバー（運転手）との相互関係、さらに車両を取り巻
く環境を含んでいます。

一般的に、図 2-1 に「コントローラ」と示されているブロックには、制御アルゴリ
ズム、モニタリング機能、および診断機能が含まれています。また、コントローラ
には、診断、測定、適合などの特定な目的に用いられる外部インターフェースを組
み込むことも必要となります。

図 2-1 ドライバー・車両・環境を含む全体モデル（DVE）

コントローラの機能をテストする際には、Driver（ドライバー）と Vehicle（車両）
と Environment（環境） 、 略して「DVE」のシミュレーションが重要な要素となりま
す。そしてさらに、系統的なテストを自動的に行うためのツールも必要です。

また、開発の段階においては、コントローラ（以降、本書では、より一般的な意味
を持つ「テスト対象ユニット（UuT： Unit under Test）」という語を用います）に対
してさまざまな「インターフェース」経由で外部からの操作を行ったり、DVE シ
ミュレーションの一部分を実際の部品（アクチュエータ、センサ）に置き換えるこ
とも要求される、といった点を考慮に入れておく必要があります。

初期の段階においては UuT には制御アルゴリズムのみが含まれますが、開発が進む
につれて以下のようなインターフェースを追加していきます。

• モニタリングと診断

• 適合

開発の過程において UuT は、その規模、特に複雑性の面で手が加えられる可能性が
あります。つまり、開発の対象は、最初は 1 つのサブファンクションを実現するモ
デル単位であり、そこから順に実際の ECU を使用する段階まで規模を拡大し、最後
に完全な ECU ネットワーク環境へと拡張されます。

車両

セットポイント
ジェネレータ

ドライバー

コントローラ アクチュエータ プラントモデル センサ

環境

�
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ETAS LABCAR-OPERATOR V5.4.0 の概要
開発プロセスにおける UuT の拡張

図 2-2 は、開発段階の各レベルにおける UuT の規模（複雑さ）を示しています。

図 2-2 開発プロセスにおける UuT の規模の拡張

上の図に示されるように、さまざまなオブジェクトが UuT として扱われます。

• ソフトウェアコンポーネントとサブシステム

図 2-2 の最下部の段階では、UuT はコントローラ機能のソフトウェアモデル
です。

• マイクロコントローラと ECU
次の 2 つの段階では、UuT はハードウェアコントローラまたは完全な ECU
です。つまり、ソフトウェアが実装されたターゲット（マイクロコントロー
ラ）のみの場合もあれば、完成された ECU 全体である場合もあります。

• 車両サブシステムまたは車両全体の ECU ネットワーク

最も上の段階では、UuT は車両のサブシステムまたは車両全体を制御する

ECU のネットワークとなります。

UuT:車両レベル
ECU 

ネットワーク

システム

車両サブシステムレベル

（例： パワートレイン）

ECUレベル

マイクロコントローラ

レベル

ソフトウェア

レベル

UuT:

UuT:

UuT:

UuT:

ECU
ネットワーク

ECU

µC

ソフトウェア

サブシステム
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
2.1.2 テストシステムの全体的なアーキテクチャ

前項に示した UuT のテストを実現するためには、図 2-3 に示されるようなアーキテ
クチャを持つ、コントローラ開発用テストシステムが必要となります。

図 2-3 テストシステムの全体的なアーキテクチャ

、

このシステムは、以下のモジュールから構成されます。

• 図 2-3 において、中心となるのは「実験」です。これは、UuT、および DVE
（ドライバー、車両、環境）のシミュレーションで構成されます。

• 実験は、「実験ツール」により管理・制御されます。ここでは、インストゥル
メンテーション（"instrumentation"）、つまり計測と操作を行うための GUI

（Graphic User Interface）エレメントが使用されます。

• 複雑なテストと評価を自動化するため、通常、実験ツールは「自動化ツール」
により操作されます。

• DVE モデルやコントローラモデルの作成と編集には、「モデリングツール」が
使用されます。

• UuT への直接のアクセスは「測定・適合ツール」により実現されます。

• UuT の診断インターフェースは「診断ツール」によりアクセスされます。

このアーキテクチャには、実験の管理や制御を行い、開発段階が進むに連れて変化
する UuT に合わせてモデル規模を調整し、さらに UuT のインターフェースにアクセ
スする、というテストシステムに必要なすべての機能が含まれています。

テスト設計ツール

自動化ツール

DVE
モデリングツール

実験ツール

DVEモデル
シミュレート

されるDVE
実際の

DVE

UuT

測定／適合／診断ツール
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2.2 LABCAR-OPERATOR

LABCAR-OPERATOR は、コントローラ機能の開発と評価に用いられるテストシステ
ムに要求される前述の基本的要件を考慮して開発されました。

その主な機能は以下のとおりです。

• 多様なファンクションモデルのための統合プラットフォーム（LABCAR-IP）

－ MATLAB/Simulink モデル

－ ASCET モジュール

－ I/O ハードウェアモジュール

－ C コードモジュール

－ CAN、LIN、FlexRay モジュール

－ FiL モジュール

－ 開ループアクセスとシグナルハンドリングのためのモジュール

• HIL（Hardware-in-the-Loop）テスト用の実験環境（LABCAR-EE）

－ 包括的なインストゥルメンテーション（計装）機能

－ リアルタイムなシグナルジェネレータとデータロガー

－ I/O ハードウェアで取り込んだ ECU データ、センサ／アクチュエータ構
成、シミュレーションモデルの可視化

－ INCA を用いた測定／適合インターフェースや診断インターフェース経由
での ECU へのアクセス（アドオンが必要）

• LABCAR-AUTOMATION によるテストのリモート制御
11LABCAR-OPERATOR V5.4.0 - 入門ガイド
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
2.2.1 LABCAR-OPERATOR V5.4.0 のコンポーネント構成

LABCAR-OPERATOR V5.4.0 のコンポーネントの構成は図 2-4 のようになっていま
す。

図 2-4 LABCAR-OPERATOR V5.4.0 のコンポーネント構成
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ETAS LABCAR-OPERATOR V5.4.0 の概要
以下に、図 2-4 に含まれている LABCAR-OPERATOR V5.4.0 の各アドオンコンポー
ネントについて説明します。

LABCAR-MCA V5.4.0（Modeling Connector for ASCET － ASCET 用モデリングコネ
クタ）

LABCAR-OPERATOR V5.4.0 では、ASCET（V6.0.1）で “RTPC” ターゲット用にエ
クスポートされた ASCET プロジェクトを「モジュール」として統合できるようにな
りました。LABCAR-IP でコード生成を行うと、実験環境（LABCAR-EE）において測
定変数とパラメータ（適合変数）が利用可能になります。

LABCAR-MCS V5.4.0（Modeling Connector for Simulink － Simulink 用モデリング
コネクタ）

「Simulink 用モデリングコネクタ」により、Simulink モデルを、ほとんど手を加える
ことなく簡単な操作だけすぐに LABCAR プロジェクトに統合することができます。
プロジェクトに関する情報やコンフィギュレーション情報は、すべて LABCAR-
OPERATOR 内で作成され、保存されます。

Simulink モデルは、MIL（Model-in-the-Loop）環境と HIL（Hardware-in-the-Loop）
環境の両方で使用することができます。これは、各モデルに定義された「LABCAR
入力ポート」と「LABCAR 出力ポート」を使用することにより、モデルシグナルを、
モデル間、およびモデルとハードウェア間で接続することが可能であるためです。

HIL テストを行う際は、LABCAR-OPERATOR のユーザーインターフェースの一部で
ある「コネクションマネージャ」（“Connection Manager”）を使用します。コネ
クションマネージャでは、Simulink モデルのすべての入出力（LABCAR 用ポートと
して設定されているポート）と定義済みハードウェアのシグナルにアクセスでき、
ここでモデルとハードウェアの「コネクション」を作成して設定します。

ここで設定されたハードウェアコンフィギュレーションは LABCAR-OPERATOR のプ
ロジェクト内に保存されるため、Simulink モデル自体がハードウェアによる影響を
受けることはありません。つまり、モデル自体のコード生成を行うことなくハード
ウェア構成や設定を変更することができます。コードの再生成が必要となるのは、
変更されたハードウェア構成や接続に関する部分だけです。

また、通常はデフォルトの OS 設定を使用します。必要に応じて「OS コンフィギュ
レータ」（“OS Configuration”）を使用してこの設定を変更できますが、この操作
は熟練したユーザーのみが行うようにしてください。

LABCAR-RTC V5.4.0（Real-Time Execution Connector － リアルタイム実行コネク
タ）

LABCAR-OPERATOR V5.4.0 を使用してハードウェアコンポーネントを用いたリアル
タイム実験を行う場合は、リアルタイム実行コネクタ LABCAR-RTC V5.4.0 がインス
トールされている必要があります。

「リアルタイム実行コネクタ」は、HIL テストで用いられるハードウェアコンポーネ
ントの統合とパラメータ設定を行う際に使用します。オンラインモードにおいて、
ハードウェアチャンネルを通るシグナルフローの可視化を行いながらハードウェア
設定を調整することができます。保存されたハードウェア情報は LABCAR-
OPERATOR 環境に表示されます。

LABCAR-CCI V5.4.0（Calibration Connector for INCA － INCA 用適合コネクタ）

INCA 用適合コネクタ LABCAR-CCI V5.4.0 を使用して LABCAR の実験を ETAS の測
定・適合ツール「INCA」のプロジェクトに接続すると、LABCAR の実験環境から

INCA で扱われるデータにアクセスすることが可能となるため、実験に使用される

INCA 用ラベルを LABCAR-OPERATOR V5.4.0 上に表示することができます。
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
ETAS の測定・適合ツール「INCA」によって ECU へのダイレクトアクセスが実現さ
れ、また LABCAR-OPERATOR V5.4.0 から INCA のリモート操作を行うためのイン
ターフェースも用意されています。

LABCAR-NIC V5.4.0（Network Integration CAN － CAN ネットワークの統合）

LABCAR-NIC V5.4.0 は CAN バスのシミュレーションを行うためのものです。シ
ミュレートされるバスの構成を設定でき、実験において、シミュレートされたバス
との CAN メッセージの交換を行うことができます。

LABCAR-NIL V5.4.0（Network Integration LIN － LIN ネットワークの統合）

LABCAR-NIL V5.4.0 は LIN バスのシミュレーションを行うためのものです。シミュ
レートされるバスの構成を設定でき、実験において、シミュレートされたバスとの

LIN メッセージの交換を行うことができます。

LABCAR-NIF V5.4.0（Network Integration FlexRay － FlexRay ネットワークの統合）

LABCAR-NIF V5.4.0 は、以前は EB tresos Busmirror を使用して取得されていたデータ
を LABCAR-OPERATOR プロジェクトに統合し、FlexRay モジュールのシグナルを扱
えるようにするためのものです。

LABCAR-LCE V5.4.0（LABCAR Integration ETK － ETK の統合）

LABCAR-LCE V5.4.0 は FiL モジュールの作成と統合を行うためのものです。FiL シス
テムでは、一部（またはすべて）の電気的接続がバイパスされ、ECU メモリが直接
アクセスされます。このためには ECU に ETK または XETK を取り付ける必要があり
ます。

LABCAR-LCX V5.4.0（LABCAR Integration XCP － XCP の統合）

LABCAR-LCX V5.4.0 は FiL モジュールの作成と統合を行うためのものです。XETK
または XCP on CAN 経由で ECU に直接アクセスします。

2.2.2 LABCAR-IP

LABCAR-OPERATOR V5.4.0 の統合プラットフォームである LABCAR-IP を用いて、
主に以下のような作業を行えます。

• さまざまな機能を含むモジュールをプロジェクトにインポートする

• I/O ハードウェアモジュールを設定する

• 各モジュールを接続する

• シミュレーションターゲット RTPC のコードを生成する

さらに以下のことも行えます。

• リアルタイムシミュレーション用の OS 設定

• 開ループ実験において入力信号をシミュレートするためのシグナルジェネ
レータセットの作成

注記

INCA のライセンスは本製品には含まれていません。
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ユーザーインターフェース

LABCAR-IP には以下のようなユーザーインターフェースウィンドウが用意されてい
ます。

• プロジェクトエクスプローラ（“Project Explorer” ウィンドウ） 
LABCAR-OPERATOR プロジェクトのすべてのパーツの一覧が表示されます。

• メインワークスペース

LABCAR-OPERATOR ユーザーインターフェースの主要部分です。以下のタブ
で構成され、LABCAR-IP の主要なパーツにアクセスできます。

－ プロジェクト情報 （”< プロジェクトファイル名 >” タブ）

プロジェクトの名前とパスが表示されます。

－ コネクションマネージャ（”Connection Manager” タブ）

シグナルの接続や、シグナル変換モジュールの挿入を行います。

－ CAN エディタ（“CAN Editor” タブ）

バスシミュレーションを設定します（LABCAR-NIC V5.4.0 がインストー
ルされていて、かつ CAN モジュールが開いている必要があります）。

－ LIN エディタ（“LIN Editor” タブ）

バスシミュレーションを設定します（LABCAR-NIL V5.4.0 がインストー
ルされていて、かつ LIN モジュールが開いている必要があります）。

－ FlexLay エディタ（“FlexRay Editor” タブ）

バスシミュレーションを設定します（LABCAR-NIF V5.4.0 がインストー
ルされていて、かつ FlexRay モジュールが開いている必要があります）。

－ OS コンフィギュレータ（“OS Configuration” タブ）

オペレーティングシステムを設定します。

－ FiL ウィザード（“FiL Wizard” タブ）

FiL モジュールを設定します。
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
• メッセージウィンドウ（“Messages” タブ）

実行されたアクションや接続されているハードウェアについての各種情報や
エラーメッセージなどが表示されます。

モジュール

モジュールは以下のものから構成されます。

• シグナル入力

• シグナル出力

• 機能（= コード）

• 測定変数

• パラメータ（= 適合変数）

• プロセス（リアルタイム実験のタスク制御において実行管理されるコードの単
位）

LABCAR-OPERATOR V5.4.0 では、以下の種類のモジュールを使用できます。

• ASCET モデル

LABCAR-MCA V5.4.0 を用いて ASCET モデルを統合できます。

• Simulink モデル

LABCAR-MCS V5.4.0 を用いて Simulink モデルを統合できます。

• C コードモジュール

ユーザー定義の C コードをモジュールとして統合することもできます。

• CAN モジュール

LABCAR-NIC V5.4.0 を用いて、バスシミュレーション用モジュールを作成し
て実行することができます。

• LIN モジュール

LABCAR-NIL V5.4.0 を用いて、バスシミュレーション用モジュールを作成し
て実行することができます。

• FlexRay モジュール

LABCAR-NIF V5.4.0 を用いて、FlexRay バスシミュレーション用モジュール
を統合することができます。

• FiL モジュール

LABCAR-LCE V5.4.0 を用いて、ETK ／ XETK 経由の ECU アクセスを行うた
めのモジュールを作成して統合することができます。

• ハードウェアモジュール

リアルタイム実行コネクタ LABCAR-RTC V5.4.0 によって I/O ハードウェア設
定用の RTIO モジュールが作成され、編集も可能です。

• シグナル変換用モジュール

LABCAR-OPERATOR V5.4.0 で新たに導入されたモジュールです。これに
よって開ループ環境におけるセンサ／アクチュエータのモデリングが大幅に
簡略化されました。

2.2.3 LABCAR-EE

LABCAR-EE は、実験を設定して実行するための新しい環境です。

新しい実験環境では以下のようなことを行えます。

• ワークスペースエレメント（“Workspace Elements”）ウィンドウ内のエレメ
ントリスト（“Element List”）とシグナルセンター（“Signal Center”）を介し
た、すべてのパラメータと測定変数への明快なアクセス
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• 実行中の実験に含まれる測定変数の表示やパラメータ値の変更を行うための
インストゥルメント（GUI エレメント）の作成

• シグナルの変換とセンサ／アクチュエータのモデリング

• シグナルパスのトレース

• データロガーによるデータの記録

• シグナルジェネレータによるスティミュレーション入力

“Workspace Elements” ウィンドウ

LABCAR-OPERATOR V5.4.0 では、エレメントリストとシグナルセンターが

“Workspace Elements” という 1 つのウィンドウに統合されました。

図 2-5 “Workspace Elements” サブウインドウ

ここから、現在開いている実験に含まれる以下のアイテムにアクセスできます。

• 測定変数

• パラメータ

• 入力

• 出力

• ハードウェアピン
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LABCAR-OPERATOR V5.4.0 の概要 ETAS
このビューにおいては、シグナルやパラメータ、測定変数、モジュール階層の検索
が容易に行えます。また “Workspace Elements” ウィンドウにも便利なフィルタ機
能や検索機能が用意されています。

インストゥルメンテーション（GUI エレメントによる表示と操作）

測定変数を表示したりパラメータ値を入力したりするためのインストゥルメント
（GUI エレメント）の機能が拡張され、さらに新しいリアルタイムオシロスコープが
導入されました。

開ループ操作とシグナル編集

HiL 実験のパーツを「モジュール」として標準化することにより、シグナルトレース
への介入をシステマティックに行うことができます。

C コードで作成された汎用的なアクチュエータモジュールやセンサモジュールをシ
グナルトレース上の任意のポイントで用いることにより、任意の入力をシグナル
チェーンに割り当てたり、定数値やシグナルジェネレータからの値を「スティミュ
ラス」（刺激）として入力に与えることもできます。

LABCAR-EE には、シグナルのマッピング、トレース、編集を行うための「シグナル
リスト」（“ シグナルリスト ”）が含まれています。

シグナルをシグナルリストに追加すると、以下のアクションが実行可能になります。

• シグナルトレース上のシグナルの追跡

• 開ループ用のモード定義（モデル、定数値、シグナルジェネレータの接続）

2.2.4 旧バージョン（V3.2.x 以降）のプロジェクトの移行

LABCAR-OPERATOR V5.1.2 までは、V3.2.x 以降のプロジェクトは自動的に現行
バージョン用に変換されていましたが、V5.2.x 以降では、この変換は行われなくな
りました。

注記

旧バージョンのプロジェクトを LABCAR-OPERATOR V5.4.0 で開くには、あらか
じめ LABCAR-OPERATOR V5.1.x を使用してそのプロジェクトを V5.1.x 用に変換
し、保存しておく必要があります。
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LABCAR-IP で旧バージョンのプロジェクトを開くと、マイグレーションウィザード
（“Migration Wizard”）が起動し、現行バージョン用に変換するための処理が実行さ
れます。

正常に変換されたプロジェクトは、選択されたディレクトリに、指定された名前で
保存されます。

制限事項

以下の場合、プロジェクトの自動変換は行われません。

• LABCAR-DEVELOPER プロジェクトが含まれる LABCAR-OPERATOR V3.2.x プ
ロジェクト

• ES1130 をシミュレーションターゲットとするプロジェクト

上記のようなプロジェクトは、LABCAR-OPERATOR V5.4.0 で新しく作成しなおす必
要があります。
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3 プログラムのインストール

この章では、製品の内容や、インストールに必要なハードウェアとソフトウェアの
要件、さらにインストールの準備作業について説明します。

3.1 準備

LABCAR-OPERATOR V5.4.0 をインストールする前に、製品の内容に不足がないこと
と、製品をインストールする PC がシステム要件を満たしていることを確認してくだ
さい。また使用するオペレーティングシステムとネットワーク環境によっては、イ
ンストールを行う前に、所定のユーザー権利が与えられているかを確認する必要が
あります。

3.1.1 製品の内容

LABCAR-OPERATOR V5.4.0 の製品パッケージには、以下のものが含まれています。

• LABCAR-OPERATOR V5.4.0 の DVD-ROM
以下のファイルが含まれます。

－ LABCAR-OPERATOR V5.4.0 の各プログラムのインストールプログラム

－ 最新の HSP（Hardware Service Pack： ハードウェアサービスパック）

－ LABCAR-OPERATOR V5.4.0 のマニュアル（PDF ファイル）

－ 最新の LABCAR ハードウェアのマニュアル（PDF ファイル）

－ What's New、リリースノート等の各種ドキュメント

• 購入済みソフトウェアのライセンス取得方法についてのドキュメント
（“License Entitlement”）

3.1.2 システム要件

LABCAR-OPERATOR V5.4.0 を操作するには、以下の条件を満足している PC が必要
です。

• 2 GHz 以上のプロセッサ

• オペレーティングシステム

－ Windows 7 SP1 （32 ビットまたは 64 ビット）

－ Windows 8.1 （64 ビット）

以下の言語のオペレーティングシステムをサポートしています。

－ 英語

－ ドイツ語

－ フランス語

－ 日本語

－ 韓国語

• 1GB RAM（2GB 以上を推奨）

• 空き容量が 1GB 以上のハードディスク

• DVD-ROM ドライブ（インストール時のみ）

• DirectX 7（またはそれ以上）に互換の VGA グラフィックカード

• イーサネットボード（10/100 BaseT）
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3.1.3 ソフトウェア要件

LABCAR-OPERATOR V5.4.0 を操作するのに必要な各ソフトウェアのバージョンを確
認するには、? メニューから Help を選択して、"LABCAR-OPERATOR 5.x.y - 
Software Compatibility List" という文書を開いてください。 

3.1.4 ユーザー権利

LABCAR-OPERATOR のインストールおよび操作に必要なユーザー権利について、以
下に説明します。

インストールに必要なユーザー権利

• LABCAR-OPERATORをPCにインストールするユーザーには管理者の特権が必
要です。不明な場合はシステム管理者の方にお問い合わせください。

• PC 上に、LABCAR-OPERATOR を使用する全ユーザーが読み書きできる一時
ディレクトリ（例： C:¥TEMP）が存在している必要があります。

運用に必要なユーザー権利

• LABCAR-OPERATOR を操作するユーザーには “ スケジューリング優先順位の
繰り上げ ” の権利が必要です。PC 上にすでに INCA がインストールされてい
る場合は、INCA のインストール時に各ユーザー用にこの権利が割り当てられ
ている場合があります（下図参照）。

• LABCAR-OPERATOR の全ユーザーには、以下のレジストリキーへの所定のア
クセス権が必要です。

－ HKEY_LOCAL_MACHINE¥SOFTWARE¥Microsoft¥Cryptography¥R
NG （必要なアクセス権： 書き込みアクセス）

－ HKEY_LOCAL_MACHINE¥SOFTWARE¥ETAS とそのサブディレクトリ内の
すべてのキー （必要なアクセス権： フルアクセス）

• LABCAR-OPERATOR の全ユーザーおよび “Everyone” グループのデフォルト
ユーザーには、¥ETAS ディレクトリ、およびそのすべてのサブディレクトリ
へのフルアクセス権が必要です。このアクセス権は、GNU C コンパイラでコー
ド生成を行う際などに必要となります。

3.1.5 Windows XP SP2 環境での HTML 形式の情報表示について

オペレーティングシステムに Windows XP（+SP2）を使用している場合、“Allow 
active content to run in files on My Computer”（“ マイコンピュータのファイルで
のアクティブコンテンツの実行を許可する ”）というオプションがオンになってい
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ることを確認してください。このオプションの確認・設定を行うには、コントロー
ルパネルから “Internet Properties”（“ インターネットのプロパティ ”）を開
き、“Advanced”（“ 詳細設定 ”）タブを選択します。

3.2 プログラムのインストール

本項では LABCAR-OPERATOR V5.4.0 のインストール方法について説明します。

LABCAR-IP をインストールする：

• 製品 DVD を PC の DVD-ROM ドライブに挿入します。

DVD ブラウザが開きます。
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• Installation → Install LABCAR-OPERATOR 5.4.0 を
選択します。

HSP のインストールの方法は、33 ページの「HSP 
Update Tool」 を参照してください。

インスタレーションウィザードが起動し、Welcome 
ページが開きます。

• Next をクリックします。

• インスタレーションウィザードの案内に従ってインス
トールに関する設定を行います。
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• Finish をクリックします。

インストールが実行されます。

3.2.1 スタートメニュー

インストールが正常に終了すると、スタートメニューのフォルダ（すべてのプログ
ラム → ETAS → LABCAR-OPERATOR x.y）には以下のエントリが含まれます。

• LABCAR-IP　

統合プラットフォームを起動します。

• LABCAR-OPERATOR Tools　
以下の LABCAR-OPERATOR 用ツールが格納された \LCO Tool ディレクト
リを開きます。

－ LABCAR-OPERATOR Version Selector　

使用する LABCAR-OPERATOR のバージョンを選択できます。詳しくは
「ソフトウェアバージョンの選択」（25 ページ）を参照してください。

－ MATLAB Version Selector　

使用する MATLAB バージョンを選択します。 詳しくは「MATLAB のバー
ジョンを選択する：」（27 ページ）を参照してください。
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－ RT-Plugin Builder　

リアルタイムプラグインを作成するためのアプリケーションを起動しま
す。

• Manuals and Tutorials　
LABCAR-OPERATOR と LABCAR ハードウェアについてのドキュメントが格
納されたフォルダ（\ProgramData\ETAS\ETASManuals\）を開きま
す。

スタートメニューのもう 1 つのフォルダ（すべてのプログラム → ETAS → 
Experiment Environment x.y）には以下のエントリが含まれます。

• Experiment Environment Vx.y Tools　
実験環境 LABCAR-EE のフォルダ \EE を開きます。ここから以下のツールを
起動できます。

－ Associate in INCA　

LABCAR-EE に関連付ける INCA のバージョンを選択します。詳しくは
「INCA のバージョンを選択する：」（27 ページ）を参照してください。

－ Associate to RTA Trace　

LABCAR-EE に関連付ける RTA-Trace のバージョンを選択します。

• Experiment Environment Vx.y　

実験環境 LABCAR-EE を起動します。

• Manuals and Tutorials　
LABCAR-EE の HTML ヘルプが格納されたフォルダ

（\ProgramData\ETAS\ETASManuals\）を開きます。

• TargetServernn Tools　
フォルダ \ETAS\TargetServernn\Toolsを開きます。ここから以下
のツールを起動できます。

－ Search for connected hardware　

ターゲットサーバーを起動します。接続されているすべてのハードウェア
が検索されます。

－ ETAS Network Settings　

ETAS ハードウェアとその他のネットワークに対応して PC のネットワー
クカードを設定するための ETAS ネットワークマネージャを起動します。

3.2.2 ソフトウェアバージョンの選択

インストールを完全に終了するためには、LABCAR-OPERATOR 環境で使用する各ソ
フトウェアのバージョンを選択する必要があります。ここでは LABCAR-OPERATOR 
のバージョンのほか、Matlab/Simulink と INCA のバージョンを選択します。
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複数バージョンの LABCAR-OPERATOR がインストールされている場合、以下のよう
にして使用するバージョンを選択します。

LABCAR-OPERATOR のバージョンを選択する：

• LABCAR-IP が開いている場合は、それを閉じます。

• Windows のスタートメニューから すべてのプログラ
ム → ETAS → LABCAR-OPERATOR x.y → LABCAR-
OPERATOR Vx.y Tools → LABCAR-
OPERATOR Version Selector を選択します。

“LABCAR-OPERATOR Version Selector” ウィンドウが
開きます。

• 使用するバージョンを選択して Switch をクリックし
ます。

選択が正常に実行されると、以下のメッセージが表示
されます。

注記

LABCAR のバージョン選択ツール "LABCAR-OPERATOR Version Selector" は、必
ず現行バージョンの LABCAR-OPERATOR のものを使用してください。 それ以外の
者を使用すると、レジストリエントリの重複によるトラブルが発生する可能性が
あります。
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複数バージョンの Matlab/Simulink がインストールされている場合、Simulink モデ
ルの統合に使用するバージョンを以下のようにして選択します。

MATLAB のバージョンを選択する：

• Windows のスタートメニューから すべてのプログラ
ム → ETAS → LABCAR-OPERATOR x.y → LABCAR-
OPERATOR Vx.y Tools → 
Matlab Version Selector を選択します。

“Select Matlab Version” ウィンドウが開きます。

• “Installed Matlab Versions” コンボボックスから使用
するバージョンを選択します。

LABCAR-OPERATOR V5.4.0 がサポートしているバー
ジョンを表示するには、Supported Matlab 
Versions をクリックします。

• Select をクリックして選択内容を保存します。

選択内容が確定されます。

• OK をクリックして “Select Matlab Version” ウィンド
ウを閉じます。

複数バージョンの INCA がインストールされている場合、LABCAR-CCI V5.4.0 から

INCA の実験にアクセスする際に使用するバージョンを以下のようにして選択しま
す。この選択は実験環境（LABCAR-EE）のインストール時に行いますが、その後、
必要に応じて変更することができます。

INCA のバージョンを選択する：

• Windows のスタートメニューから すべてのプログラ
ム → ETAS → Experiment Environment x.y → 
Experiment Environment Vx.y Tools → 
Associate to INCA を選択します。

“Associate to INCA” ウィンドウが開きます。

• 使用するバージョンをリストから選択します。
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• Associate をクリックして選択内容を保存します。

• ETAS ターゲットサーバーのインストールが開始され
ます。

• 表示される指示に従って操作を行います。

• 必要に応じて、スケジューリング優先度の繰り上げが
必要なユーザーを追加します。

詳しくは、21 ページの「運用に必要なユーザー権利」 
を参照してください。

3.3 フトウェアのライセンス管理

ETAS のソフトウェア製品を使用するにはライセンスが必要です。本項ではライセン
ス管理について詳しく説明します。

• ETAS のライセンスモデル（28 ページ）

• ライセンスの取得（29 ページ）

• ライセンスファイル（30 ページ）

• グレースモード（32 ページ）

• ライセンスの借用（32 ページ）

各ライセンスの適用範囲やその他の条件については、ソフトウェア製品の使用条件
に関するドキュメントをご参照ください。このドキュメントはソフトウェア製品に
同梱されています。

3.3.1 ETAS のライセンスモデル

ETAS ソフトウェアのライセンスには 2 種類のライセンスモデルがあります。

マシンネームライセンス （ローカル）

• 特定の PC を対象としたライセンスで、ライセンス管理は PC のユーザー自身
が行います。

• ライセンスは特定の PC にリンクするので、その PC を使用すればいつでもラ
イセンスを使用できます。

• PC を交換する際は新しいライセンスを発行する必要があります。
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コンカレント（または「フローティング」）ライセンス （サーバーベース）

ユーザーネームライセンスと同様のものですが、ここでは複数のユーザーが決めら
れた数のライセンスを共有できます。

3.3.2 ライセンスの取得

社内で ETAS ソフトウェアのサーバーベースライセンス管理を行っている場合、ライ
センスの取得についてはサーバーの管理者の方にお問い合わせください。その他

（マシンネームライセンス）の場合は、ETAS ライセンスポータル（URL は製品に同
梱されたドキュメントに記載されています）からライセンスを取得してください。

ライセンスポータルへのログイン方法には以下の 3 通りがあります。

• アクティベーション ID でログインする

ログインすると「アクティベーション」1 が表示され、これを管理することが
できます。アクティベーション ID は製品に添付されたライセンスドキュメン
トに記載されています。

• エンタイトルメント ID でログインする

エンタイトルメント2 に関連付けられたすべてのアクティベーションが表示
され、これらを管理することができます。この方法は、部署や会社単位で 1
つのエンタイトルメントを使用するような場合に便利です。

• E メールアドレスとパスワードでログインする

ユーザーアカウントに割り当てられたすべてのアクティベーションとエンタ
イトルメントが表示され、それらを管理することができます。この方法は、
ツール管理者の方が複数のエンタイトルメントを管理するような場合に便利
です。

ライセンスポータルの使用方法がわからない場合は ヘルプ というリンクをクリック
してヘルプドキュメントを開いてください。

必要な情報

ライセンスをアクティベート（= 有効化）するには、使用する PC についての以下の
情報が必要です。

• マシンネームライセンス

ライセンスを結び付けるイーサネットアダプタの MAC アドレス

• コンカレント（フローティング）ライセンス

サーバーホストまたはサーバートライアド

1. 「アクティベーション」には、特定の製品とそのライセンス条件、ライセンス数など、
ライセンス発行に必要な情報が割り当てられています。各アクティベーションは、「ア
クティベーション ID」によって識別されます。

2. 「エンタイトルメント」は、ある製品について 1 つまたは複数のライセンスを保持する
ためのユーザー権限を表すものです。つまりエンタイトルメントはソフトウェアを使用
する権利の「口座」のようなもので、ここから必要に応じてライセンスを取り出すこと
ができます。

注記

PC ハードウェアやユーザーの変更に伴い上記の情報が変更された場合は、ライセ
ンスを「リホスト」する必要があります。この方法はライセンスポータルのヘル
プドキュメントに記載されています。
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3.3.3 ライセンスファイル

ライセンスポータルでライセンスが発行されると <name>.Lic というライセンス
ファイルが生成されるので、このファイルを ETAS ライセンスマネージャで PC に登
録します。

ライセンスのインストール状態を調べる：

• Windows スタート メニューから ETAS → License 
Management → ETAS License Manager を選択し
ます。

ETAS ライセンスマネージャが開き、インストールさ
れている製品のライセンス情報が表示されます。

• 各エントリ行の先頭の列のシンボルと “ ステータス ”
列に表示されるテキスト情報で、有効なライセンスが
インストールされているかどうかがわかります。

ライセンスを追加する：

• ETAS ライセンスマネージャを開いて（30 ページ参
照）、ファイル メニューから ライセンスファイルの追
加 を選択します。

“ ライセンスのインストール ” ダイアログボックスが
開きます。
LABCAR-OPERATOR V5.4.0 - 入門ガイド



ETAS プログラムのインストール
• “ ライセンスファイルの選択 ” フィールドの右側にあ
る ... ボタンをクリックします。

• ファイル選択ダイアログボックスで、ライセンスファ
イルを選択して 開く をクリックします。

“ ライセンスのインストール ” ダイアログボックス
に、選択されたライセンスファイルの情報が表示され
ます。

• OK をクリックしてライセンスファイルをインストー
ルします。

上記の操作で選択されたライセンスの情報が、ETAS
ライセンマネージャに反映されます。エントリの先頭
部分には、ライセンスが有効であることを示す緑の
チェックマークシンボルが表示されます。

• 閉じる をクリックして ETAS ライセンスマネージャを
閉じます。

注記

上記ダイアログボックスの “ バージョン ” 列に表示さ
れる番号は、ライセンスのバージョン番号で、ソフト
ウェアのバージョン番号とは異なります。

注記

上記の操作を行っても緑のシンボルが表示されない場
合、ライセンスファイル、または他の製品に関連する
ライセンスに何らかの問題がある可能性があります。

ETAS ライセンスマネージャについての詳しい情報は、

ETAS ライセンスマネージャのオンラインヘルプを参照
してください。
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3.3.4 グレースモード

ライセンスをインストールしていなくても、一定の期間のみ「グレースモード」で
ソフトウェアを使用することができます。その期間はソフトウェア起動時に以下の
ウィンドウが開き、グレースモードで使用できる残日数が表示されます。

3.3.5 ライセンスの借用

サーバーライセンスを使用している場合、ライセンスの「ボロー」メカニズムを利
用することにより、オフライン（ライセンスサーバーに接続しない状態）で ETAS ソ
フトウェアを使用することができます。

ライセンスの借用は以下のように行います。

ライセンスを借用する：

• ライセンスを借用したい ETAS ソフトウェアが、現在
起動されていないことを確認します。

• ETAS ライセンスマネージャ ウィンドウの “ ライセン
スリスト ” フィールドから、借用したいライセンスを
選択します。

• ライセンス メニューから ライセンスの借用 を選択し
ます。

“ 借用期限の設定 ” ダイアログボックスが開きます。

• カレンダーで、ライセンスを借用する期限を指定しま
す。

注記

ライセンスの借用ができるのはサーバーベースライセンスの場合のみです。
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• OK をクリックします。

ETAS ライセンスマネージャ ウィンドウの “ ソース ”
列の表示が “ サーバー ” から “ 借用 ” に変わり、借
用期限の日付が表示されます。

これで、ETAS ソフトウェアを借用期限までオフラインで使用できるようになりまし
た。

指定した借用期限を超えて ETAS ソフトウェアを使用する必要が生じた場合は、再度
ライセンスを借用してください。指定した借用期限前に ETAS ソフトウェアの使用を
終了する場合は、ライセンスを期限前に返却（ライセンス → ライセンスを期限前に
返却）することができます。ライセンスの返却は、それを借用したユーザーしか行
えません。他のユーザーによる返却は行えません。 

3.4 HSP Update Tool

HSP Update Tool は、ご使用のハードウェアのファームウェアを、製品 DVD に格納
されている最新 HSP（Hardware Service Pack： ハードウェアサービスパック）に含
まれるバージョンにアップデートするためのツールです。

インストールを実行する：

• 製品 DVD を PC の DVD-ROM ドライブに挿入します。

DVD ブラウザが開きます。
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• Installation → Install HSP <version no.> を選択し
ます。

インストールプログラムが起動します。

• Next をクリックします。

インストール処理が開始されます。

• ダイアログボックスに表示される指示に従って操作を
行います。

• すべての処理が完了したら、Finish をクリックしてイ
ンストールプログラムを終了します。
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ファームウェアアップデートを実行する：

• LABCAR-IP から Tools → HSP Update Tool を選択し
ます。

HSP Update Tool が起動します。

• HSP Update Tool から Help（ヘルプ） → Quick Start
（クイックスタート）を 選択します。

アップデートの手順を説明したヘルプトピックが開き
ます。

• 説明に従ってハードウェアのファームウェアアップ
デートを行います。

3.5 Real-Time PC へのネットワーク接続

LABCAR-OPERATOR 用 PC とシミュレーションターゲットの "RTPC" とを接続する
には、PC の 2 番目のイーサネットボードと Real-Time PC の “ETH0” ポートを接続
し、さらに PC のイーサネットボードに固定ネットワークアドレス 192.168.40.240 

（サブネットマスク 255.255.255.0）をセットします。

詳しくは、『ETAS RTPC V6.2.0 - ユーザーズガイド』と、71 ページの「ETAS ネット
ワークマネージャ」 を参照してください。 
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4 チュートリアル

ここでは、簡単な例を使用して LABCAR-OPERATOR プロジェクトを作成して実験を
行う方法を具体的に説明します。

このチュートリアルは以下のように構成されています。

• “IdleController” モデル（36 ページ）

この項では、このチュートリアルプロジェクトに使用される

“IdleController.mdl” という Simulink のモデルについて簡潔に説明します。

• LABCAR-OPERATOR プロジェクトの作成（38 ページ）

この項では、LABCAR-MCS V5.4.0（Simulink 用モデリングコネクタ）を使
用してプロジェクトを作成する場合の基本手順について説明します。

• 測定変数の表示とパラメータの適合（43 ページ）

この項では、エンジン回転数を表示する表示エレメントとエアコンの ON/
OFF を切り替えるスイッチ（操作エレメント）を作成します。

• ハードウェアコンフィギュレーションの設定（50 ページ）

このチュートリアルにおいては、実際の HIL 実験を作成することはできませ
んが、この項では、このチュートリアルの実装範囲内でのツールの取り扱い
と LABCAR-MCS の各機能の使用方法について説明します。

• 入力ポートの追加（53 ページ）

ハードウェアをモデルシグナルに接続する前に、LABCAR 入力ポートと出力
ポートをモデルに追加する必要があります。

• コネクションマネージャでのシグナルの接続（56 ページ）

A/D コンバータからのシグナル（“0” または “1”）を、コネクションマネー
ジャでモデル入力 “AirConditionManual” に接続します。

• リアルタイムオペレーティングシステムのコンフィギュレーション（58 ペー
ジ）

LABCAR-OPERATOR は、新しいプロジェクトが作成されるたびに、そのプロ
ジェクト用に標準 OS コンフィギュレーションを 1 つ作成します。このコン
フィギュレーション内には、必要なタスクがすべて定義され、すべてのプロ
セスが各タスクに適切に割り当てられています。

• 実験の実行（59 ページ）

この項では、実験を実行する前に行う最後のステップについて、以下の手順
に従って説明します。

• データロガー（“Datalogger”）による記録（66 ページ）

この項では、データロガーでシグナルを記録する方法について説明します。

4.1 “IdleController” モデル

この項では、このチュートリアルプロジェクトに使用される “IdleController.mdl” と
いう Simulink のモデルについて簡潔に説明します。

図 4-1 に示されるように、この Simulink モデルは、単純なエンジンモデル

“Pedal2Nengine” とアイドルコントローラ “A_IdleController” で構成されていま
す。
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このコントローラの入力は、アクセル位置（ドライバーが設定します）とエンジン
回転数です。アイドリング時には、あらかじめ定義されている回転数が維持されま
す。

図 4-1 全体モデル “IdleController.mdl”

図 4-2 のエンジンモデルでは、アクセル位置（“Accelerator_Input”）からトルクが
算出され、そのトルクからエンジン回転数が算出されます。また、エアコンを ON
にすることもできます。エアコンが ON になると当然ながらトルク負荷が増大し、
特にアイドリング時にはエンジン回転数が低下します。エンジン回転数が低下する
とアイドルコントローラがアクティブになって補正後のアクセル位置をエンジンモ
デルに提供し、それによってエンジン回転数が修正されて目標回転数に戻るように
します。

エアコンの ON/OFF は、図 4-2 の左上にある “AirConditionManual” の値に従って
切り替わります。このチュートリアルでは、この値をまず制御ウィンドウで変更す
る実験を行い、次に、A/D コンバータハードウェアを用いてこの値を変更する実験
を行います。

図 4-2 “Pedal2Nengine” エンジンモデル
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4.2 LABCAR-OPERATOR プロジェクトの作成

この項では、LABCAR-MCS V5.4.0（Simulink 用モデリングコネクタ）を使用してプ
ロジェクトを作成する場合の基本手順について説明します。

LABCAR-OPERATOR を起動する：

• スタート → すべてのプログラム → ETAS → 
LABCAR-OPERATOR x.y → LABCAR-IP を選択しま
す。

または

• デスクトップにある LABCAR-OPERATOR のアイコ
ンをダブルクリックします。

LABCAR-OPERATOR が起動し、メインウィンドウが
開きます。

このユーザーインターフェースについては、
『LABCAR-OPERATOR V5.4.0 - ユーザーズガイド』に
詳しく説明されています。
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LABCAR-OPERATOR プロジェクトを作成する：

• File メニューから New → New Project を選択しま
す。

プロジェクトウィザード（“Project Wizard”）が開き
ます。

• 新しいプロジェクトを作成するディレクトリを

“Location” フィールドに設定します。

• プロジェクト名を “Project Name” フィールドに入力
します。

• 必要に応じて、“Target Name” フィールドにターゲッ
トの任意の名前を入力します。

• Finish をクリックします。

プロジェクト（モジュールとハードウェアは含まれま
せん）が作成されます。

Simulink モデルを統合する：

• Project → Add Module を選択します。

または

• Add Module ボタンをクリックします。

または

• プロジェクトエクスプローラ内の "RTPC" ターゲット
を右クリックしてショートカットメニューを開き、

Add Module を選択します。

モジュール追加ウィザード（“Add Module Wizard”）
が開きます。
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• “Add Simulink (TM) Module” オプションを選択しま
す。

Next をクリックします。

• “Use existing Simulink Model” を選択します。
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• Next をクリックします。

• Browse ボタンで、使用する Simulink モデルを選択
します。

“IdleController.mdl” は以下のディレクトリ
に格納されています。
<drive>:¥Program Files¥ETAS¥
LABCAR-OPERATORx.y¥Manuals¥
Tutorial

• Copy Model Directory into Project オプションをオ
ンにすると、Simulink モデルとすべての関連ファイル
がプロジェクトディレクトリにコピーされます。オフ
の場合は、モデルは参照されるのみとなります。

• 必要に応じて Advanced Settings ボタンで外部の
ファイルとディレクトリについて詳細に設定すること
もできますが（『LABCAR-RTC V5.4.0 - ユーザーズガ
イド』を参照してください）、ここではその必要はあ
りません。

• Finish をクリックします。

プロジェクトが作成され、関連するディレクトリと
ファイルが PC のハードディスク上に作成されます。

プロジェクトのディレクトリツリーがプロジェクトエ
クスプローラ（“Project Explorer”）に表示されます。
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プロジェクトが作成されたので、次にコード生成を行います。

コードを生成する：

• Project → Build... を選択します。

または

• Build LABCAR Project ボタンをクリックします。

• 次のダイアログボックスで、コードを生成するモ
ジュールを選択します。

• Build をクリックします。

選択されたモジュールのコードが生成されます。

処理が終了すると、その旨を表すメッセージが

“Messages” タブに出力されます。

コードが正常に生成された後は、LABCAR-EE で実験を開き、設定を行って実験を実
行することができます。

注記

ここで、実験ターゲット（ここでは RTPC）が PC に接続されていて、稼動可能な
状態であることを確認してください。

注記

最初にコード生成を行った場合、自動的に LABCAR-EE が起動し、実験用のワー
クスペースが生成されます。
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LABCAR-EE で実験を開く：

• Open Experiment Environment ボタンをクリック
します。

LABCAR-EE が起動して実験が開きます。

“Workspace Elements” ウィンドウ内に、モデルのすべてのパラメータ、測定変数、
入力、出力が階層的に表示されます。

メインワークスペース（上記ウィンドウの中央部分）で、複数のレイヤ上にインス
トゥルメント（GUI エレメント）を作成し、設定を行った後、データロガー

（“Datalogger” タブ）を操作し、さらにシグナルジェネレータ（“Signal Generator”
タブ）を作成して操作します。

4.3 測定変数の表示とパラメータの適合

この項では、エンジン回転数を表示する表示エレメントとエアコンの ON/OFF を切
り替えるスイッチ（操作エレメント）を作成します。

オシロスコープを作成する：

• エンジン回転数を表示するためのオシロスコープを作
成するために、ツールバーの Add Oscilloscope ボタ
ンをクリックします。

オシロスコープウィンドウが開きます。

• “Workspace Elements” ウィンドウで

“TorqueToNEngine” フォルダを検索します
（“Search&Filder” 機能を使用します）。

• フォルダをクリックして、“TorqueToNEngine/Out”
というラベルが表示されるまで階層を開きます。
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• “Out” を選択し、マウスボタンを押し下げたままオシ
ロスコープウィンドウまでドラッグします。

• オシロスコープウィンドウ上でマウスボタンから指を
離します。

“Create Instruments” ダイアログボックスが開きま
す。

• 測定変数の値を取得するタスクとして “Acquisition”
を選択します。
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• OK をクリックします。

測定変数がオシロスコープに追加されます。

変数の名前が注釈部分に表示されます。

続いて、エアコンの ON/OFF を切り替えるスイッチを作成します。

エアコンのスイッチを作成する：

• “Workspace Elements” ウィンドウ
で、“AirConditionManual” フォルダ内の “Value” パ
ラメータを検索します。

以下のようにして操作エレメントや表示エレメントを
作成できます。

• “Value” パラメータを右クリックします。

注記

測定変数は、割り当てられたタスクのラスタ内で常に記録されます。ただしラス
タ周期が 5ms 未満の場合は、以下の制限事項を考慮する必要があります。 
1. 上記の範囲において、測定変数の連続的な記録は保証されません。確実に記録
を行う必要がある場合は、データロガーを使用してください。

2. 各測定ポイントの x 値（時刻）は、ラスタの実時刻と比べて若干の遅れが生じ
る場合があります。
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• Measure / Calibrate を選択します。

“Create Instruments” ダイアログボックスが開きま
す。

• “Instrument Type” 列で “On/Off” を選択します。

• “Group” 列で “<New Group>” を選択します。

• OK をクリックします。

• 操作エレメントが作成されます。

• 操作エレメントを選択し、さらに “Properties” ウィン
ドウを選択します。
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• “Label Format” フィールドに表示されている文字列

“%Default” を “Air Condition” に変更します。

スイッチにラベルが表示されます。

• “Value” パラメータをオシロスコープに追加します。

実験をターゲットにダウンロードする：

• プロジェクト作成時に指定したシミュレーションター
ゲットが PC に接続されていて、電源がオンになって
いることを確認します。

• Experiment → Download → LABCAR を選択しま
す。

または

• Download ボタンの横の▼マークをクリックして 
LABCAR を選択します。
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実験がシミュレーションターゲットにダウンロードさ
れます。

ダウンロードが正常に終了すると、ログウィンドウに
メッセージが出力されます。

実験を実行する：

• Experiment → Start Simulation → LABCAR を選択
してシミュレーションを起動します。

または

• Start Simulation ボタンの横の▼マークをクリック
して LABCAR を選択します。

測定変数の値の変化がオシロスコープ上に表示されま
す。

数秒後、アイドリング回転数が 750 rpm で安定しま
す。
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• エンジン回転数とエアコンスイッチ用パラメータをそ
れぞれ個別の座標系で表示するために、座標軸を右ク
リックして Single Axis per Channel を選択します。

• Y 軸の表示範囲をフルに使用して値が表示されるよう
にするには、その Y 軸を右クリックします。

• ショートカットメニューから Zoom to Fit を選択しま
す。

• 必要に応じて Y 軸をマウスで移動します。

• 次に、作成した “Air Condition” スイッチを使用して
エアコンを ON にします。

トルク負荷の増加によりアイドル回転数が一時的に低
下し、その後、アイドルコントローラにより修正され
ます。
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• エアコンを OFF に戻します。

アイドルコントローラによってペダル位置が補正さ
れ、それによって回転数がやや上昇しますが、それも
すぐに修正されます。

• シミュレーションを停止するには、Stop Simulation 
ボタンをクリックします。

または

• Experiment → Stop Simulation → LABCAR を選択
します。

• 実験を終了するには、Disconnect ボタンをクリック
します。

または

• Experiment → Disconnect → LABCAR を選択しま
す。

• File → Save Experiment を選択します。

• File → Exit を選択します。

次は LABCAR-IP に戻ってハードウェアの設定を行います。

4.4 ハードウェアコンフィギュレーションの設定

このチュートリアルにおいては、実際の HIL 実験を作成することはできませんが、
この項では、このチュートリアルの実装範囲内でのツールの取り扱いと LABCAR-
MCS の各機能の使用方法について説明します。

A/D コンバータハードウェア（ES1651.1 キャリアボードに搭載された

PB1651ADC1 A/D モジュール）を使用すると、0 ～ 10V の電圧信号によってエアコ
ンの ON と OFF を切り替えることができます。

ハードウェアコンフィギュレーションを作成する：

• LABCAR-IP を開きます。

• Project → RTIO Editor を選択します。

または
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• Edit Hardware Configuration ボタンをクリックし
ます。

または

• ハードウェアモジュールを選択してショートカットメ
ニューを開き、Edit を選択します。。

RTIO エディタが開きます。プロジェクト作成時に指
定したシミュレーションターゲット（この例では

RTPC）が、すでに HWC アイテムツリーに組み込ま
れています。

• シミュレーションターゲット "RTPC" の下の

“Domain” システムを選択します。

• Edit → Add Item を選択します。

“Add Items” ダイアログボックスが開きます。

• “ES1651-CB” というアイテムを選択します。
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• OK をクリックします。

キャリアボード ES1651.1 がハードウェアコンフィ
ギュレーションに追加されます。

• “Items” リストからこの新しいアイテムを選択しま
す。

• Edit → Add Item を選択し直します。

• “Add Items” ダイアログボックスか
ら、“PB1651ADC1” というアイテムを選択します。

• OK をクリックします。

A/D コンバータモジュール PB1651ADC1.1 がハード
ウェアコンフィギュレーションに追加されます。

• “Signals” タブを選択します。

• シグナル “AnaIn_0” を選択します。

• “Operating Mode” 列のセルをダブルクリックしま
す。
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• 動作モードとして “Comparator” を選択します。

• “Threshold [V]” 列のセルをダブルクリックします。

• 5.0（V）という値を入力します。

これにより、チャンネルがコンパレータとして定義さ
れ、電圧が 5V 未満の時にはシグナル値は “0”、そう
でない時には “1” とみなされるようになります。

• Accept をクリックします。

• File → Save を選択します。

• File → Exit を選択して LABCAR-RTC を閉じます。

4.5 入力ポートの追加

ハードウェアをモデルシグナルに接続する前に、LABCAR 入力ポートと出力ポート
をモデルに追加する必要があります。

入力ポートを追加する：

• プロジェクトエクスプローラで “Idlecontroller” モデ
ルを選択します。

• ショートカットメニューから Edit を選択します。

プロジェクトに属するモデルが Simulink で開きます。
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• “Pedal2Nengine” ブロックが開いていない場合は、
ダブルクリックして開きます。

ここで、“AirConditionManual” パラメータを A/D コンバータハードウェアからモ
デルに入力されるようにします。このためには、当該シグナルについて、Constant
ブロックの代わりに LABCAR 入力ポートをモデルに追加する必要があります。

• Simulink で、View → Library Browser を選択しま
す。

Simulink ライブラリブラウザ（“Simulink Library 
Browser”）が開きます。

• “LABCAR Port Blocks” ライブラリを開きます。
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• マウスを使用して、入力ポートをモデル内までドラッ
グします。

• “AirConditionManual” ブロックを削除します。

• LABCAR 入力ポートの名前を

“AirCondition_Manual” に変更します。

• 空いている入力にこの LABCAR 入力ポートを接続し
ます。

• File → Save を選択して変更内容を保存します。
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4.6 コネクションマネージャでのシグナルの接続

A/D コンバータからのシグナル（“0” または “1”）を、コネクションマネージャで
モデル入力 “AirConditionManual” に接続します。

LABCAR-OPERATOR でコネクションマネージャを起動する：

• LABCAR-OPERATOR V5.4.0 のメインウィンドウ内の

“Connection Manager” タブを選択します。

コネクションマネージャ（“Connection Manager”）
が開きます。

• Update Ports をクリックして、すべてのハードウェア
とモデルポートの表示を更新します。

モデルとハードウェア間のコネクションを作成する：

• マウスを使用して、ハードウェア出力（“AnaIn_0”）
とモデル入力（“AirConditionManual”）を選択しま
す。
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• 下図のアイコンをクリックして、選択したシグナルを
接続します。

または

• マウスを使用して出力を選択し、接続先の入力までド
ラッグします。
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「コネクション」が作成され、“Existing Connections”
フィールドに表示されます（ただし、新しく作成され
たコネクションを非表示にするフィルタが有効になっ
ている場合は表示されません）。

接続された出力ポートと入力ポートは、青で表示され
ます。

• File → Save All を選択して変更内容を保存します。

4.7 リアルタイムオペレーティングシステムのコンフィギュレーション

LABCAR-OPERATOR は、新しいプロジェクトが作成されるたびに、そのプロジェク
ト用に標準 OS コンフィギュレーションを 1 つ作成します。このコンフィギュレー
ション内には、必要なタスクがすべて定義され、すべてのプロセスが各タスクに適
切に割り当てられています。

ここでは、以下の説明に従って OS コンフィギュレータを起動し、コンフィギュレー
ションの内容を確認してみましょう。詳細は、『LABCAR-OPERATOR V5.4.0 - ユー
ザーズガイド』を参照してください。

OS コンフィギュレータを起動する

• LABCAR-IP のメインウィンドウ内の “OS 
Configuration” タブを選択します。

“OS Configuration” ダイアログボックスが開きます。
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• すべての情報を見られるようにするには、両方のツ
リー表示内のエレメントをすべて展開し、▼ をクリッ
クします。

• Update Processes をクリックします。

“Processes” フィールドには、ハードウェアとモデル
のすべてのプロセスが表示され、“Tasks” フィールド
には自動的に作成されたすべてのタスクとそれに割り
当てられたプロセスが表示されています。

これによって自動的に割り当てられた内容が有効にな
ります。

• File → Save を選択して変更内容を保存します。

4.8 実験の実行

この項では、実験を実行する前に行う最後のステップについて、以下の手順に従っ
て説明します。

1. コードを生成する：（59 ページ）

2. インストゥルメント用に新しいレイヤを作成する：（60 ページ）

3. 測定変数 “ をオシロスコープに表示する：（61 ページ）

4. シグナルチェーンを開く（62 ページ）

5. ADC モジュールに電源を供給する：（64 ページ）

6. 実験を開始する：（64 ページ）

コードを生成する：

• プロジェクト作成時に指定したシミュレーションター
ゲットが PC に接続されていて、電源がオンになって
いることを確認します。
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• Project → Build を選択します。

• コード生成を行うモジュールを選択します。

• Build をクリックします。

モデル、ハードウェアコンフィギュレーション、およ
びコネクションマネージャ用のコード生成が開始さ
れ、実行ファイルが生成されます。

• “Messages” タブで、ビルドプロセスが正常終了した
ことを確認します。

エラーが発生した場合は、別のウィンドウが開き、そ
こにエラーについての詳細が表示されます。

• Experiment Environment ボタンをクリックします。

LABCAR-EE が起動して実験が開きます。

“Instrumentation” タブには、作成したオシロスコープとエアコンスイッチのレイヤ
が含まれています。この時点においてこのスイッチは強調表示され、割り当てられ
たパラメータがすでに存在していないこと（LABCAR 入力ポートと入れ替えられた
ため）を示します。

インストゥルメント用に新しいレイヤを作成する：

• レイヤ名を右クリックして Rename Layer を選択し
ます。

• レイヤ名に新しい名前（例： “Experiment without 
haredware”）を付けます。
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• レイヤ名が表示されたタブを右クリックして Create 
Layer を選択します。

• 新しいレイヤに名前（例： “Experiment with 
hareware”）を付けます。

測定変数 “ をオシロスコープに表示する：

• 新しいレイヤ上にエンジン回転数を表示するオシロス
コープを作成するため、ツールバーの Add 
Oscilloscope ボタンをクリックします。

• エンジン回転数を表示するための測定変数
“IdleController/Pedal2NEngine/TorqueToNEngine/
Out” を、ドラッグアンドドロップでオシロスコープ
に追加します。

• さらに、新しいモデル入力 “AirConditionManual” も
追加します。

• 実験をシミュレーションターゲットにダウンロードし
ます。

• シミュレーションを開始します。

アイドル回転数がデフォルト値に到達します。ハード
ウェア入力に電圧が存在していないた
め、“AirConditionManual” の値は 0 になり、D/A コ
ンバータは出力信号を出力しません。
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I/O ハードウェアを使用する際は、以下のセクション内の「シグナルリスト」の機能
につての記述をよくお読みください。

シグナルチェーンを開く

• “Workspace Elements” ウィンドウで、作成済みのモ
デル入力 ”AirConditionManual” を選択して右クリッ
クします。

• ショートカットメニューから Signal → Trace を選択し
ます。

“Select the Tracing Mode” ダイアログボックスが開き
ます。

• “backward” と “<New Group>” を選択して OK をク
リックします。

“Signal List” というタイプの新しいインストゥルメン
トが開きます。

コネクションマネージャで作成した A/D コンバータモ
ジュールとモデルポート間のコネクションが表示され
ます。

• マウスでシグナリストの内部をクリックします。
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• “Properties” ウィンドウで、“Label Format” を

“%HIERARCHY0” から “％HIERARCHY2” に変更し
ます。

シグナル名にシグナルパスが付加されます。

• このコネクションを一時的に切断するため
に、“Mode” 列のリストから “CONST” を選択しま
す。

“Constant” 列の定数値がこの入力に供給されます。

• シミュレーションを開始します。
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• “Constant” 列の値を 1 に変更します（値を入力して 
<Enter> で確定します）。

アイドル回転数がやや低下し、その後、修正されま
す。

• “Constant” 列の値を 0 に戻します（値を入力して 
<Enter> で確定します）。

アイドル回転数が通常挙動に戻り、修正されます。

• この後はハードウェアによる操作を行うの
で、“Mode” を “MODEL” に戻します。

ADC モジュールに電源を供給する：

• 電圧の調整が可能な電源（0 ～ 10V）を入力チャンネ
ル 0 に接続します。正面パネルのコネクタについての
情報は、『PB1651ADC1 A/D Module － User's Guide』
を参照してください。

実験を開始する：

• プロジェクト作成時に指定したシミュレーションター
ゲットが接続されていて、電源が ON になっているこ
とを確認します。

• Experiment → Download → LABCAR を選択しま
す。

または

• Download ボタンの横の▼マークをクリックして 
LABCAR を選択します。

実験ターゲットに実験がダウンロードされます。

ダウンロード処理が正常に終了すると、“Message”
タブにメッセージが出力されます。
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• Experiment → Start Simulation → LABCAR を選択
します。

または

• Start Simulation ボタンの横の▼マークをクリック
して LABCAR をクリックします。

実験が起動します。

供給電圧が定義されたしきい値より低いうち
は、“AirCondirionManual” シグナルは 0 で、アイド
ル回転数はデフォルト値 750 rpm を保ちます。

シグナルリストにも “0” という値が表示されます。

• ここで電圧を変え、コンパレータのしきい値（5V）よ
り高くなるようにします。

エアコンが ON に切り替わります
（“AirCondition_Manual” ＝ 1）。するとトルク負荷が
増えるためアイドル回転数が一時的に低下し、その
後、修正されます。

• 電圧を下げて、再びコンパレータのしきい値より低く
します。

オーバーシュートの後、アイドル回転数が修正されて
安定します。

• 実験を停止するため、Stop Simulation ボタンをク
リックします。

または

• Experiment → Stop Simulation → LABCAR を選択
します。
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4.9 データロガー（“Datalogger”）による記録

この項では、データロガーでシグナルを記録する方法について説明します。

ここではエアコンの ON/OFF 状態の遷移をデータロガーで記録します。

データロガーを作成する：

• LABCAR-EE のワークスペースで “Datalogger” タブを
選択します。

• “Available Dataloggers” フィールドの Add をクリッ
クします。

新しいデータロガーが追加されます。

データロガーを設定する：

• シグナルをデータロガーに追加するために、エレメン
トリスト内の測定変数 “Out” を選択します。
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• 左マウスボタンを押して、エレメントをデータロガー
ウィンドウ上にドラッグします（次の図を参照してく
ださい）。

シグナルが、記録されるシグナルのリストに追加され
ます。

• 続いてモデル入力 “AirConditionalManual” もデータ
ロガーに追加します。

• データロガーが記録を行うタスク（ここでは

“Acquisition”）を選択します。

記録されたデータが保存されるファイルの基本名（“base name”）は、“Recording 
File Settings” フィールドの “Recording Base filename” に表示されていますが、こ
れは以下のようにして任意に変更することができます。

記録データ用ファイルを選択する：

• 異なる基本名を使用するには、... ボタンをクリックし
ます。
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記録が実行されるたびに生成されるファイルの名前の
詳細は、“Auto Increment” で指定します。

“Auto Increment” オプションをオンにすると、ファ
イル名に数字が付加され、データロガーが起動される
たびにその数字が自動的にインクリメントされま
す。“Digits” フィールドでこの数字の桁数を指定でき
ます。

マニュアル操作でデータロガーを起動する：

• シミュレーションを開始します。

• データロガーを起動します（“Active” 列をクリックし
ます）。

• 記録を開始するため、青い矢印をクリックします。

データロガーが記録を開始します。

• 記録を終了するには再度青い矢印をクリックします。

データロガーが記録を終了し、データをファイル
（*.dat）に保存します。

注記

データロガーは、シミュレーションが実行されていな
いと起動できません。
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記録の開始と終了を自動的に行うには、以下のようにしてトリガ条件を定義します。

トリガ条件と記録時間を定義する：

• “Trigger Settings” フィールドの右下部の ... ボタンを
クリックします。

トリガ設定エディタが開きます。

• “Filter Type” フィールドで “Start Trigger Filter” を選
択します。

• “Trigger Condition” フィールドで以下の内容を設定
します。

－ First Operand (Signal): AirConditionManual

－ Operator: >

－ Threshold: 0
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• “Trigger Timming” フィールドで以下の内容を設定し
ます。

－ Pre Trigger Time: 0 s

－ Post Trigger Time: 10 s

• OK をクリックします。

• “Active” 列でデータロガーを起動します。

• 電圧を供給してエアコンを ON に切り替えてくださ
い。

トリガ条件が満たされるとデータロガーが記録を開始
し、10 秒後に記録が終了します。
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5 ETAS ネットワークマネージャ

ETAS ネットワークマネージャは、ETAS IP マネージャが使用するコンフィギュレー
ション（ネットワーク構成）を作成するためのツールです。IP マネージャは、ネッ
トワーク接続された ETAS ハードウェアのダイナミック IP アドレッシングを行う役
割を果たします。

5.1 概要

ETAS ソフトウェアからイーサネット経由でハードウェアシステムにアクセスするに
は、以下のいずれかの方法で行えます。

1. 複数のネットワークアダプタ（イーサネットカード）をそれぞれ各ネット
ワークに使用

－ 1 つのアダプタを社内 LAN に使用

－ 1 つまたは複数のアダプタを ETAS ハードウェアに使用

2. 1 つのネットワークアダプタを共有

－ 社内 LAN と ETAS ハードウェアとを自動切り替え

ETAS ネットワーク環境の管理は、ETAS の「ネットワークマネージャ」を使用して
容易に行うことができます。

ネットワークマネージャには、PC にインストールされているネットワークアダプタ
の一覧と、各アダプタの IP アドレス割り当て状況が表示されます。システム内に 2
つ以上のネットワークアダプタがインストールされている場合は、ここでどちらの
アダプタを ETAS ハードウェア用に使用するかを選択します。また、ETAS ハード
ウェア用に使用される IP アドレスの領域（「アドレスプール」と呼ばれます）もここ
で指定できます。

ネットワークアダプタを選択したり ETAS ハードウェア用のネットワーク環境を構成
する際、管理者の権限は必要ありません。また ETAS ネットワークと社内 LAN の切
り替え時に PC を再起動する必要はありません。

5.2 ETAS ハードウェアのアドレス構成

ETAS ネットワークでは複数の ETAS デバイスを PC に接続することができ、同種の
デバイスを複数接続することも可能です。ETAS ローカルネットワークに接続された
各デバイスは、それぞれユニークな IP アドレスで認識されます。

ETAS ソフトウェアに組み込まれた IP マネージャは、定義済みアドレスプールの中か
ら使用できる IP アドレスを探し出し、接続された各 ETAS ハードウェアに割り当て
ます。

アドレスプールのアドレス領域は、ETAS ネットワークマネージャ上で構成します。

注記

ETAS ハードウェアで構成される ETAS ネットワークを PC に接続する際は、PC 側
に専用のネットワークアダプタを用意する必要はありません。社内 LAN と ETAS
ネットワークとで 1 つのネットワークアダプタを共有できます。

注記

ETAS ネットワークマネージャでは、ネットワークアダプタを新しく追加したり、
ネットワークアダプタ自体の構成変更を行うことはできません。これらの操作は

Windows のコントロールパネルから行ってください（操作方法は Windows のド
キュメントを参照してください）。
なお、この操作には管理者の権限が必要です。
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5.3 ネットワークアダプタのアドレス構成

5.3.1 ネットワークアダプタのアドレッシングタイプ

社内 LAN で使用されるネットワークアダプタのアドレッシングには、オペレーティ
ングシステムの種類やネットワークアダプタのコンフィギュレーションによって、
以下のようなタイプが使用されます。

また ETAS ネットワークがサポートするネットワークアダプタのアドレッシングタイ
プは、以下のとおりです。

1 つのネットワークアダプタを社内 LAN と ETAS ネットワークの両方で共有する場
合、DHCP アドレッシングのみをサポートするネットワークアダプタは使用できま
せん。

5.3.2 ネットワークアダプタアドレスのマニュアル構成

ネットワークアダプタのアドレスをマニュアル操作で設定する方法は、オペレー
ティングシステムによって異なるため、ご使用のオペレーティングシステムのマ
ニュアルを参考にしてください。

ネットワークアダプタのアドレスをマニュアル構成するには、管理者の権限が必要
ですので、詳しくはシステム管理者の方にご相談ください。

ネットワークアダプタのアドレスをマニュアル構成して固定 IP アドレスを割り当て
ていた場合、社内ネットワーク に接続したまま ETAS ハードウェアの検索や初期化
の操作を行ってしまうことを防ぐため、IP アドレスが ETAS ハードウェアに割り当て
られる前に警告が表示されるように、ネットワークマネージャで設定しておくこと
ができます。

オペレーティング
システム

ネットワークアダプタのアドレッシングタイプ

マニュアル構成 DHCP DHCP+APIPA DHCP +
代替 IP アドレス

Windows XP ○ ○ ○ ○

Windows Vista ○ ○ ○ ○

Windows 7 ○ ○ ○ ○

○： 使用可、 －： 使用不可

オペレーティング
システム

ネットワークアダプタのアドレッシングタイプ

マニュアル構成 DHCP DHCP+APIPA DHCP +
代替 IP アドレス

Windows XP ○ － ○ ○

Windows Vista ○ － ○ ○

Windows 7 ○ － ○ ○

○： 使用可、 －： 使用不可

注記

DHCP が使用できるのは、APIPA または代替 IP アドレスが併用されている場合の
みです。
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5.3.3 DHCP によるネットワークアダプタのアドレス構成

DHCP でのアドレッシングを行う場合は DHCP サーバーが利用可能になっている必
要がありますが、DHCP サーバーが存在しない場合や利用不可能である場合（ETAS
ネットワークへの接続時など）、ネットワークアダプタの構成は行えません。

このため、各オペレーティングシステムには、ネットワークアダプタに代替 IP アド
レスを割り当てるための以下のようなメカニズムが用意されています。

Windows XP ／ Windows Vista ／ Windows 7

Windows XP、Windows Vista、Windows 7 では、DHCP サーバーへの接続が確立
されているかどうか自動的に判定され、接続されていない場合は、APIPA によって

IP アドレスが自動的に割り当てられるか、またはユーザー定義の代替 IP アドレスが
使用されます。ETAS ネットワーク内では、APIPA アドレスと代替 IP アドレスのいず
れか使用されます。社内 LAN（DHCP ネットワーク）から ETAS ネットワークへの
切り替えを行う際には、オペレーティングシステムが接続の切断を検知してネット
ワークアダプタの再構成を開始できるよう、10 秒間ほど接続を切断したままにして
ください。オペレーティングシステムによる DHCP アドレスから APIPA アドレスま
たは代替 IP アドレスへの再構成処理には、60 秒ほどを要します。その後、PC を

DHCP ネットワークに再接続すると、DHCP サーバーへの接続が検出された直後に、
ネットワークアダプタが DHCP アドレスに再構成されます。

代替 IP アドレスや APIPA を併用しない DHCP でのネットワークアダプタのアドレス
構成はサポートされていません。

5.4 ユーザーインターフェース

5.4.1 “ETAS ハードウェア用のネットワーク設定（ページ 1）” ウィンドウ － 
ネットワークアダプタの選択

PC に組み込まれているネットワークアダプタに関する以下のような情報が表示され
ます。

• IP アドレス領域の自動構成 チェックボックス

このチェックボックスがオンになっていると、ページ 2 以降の処理がスキッ
プされ、ETAS ネットワークマネージャは、選択されているネットワークアダ
プタが ETAS ハードウェアのアクセスに使用するデフォルト IP アドレス領域
を自動的に割り当てます。IP マネージャによって IP アドレス領域が自動的に
変更されると、その旨を通知するメッセージが Windows のシステムトレイ
に表示されます。
73LABCAR-OPERATOR V5.4.0 - 入門ガイド



74

ETAS ネットワークマネージャ ETAS
• ETAS ネットワークの自動構成 チェックボックス

このチェックボックスがオンになっていると、ページ 2 以降の処理がスキッ
プされ、IP マネージャは、複数のネットワークアダプタの候補の中からいず
れかを選んで自動構成を行います。

このチェックボックスをオンにすると、IP アドレス領域の自動構成 チェック
ボックスが自動的にオンになり、“ 使用可能なネットワークアダプタ ”
フィールド内の一覧表に 自動構成 列が追加されます。この列で、IP マネー
ジャによる自動構成を行うアダプタの候補を選択します。

これにより、ETAS ネットワークマネージャは、現在ウィンドウ内で選択され
ているネットワークアダプタを先頭に、アダプタリストを下の方向へ順に
チェックし、ETAS 用に有効な IP 構成1 を持つネットワークアダプタを見つけ
ると、そのアダプタを使用して IP アドレス領域を自動的に設定します。そし
てそのネットワークアダプタが何らかの原因（無効化されている、物理的に
使用不可になっている、など）により使用できなかった場合、IP マネージャ
は次の使用可能なネットワークアダプタを自動構成し、その際、Windows の
システムトレイに新しい構成を示すメッセージが表示されます。

• 自動構成 列
この列は、ウィンドウ上部の ETAS ネットワークの自動構成 オプションがオ
ンになっている場合にのみ表示されます。ETAS ネットワークマネージャによ
る自動構成が行われる際、ここに表示されるチェックボックスがオンになっ
ているネットワークアダプタのいずれかが使用されます（79 ページ「ETAS
ハードウェア用ネットワークアダプタの自動構成」 参照）。

• 名前 列
ネットワークアダプタの名前です。このウィンドウでは変更できません。

この列には「アダプタなし」というエントリも表示されます。PC にイーサ
ネットハードウェアが接続されていないなどの理由により IP マネージャを無
効にするには、自動構成 列のチェックボックスをオンにしておいてくださ
い。

• IP アドレス 列
ネットワークアダプタの IP アドレスです。このウィンドウでは変更できませ
ん。

• サブネットマスク 列
サブネットマスクの設定です。このウィンドウでは変更できません。

• DHCP 列
ネットワークアダプタが DHCP 用に設定されているかどうかを表わします。

－ Enabled

ネットワークアダプタが DHCP 用に設定されています。

－ Disabled

ネットワークアダプタが固定 IP アドレス用に設定されています。

• 代替 IP コンフィギュレーション 列
DHCP 設定のネットワークアダプタの代替 IP アドレスが表示されます。表示
内容はオペレーティングシステムに応じて異なります。

－ APIPA

Automatic Private IP Addressing： ネットワーク接続用の IP コンフィギュ
レーションの自動化を行います。

1. ネットワークアダプタが固定 IP アドレスを使用している場合、または DHCP と APIPA
が有効なっている場合、IP 構成は「有効」です 。
LABCAR-OPERATOR V5.4.0 - 入門ガイド



ETAS ETAS ネットワークマネージャ
－ ---

代替 IP アドレスがありません。

－ ユーザー定義

代替 IP アドレスをユーザー定義することができます（Windows XP ／

Windows Vista の場合）。

5.4.2 “ETAS ハードウェア用のネットワーク設定（ページ 2）” ウィンドウ － ア
ドレスプールの定義

各アドレスの値の変更は、キー入力によって直接編集するか、またはリストボック
スからデフォルト設定を選択します。

以下のネットワークパラメータを設定できます。

• 先頭アドレス

ETAS ハードウェア用の IP アドレス領域の 1 番目のアドレスです。

• 最終アドレス

ETAS ハードウェア用の IP アドレス領域の最後のアドレスです。

• サブネットマスク

使用するサブネットマスクです。

予約済み IP アドレス

ETAS ハードウェアが現在使用している IP アドレス領域（192.168.40.1 ～ 
192.168.40.254、サブネットマスク 255.255.255.0）のうち、以下の IP アドレス
は、ETAS の特定のハードウェア用に予約されています。

これらのアドレスは特定のデバイスにのみ使用でき、他の ETAS ハードウェアには使
用できません。アドレスプールを定義する際は、この点を考慮する必要があります。

IP アドレス ETAS ハードウェア

192.168.40.10 ES1120

192.168.40.11 ES1130

192.168.40.12 ES780

192.168.40.13 （予約済み）

192.168.40.14 ETAS Real-Time PC

192.168.40.15 ES1135
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5.4.3 “ETAS ハードウェア用のネットワーク設定（ページ 4）” ウィンドウ － 警
告表示の設定

このウィンドウは、選択されたネットワークアダプタのアドレスがマニュアル設定
されている場合にのみ開きます。

ここでは以下のオプションを設定します。

• IP アドレスが割り当てられる時に警告を表示

このオプションが有効になっていると、ETAS ハードウェアデバイスに IP ア
ドレスが割り当てられる際に、前もって警告メッセージが表示されます。

注記

この警告メッセージは、当該ネットワークアダプタで、社内 LAN と、ETAS
ネットワーク内の ETAS 測定モジュールの両方に接続する場合にのみ意味を持
ちます。
LABCAR-OPERATOR V5.4.0 - 入門ガイド



ETAS ETAS ネットワークマネージャ
5.5 ETAS ハードウェア用のネットワークアドレスの設定

5.5.1 ネットワークアダプタのマニュアル設定

ETAS ハードウェア用ネットワークアダプタを設定する：

• Windows のスタートメニューから、プログラム → 
ETAS → <ETAS ソフトウェア名 > → ETAS ネット
ワーク設定（または ETAS Network settings） を選
択します。

“ETAS ハードウェア用のネットワーク設定（ページ

1）” ウィンドウが開きます。

• “ 使用可能なネットワークアダプタ ” フィールドで、
社内 LAN と ETAS ネットワーク用に使用したいネット
ワークアダプタを選択します。PC にネットワークア
ダプタが組み込まれていない場合、このフィールドに
はエントリが表示されます。

注記

ここでは、ETAS ネットワークがサポートするタイプの
ネットワークアダプタしか選択できません。
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• 次へ をクリックします。

“ETAS ハードウェア用のネットワーク設定（ページ

2）” ウィンドウが開きます。

• ETAS ハードウェア用の IP アドレスの領域とサブネッ
トマスクを入力します。

または

• デフォルト をクリックすると、ネットワークマネー
ジャが自動的に IP アドレス領域とサブネットマスク
を設定します。

• 次へ をクリックします。

“ETAS ハードウェア用のネットワーク設定（ページ

4）” ウィンドウが開きます。
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• ETAS ハードウェアへ IP アドレスが割り当てられる際
に前もって警告メッセージが表示されるようにするに
は、IP 割り当てが行われる時に警告を表示 オプション
をオンにします。

• 終了 をクリックします。

ネットワークアダプタの設定が終了し、ウィンドウが
閉じます。変更された内容はすべて保存されます。

• 変更内容が有効になるように、ETAS ソフトウェアを
再起動します。

ETAS ソフトウェアでのハードウェア検索時または初
期化時に自動的にネットワークマネージャが呼び出さ
れた場合は、再起動は必要ありません。

5.5.2 ETAS ハードウェア用ネットワークアダプタの自動構成

ETAS ネットワークマネージャでは、ETAS ネットワーク内の IP アドレス領域が IP マ
ネージャによって自動設定されるようにすることができます。その際は、選択した
ネットワークアダプタの自動構成を行うか、または複数のネットワークアダプタが
使用可能な場合、選択した複数のアダプタから IP マネージャに ETAS ネットワーク
を自動構成させることもできます。

選択したネットワークアダプタを ETAS ハードウェア用に自動構成する：

• Windows のスタートメニューから、プログラム → 
ETAS → <ETAS ソフトウェア名 > → ETAS ネット
ワーク設定（または ETAS Network settings） を選
択します。

“ETAS ハードウェア用のネットワーク設定（ページ

1）” ウィンドウが開きます。

注記

この警告は、当該ネットワークアダプタで、社内 LAN
と、ETAS ネットワーク内の ETAS 測定モジュールの両
方に接続する場合にのみ意味を持ちます。
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• 使用可能なネットワークアダプタフィールドで、ETAS
ネットワーク用に使用したいネットワークアダプタを
選択します。

ここでは、ETAS ネットワークがサポートするアド
レッシングが指定されているネットワークアダプタし
か選択できません。

• IP アドレス領域の自動構成 チェックボックスをオン
にします。

• 終了 をクリックします。

これにより、選択されたネットワークアダプタが

ETAS ハードウェアにアクセスする際に自動的にデ
フォルトの IP アドレス領域が割り当てられるように
なります。

これ以降、IP マネージャによって IP アドレス領域が自動的に変更されると、その旨
を通知するメッセージが Windows のシステムトレイに表示されます。

使用可能な複数のネットワークアダプタから、ネットワークアダプタを自動構成す
る：

• Windows のスタートメニューから、プログラム → 
ETAS → <ETAS ソフトウェア名 > → ETAS ネット
ワーク設定（または ETAS Network settings） を選
択します。

“ETAS ハードウェア用のネットワーク設定（ページ

1）” ウィンドウが開きます。

• ネットワークの自動構成 チェックボックスをオンにし
ます。

IP アドレス領域の自動構成 チェックボックスが自動
的にオンになり、 “ 使用可能なネットワークアダプタ 
フィールド ” 内の一覧表に 自動構成 列が追加されま
す。

• IP マネージャによる自動構成の対象にできるすべての
アダプタについて、自動構成 列のチェックボックスを
オンにします。

• 終了 をクリックします。
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これ以降、ETAS ネットワークマネージャは、現在ウィンドウ内で選択されている
ネットワークアダプタを先頭に、アダプタリストを下の方向へ順にチェックし、

ETAS 用に有効な IP 構成1 を持つアダプタを見つけると、そのアダプタを使用して IP
アドレス領域を自動的に設定します。そしてそのネットワークアダプタが何らかの
原因（無効化されている、物理的に使用不可になっている、など）により使用でき
なかった場合、IP マネージャは次の使用可能なネットワークアダプタを自動構成し、
その際、Windows のシステムトレイに新しい構成を示すメッセージが表示されま
す。

5.5.3 レジストリ内の APIPA の有効化

レジストリを変更して APIPA を有効にする：

• Windows の スタート メニューから ファイル名を指
定して実行 を選択します。

• regedit と入力して OK をクリックします。

レジストリエディタが開きます。

• ネットワークアダプタに関する以下のフォルダを選択
します。

グローバルキー（すべてのネットワークアダプタにつ
いてのキー）

HKEY_LOCAL_MACHINE¥SYSTEM¥
CurrentControlSet¥Services¥Tcpip¥
Parameters

各インターフェースまたはカード固有のキー

HKEY_LOCAL_MACHINE¥SYSTEM¥
CurrentControlSet¥Services¥Tcpip¥
Parameters¥Interfaces¥adapter_name

• IPAutoconfigurationEnabled というキーの
値を 1 に設定します。

APIPA メカニズムが有効になります。

1. ネットワークアダプタが固定 IP アドレスを使用している場合、または DHCP と APIPA
が有効なっている場合、IP 構成は「有効」です 

注記

レジストリの編集を行うに、は管理者権限が必要です。

注記

上記のどちらのキーも存在しない場合は、APIPA メカ
ニズムは有効になっています。グローバルキーが存在
するけれども有効になっていない場合には、グローバ
ルキーの設定により APIPA の有効／無効が決まります。
グローバルキーが存在しないかまたは有効になってい
る場合には、カード固有のキーの設定により APIPA の
有効／無効が決まります。
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6 お問い合わせ先

製品に関するご質問等は、各地域の ETAS 支社までお問い合わせください。

ETAS 本社

ETAS GmbH

日本支社

イータス株式会社

その他の支社

上記以外の各国支社および技術サポート窓口につきましては、ETAS ホームページを
ご覧ください。

Borsigstrasse 14 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany WWW: www.etas.com/

〒 220-6217

神奈川県横浜市西区 Phone: (045) 222-0900

みなとみらい 2-3-5 Fax: (045) 222-0956

クイーンズタワー C 17F WWW: www.etas.com/

各国支社 WWW: www.etas.com/ja/contact.php

技術サポート WWW: www.etas.com/ja/hotlines.php

http://www.etas.com/ja/hotlines.php
http://www.etas.com/
http://www.etas.com/
http://www.etas.com/ja
http://www.etas.com/ja
http://www.etas.com/ja/contact.php
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