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1 Introduction

This manual contains a description of the INCA add-on ODX-LINK for ODX-based
ECU diagnostics.

1.1 Intended Use
INCA and INCA add-ons are developed and approved for automotive applications
and procedures as described in the user documentation for INCA and INCA add-
ons.

ODX-Link adds diagnostic functionality to INCA and makes diagnostic data avail-
able as measurement signals in INCA. ODX-Link supports various "Protocols " on
page 12.

INCA and the INCA add-ons are intended to be used in industrial labs and in test
vehicles.

ETAS GmbH cannot be made liable for damage that is caused by incorrect use
and not adhering to the "Safety Information" on the next page.

1.2 Target Group
This software product and this user guide address qualified personnel working in
the fields of automotive ECU development and calibration, as well as system
administrators and users with administrator privileges who install, maintain, or
uninstall software. Specialized knowledge in the areas of measurement and ECU
technology is required.

1.3 Classification of Safety Messages
Safety messages warn of dangers that can lead to personal injury or damage to
property:

DANGER

DANGER indicates a hazardous situation that, if not avoided, will result in death
or serious injury.

WARNING

WARNING indicates a hazardous situation that, if not avoided, could result in
death or serious injury.
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CAUTION

CAUTION indicates a hazardous situation that, if not avoided, could result in
minor or moderate injury.

NOTICE
NOTICE indicates a situation that, if not avoided, could result in damage to
property.

1.4 Safety Information
Observe the following safety information when working with INCA and INCA add-
ons:

WARNING

Risk of unexpected vehicle behavior

Calibration activities influence the behavior of the ECU and the systems that
are connected to the ECU.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Only perform calibration activities if you are trained in using the product and
can assess the possible reactions of the connected systems.

WARNING

Risk of unexpected vehicle behavior

Sending messages via bus systems, such as CAN, LIN, FlexRay, or Ethernet,
influences the behavior of the systems connected to it.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Only perform the sending of messages via a bus system if you have sufficient
knowledge in using the respective bus system and can assess the possible
reactions of the connected systems.
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WARNING

Risk of unexpected vehicle behavior

Invoking diagnostic functions or sending diagnostic messages affects the beha-
vior of the ECU and the systems connected to it.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Only invoke diagnostic functions or send diagnostic messages if you have suf-
ficient knowledge in using diagnostic functions.

WARNING

Risk of unexpected vehicle behavior

ODX consistency errors in the ODX files can result in INCA runtime errors.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Do not use the respective ODX files if relevant diagnostic functions are
affected by inconsistencies.

Adhere to the instructions in the ETAS Safety Advice and the safety information
given in the online help and user guides.

Open the ETAS Safety Advice in the INCA help menu ? > Safety Advice.

1.5 Data Protection
If the product contains functions that process personal data, legal requirements
of data protection and data privacy laws shall be complied with by the customer.
As the data controller, the customer usually designs subsequent processing.
Therefore, he must check if the protective measures are sufficient.

1.6 Data and Information Security
To securely handle data in the context of this product, see the INCA Help section
“Data and Information Security”.
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2 About ODX-LINK

This chapter contains a general introduction to ECUs and the ODX standard. The
characteristics of ODX-LINK are also described.

2.1 Tasks of an ECU
Nowadays a modern car without electronic components is unthinkable. Every unit
of a motor vehicle contains electronics: from the lights through electrically pro-
pelled starters to completely modern components like ABS and ESP.

Today's vehicles have a large number of ECUs – virtually every electronic function
has its own ECU or uses an ECU. Every ECU executes different tasks. These func-
tions can be divided into three categories:

Controlling tasks

Communication with other ECUs

Diagnostics

Controlling Tasks
Every ECU has its own specific function area, for example gearbox, engine, or
door ECU. The data the ECUs need to fulfil their tasks is received from a large
number of analog and digital sensors. The ECUs receive additional data via the
vehicle's bus systems (onboard communication). For example, the gearbox
sends information about the gear currently selected to the engine ECU so that
the latter can calculate the correct ignition time.

In addition to the actual acquisition of data (sensor system), actuating elements
play an extremely important role. Target values calculated by the ECU are con-
verted to physical values (voltage, pressure etc.) using various actuators.

Communication Tasks
Normally an ECU requires information from other ECUs to carry out its controlling
tasks. The resulting communication with other ECUs is referred to as onboard
communication. This involves an ECU sending information on the bus system and
all other ECUs checking to see whether they need this information.

Diagnostic Tasks
The third category of task of an ECU, after the controlling tasks and com-
munication, is diagnostics. The increased volume of electronic components
inside the vehicle is providing more and more diagnostic options. Communication
between ECUs and diagnostic devices is referred to as offboard as the dia-
gnostic system is not part of the vehicle. The diagnostic system provides
developers and technicians with a lot of failure-specific and vehicle information
which helps them to solve vehicle problems and optimize vehicle performance.
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2.1.1 Diagnostics
Development engineers and technicians use the diagnostic functions to
exchange data with the ECU. This makes it easier to detect faults and to optimize
vehicle performance. When a fault occurs, for example wrong ignition timing, all
relevant parameters are stored in the fault memory of the ECU. The technician
reads this information using the diagnostic functions to find the cause of the
fault.

Developers can also use the diagnostic functions to acquire up-to-date inform-
ation on the behavior of the ECU under normal operating conditions.

Diagnostic functions can also be used during production. Internal test results can
be checked or the serial number of the ECU is read to guarantee a faultless
device.

2.2 The ODX Standard
The ODX standard (ASAMMCD 2D) standardizes the formal description of inform-
ation in the vehicle and ECU diagnostic sector – ODX stands for "Open Diagnostic
Data Exchange".

A vehicle-external repair shop tester is connected to the network of these ECUs
via a special data interface, called the diagnostic interface. The tester exchanges
information with the ECUs and uses message-oriented protocols for this pur-
pose. These protocols are usually standardized (KWP2000 in acc. with ISO14230,
UDS in acc. with ISO14229 etc.).

The ODX specification contains the data model for describing all diagnostic data
of a vehicle/ECU. ODX is described with UML diagrams (Unified Modelling Lan-
guage) – the format for data exchange is XML (eXtensible Markup Language).

The ODX specification enables the following:

The transfer of diagnostic data and program data between system sup-
pliers, vehicle manufacturers and repair shops in accordance with the
single-source principle.

The communication of an offboard tester with the ECUs and the sub-
sequent interpretation of the data contained in the messages without test
equipment having to be specifically programmed for this purpose.

The following figure shows an overview of the ISO standards and ASAM spe-
cifications for MCD systems.
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Fig. 2-1: ISO Standards and ASAM Specifications

Using the standardization

of the API to the vehicle hardware interface (ISO 22900-2: D-PDU API),

the diagnostic data model (ISO 22901-1 ODX) and

the interface between the runtime system and the test application
(ISO/CD 22900-3: D-Server API),

it is possible, depending on the application, to combine the best hardware with
the desired runtime system and the most suitable application.

2.3 ODX-LINK
ODX-LINK adds diagnostic functionality to INCA – once ODX-LINK has been
installed, there are additional dialog boxes available for ECU diagnosis in the INCA
Experiment Environment. ODX-LINK makes it possible for you to access the fault
memory, for example, during calibration and display the diagnostic information in
plain text.

ODX-LINK processes diagnostic data using the ODX description – the user can
select and run every diagnostic service described in ODX.

ODX-LINK determines all information necessary for sending the service, sends
this to the ECU using the connected hardware, receives the response of the ECU
with the same hardware and then decodes the response for the user.

ODX Standard
ODX-LINK supports ODX files (including PDX = Packaged ODX) and the binary
databases created with DTS-Venice which correspond to the "ASAMMCD 2D
(ODX) V2.0.1 and V2.2" specification. This thus guarantees the use of single-
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source databases throughout the entire development cycle – new imple-
mentation of diagnostic information, which is both expensive and prone to errors,
is thus no longer necessary.

Protocols
ODX-LINK is available as an add-on to INCA – together with INCA, ODX-LINK sup-
ports the following protocols for the serial ECU interfaces:

UDSonCAN (ISO 14229-1 / ISO 15765-3 on ISO 15765-2)

KWPonCAN (ISO 14230-3 on ISO 15765-2)

OBDonCAN (SAE J1979 / ISO 15031-5 on ISO 15765-4)

OBDonUDS (SAE J1979-2 on ISO 15765-4)

ZEVonUDS (J1979-3 on ISO 15765-4)

DoIP (ISO 14229-5 on ISO 13400-2)

Hardware Support
Amongst others1) , ODX-LINK supports the following ETAS measure and cal-
ibration hardware:

ES59x Interface Modules

ES58x

ES8xx

ES910 Rapid Prototyping Module / ES921 CANModule

By using ETAS hardware, measure, calibration and diagnostic access to the ECU
are possible both from a user interface and via a hardware interface, e.g. UDS on
CAN. This means software and hardware costs can be saved and valuable time
gained to spend on development.

ODX-LINK and INCA
But ODX-LINK offers a great deal more than the special dialog boxes for querying
diagnostic data: The diagnostic data that can be queried by the ECU (via the dia-
gnostic interface) can be used as normal measurement signals in INCA. This
means that all INCA functions that are available for measurement signals can also
be used for diagnostic data:

configuration of measure windows with diagnostic signals in the exper-
iment via the variable selection

definition of trigger conditions based on diagnostic signals

definition of calculated signals

recording of diagnostic data in INCA measure files

1) Generally, ODX-LINK supports all INCA hardware with a CAN port – the following is
simply a list of a few examples.
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Diagnostic data can thus be measured together with standard INCA measure
data acquired address-based via measure interfaces such as, for example, ETK,
CCP and XCP, and recorded and analyzed in a commonmeasure file. Among
other things, this makes it possible to validate and evaluate diagnostic data more
precisely and efficiently than before.

2.4 Working with ODX Projects
The ODX project is part of the INCA workspace – the ODX project and the logical
link are assigned in the Hardware Configuration Editor and saved with the work-
space.

This standardizes the operation of ODX-LINK and experiments of one workspace
can use different ODX-LINK windows and settings.

Quick Access to Example Data Bases
You can import example data bases via *.exp files from the following folder:

..\ETASData\INCA7.5\ODX

Quick Access to ODX Project Files
You can find *.pdx files according to different versions of the OBD SAEJ1979
standard in the following folder:

..\ETASData\ODX7.5\Projects

2.4.1 Procedure
This section takes a brief look at the procedure in INCA – for more details, refer to
the tutorial:

"ODX-LINK Tutorial" on page 72.

Create amain directory andworkspace.

Add an ECU project if necessary.

This step can be skipped (see "Diagnostics without an A2L File" on the next
page).

Read in theODX project.

For ODX projects, you can use the following file formats: *.pdx, *.odx-*,
*.xprj, *.prj.

With ODX V2.2, a consistency check is executed after the import of the pro-
ject. The consistency check report of the last imported ODX V2.2 project
can be found in \ETAS\LogFiles\ODX.

For a ODX V2.0.1 project, no consistency check is performed. Therefore, an
imported ODX project of the INCA database can have three different con-
sistency states. When you click on the project, the state is displayed:
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l consistent: ODX projects without consistency errors
l not consistent: ODX projects with consistency errors
l consistency state unknown: for ODX V2.0.1 projects that have not been
checked

WARNING

Risk of unexpected vehicle behavior

ODX consistency errors in the ODX files can result in INCA runtime errors.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Do not use the respective ODX files if relevant diagnostic functions are
affected by inconsistencies.

Add a hardware configuration (see "Automatic Search for and Con-
figuration of OBDonCAN Devices and OBDonUDS Devices" on the next
page).

In the Hardware Configuration Editor: Device > Add.

ODX configuration

In the Hardware Configuration Editor: Hardware >Configure ODX. Select
the ODX project.

Logical link mapping (assignment of a logical link of the ODX project to the
INCA device).

Add experiment and assignworkspace.

2.4.2 Diagnostics without an A2L File
Communication with the connected ECUs is established during hardware -ini-
tialization. The communication parameters necessary for this can be defined in
A2L or ODX files and must correspond to the ECUs.

A different set of parameters is also required for each protocol (KWP2000, UDS,
CCP, XCP, etc.). A2L files normally contain parameters for a specific protocol and
a specific bus system and cannot be used for other protocols and buses.

In earlier versions of ODX-LINK, KWP2000 and UDS devices could only be used if
they were assigned an A2L file with the corresponding communication para-
meters. If there was no such file, a dummy file had to be created containing these
KWP2000 or UDS parameters.

ODX-LINK can also be used without an ECU project (in the form of an A2L file).
The communication parameters for UDS or KWP2000 devices are then determ-
ined from the assigned logical link of the ODX project.
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Note

The ODX communication parameters must comply with the ISO 22900-1
specification for ODX V2.0.1 or V2.2 (as far as parameter names, values,
units, etc. are concerned)!

An ECU project can still be assigned to UDS or KWP2000 devices – in this case,
the A2L file is the "master" and ODX parameters are ignored.

If you use a UDS or KWP2000 device in the hardware configuration, you can
simply skip assigning an A2L file – after assigning an ODX project and logical link
for the device, the communication parameters are read out of ODX and used dur-
ing hardware initialization.

Note

If hardware initialization via ODX communication parameters does not
work, you have either assigned the wrong logical link or the ODX data
does not correspond to the ECU.

2.4.3 Automatic Search for and Configuration of OBDonCAN
Devices and OBDonUDS Devices
In ODX-LINK, it is possible to search for all connected devices that support
OBDonCAN or OBDonUDS. To do so, select Hardware > Search For OBD ECUs in
the Hardware Configuration Editor.

An OBDonCAN or an OBDonUDS device with the correct OBD parameters (baud
rate and CAN-ID) is automatically added to the hardware configuration for every
ECU found.

For more details, refer to the corresponding tutorial chapters in the ODX-LINK
User Guide:

"Using OBDonCAN (SAE J1979) with ODX-LINK" on page 87

"Using OBDonUDS (SAE J1979-2) with ODX-LINK" on page 92
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3 Installation

This chapter contains tips on installing the add-on ODX-LINK.

3.1 System Requirements
The hardware and software requirements for working with INCA V7.5 (or higher)
are also sufficient for the add-on ODX-LINK – they are described in the manual
"INCA V7.5 - Installation Guide".

3.2 Installing
This section describes the installation of ODX-LINK.

Certain system requirements according to the ETAS INCA 7.5 Installation Guide
must be met to install the product. Make sure that these system requirements
are met before starting the installation.

To download the INCA installation package

1. On the ETAS homepage, click Download Center.

2. Search for INCA > INCA V7.5 > Software.

3. Download the Installation Package (*.zip).

4. In theWindows File Explorer, select the downloaded ZIP file, right-click and
select Properties.

5. On the General tab, at the Security option disable the Unblock button.

6. Extract the complete structure of the ZIP file.

Note

The fully qualified file name of all components of the setup and the dir-
ectory name are subjects of a restriction and must fall below a certain
character length. The character length is calculated individually.

The path length of the folder where you save the Setup_Ser-
vicePack.exe shall not exceed 80 characters.

Do not change the folder structure, the folder-names, or any name of
installation executables of the installation package.
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To install the software

1. Close all open ETAS software.

Note

Do not execute other software updates in parallel, for example an
update of the operating system. Wait until all updates are installed and
restart the computer before starting the installation.

2. Execute the Setup_ServicePack.exe file from your installation dir-
ectory.

The "Service Pack Installer" window opens.

3. In the Install column, enable your desired software products and add-ons.

To select all, enable the corresponding package on top level.

4. Read the license agreement and enable I read and accept the end user
license agreement option.

5. Select your preferred setup language.

Note

The language you select changes the user interface language for the
Service Pack Installer and the language for newly installed and for all
already installed INCA and INCA add-on products. 

6. Click on Install.

The installation process is initiated.

7. Click on Restart Options.

The "Restart" dialog box opens.

Note

It is recommended to restart your system after the installation is fnished.

Some installations require a restart in between the installation routine. In
this case, a warning sign is displayed in the Status column. After a
restart, the installation will continue automatically.

8. Select the desired restart options.

9. ClickOk.

All your desired software products and add-ons will be installed in silent mode.
This means no additional dialog windows are displayed during installation.

3.3 Licensing
A valid license is required to use the software. You can obtain a license in one of
the following ways:
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from your tool coordinator

via the self-service portal on the ETAS website at
www.etas.com/support/licensing

via the ETAS License Manager

To activate the license, you must enter the Activation ID that you received from
ETAS during the ordering process.

For more information about ETAS license management, see the ETAS License
Management FAQ or the ETAS License Manager help.

To open the ETAS License Manager help

The ETAS License Manager is available on your computer after the installation of
any ETAS software.

1. From theWindows Start menu, select E > ETAS > ETAS License Manager.

The ETAS License Manager opens.

2. Click in the ETAS License Manager window and press F1.

The ETAS License Manager help opens.

ODX-LINK V7.5 | User Guide
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4 ODX-LINK Menus and Functions

If you have installed ODX-LINK on your system, theODXmenu is displayed in the
INCA menu bar of the experiment window.

You can use this menu to

work with the GUIs to run ODX functions (see "User Views" below)

define how the snapshot data is saved (see "Data Logging Configuration "
on page 57)

configure and trigger snapshot functionality (see "Snapshots" on page 60)

This chapter also contains information on the subject "Diagnostic -Signals in The
INCA Variable Selection" (see section "Diagnostic Signals in the INCA Variable
Selection" on page 63).

4.1 User Views
Generally ODX-LINK can open all ODX projects which comply with the ODX stand-
ard in Version 2.0.1 and 2.2.

These projects describe the diagnostic services, with their parameters, which
can be queried via the ODX-LINK user views. In addition, the ODX project contains
decoding information for responses from the ECU, i.e. information about how the
data from the ECU is to be interpreted.

The ODX-LINK user views output this decoded information (or parts thereof) in
the windows.

With the help of several ODX-LINK user views (e.g. the "Diagnostic Services" win-
dow), the user can select and parameterize any service – once the service
request has been sent, the complete, decoded response is shown in the user
view. In this case, the user must have detailed knowledge of the different ser-
vices and of the data transported.

Other ODX-LINK user views, on the other hand, have been developed for very spe-
cial requirements, such as the display of data for Service Inspector ("Service
Inspector" window). In these cases, the user gets the required result at the
simple push of a button.

The ODX-LINK user views do not depend on whether INCA measuring is taking
place or not, i.e.:

even if there is no current INCA measuring, the windows for querying dia-
gnostic data can be used,

the display of data in the ODX-LINK user views is not controlled via the start-
ing or stopping of INCA measuring but exclusively via manual user oper-
ation (using the relevant Read ... buttons),

the displayed diagnostic data of the ODX-LINK windows is not recorded in
an INCA measure file. To record diagnostic data, corresponding diagnostic
signals must be configured for INCA measuring in the INCA variable selec-
tion.

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 20

UseODX > User views to open the dialog windows for running your diagnostic
tasks. The menu contains the following items:

"Diagnostic Services" on page 22

Service Inspector

"Hex Service" on page 28

"OBD" on page 29

Note

The configuration of most ODX-LINK user views (apart from "Diagnostic
Services" and "Hex Services") must correspond to the ODX diagnostic
database read in.
ODX-LINK makes ODX configurations (ODX databases and the cor-
responding default window configurations) available to available stand-
ard diagnostic protocols (OBDonCAN and OBDonUDS) in the form of INCA
export files (to be found in ETASData\INCA7.5\export\ODX).
Please note, however, that these ODX configurations may not actually
suit all diagnostic services of the ECU used, as the diagnostic services of
many ECUs deviate from the relevant standard diagnostic protocol. ECU-
specific fault memory entries and environment data in particular are thus
not part of these sample configurations.

The "OBD" User View
Unlike other diagnostic protocols, the OBD standard defines which services there
are, how they are to be parameterized and which responses they supply.

This is why it is possible in the application case "OBD" to use a specific ODX pro-
ject and preconfigure the "OBD" user view entirely for this project.

When the "OBD" user view is opened, a check is made to see whether all the
necessary services and parameters etc. exist in the ODX project currently being
used by ODX-LINK. If this is not the case, an error message is issued. In this case,
the "OBD" user view is opened but cannot be used with the current database.

Note

The "OBD" User View can only be used with the ETAS OBD-ODX database
ETASData\ODX7.5\Projects\OBDonCAN_ETAS_SAEJ1979<Ver-

sion>.pdx and OBDonUDS_ETAS_SAEJ1979<Version>.pdx. The data-
base is also contained in the INCA export file:
ETASData\INCA7.5\export\ODX\OBDonCan.exp64 and
ETASData\INCA7.4\Export\ODX\ODXTestDevice_OBDonUDS.-

exp64.
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Default Configurations
The configuration of a user view can be saved as a default setting by selecting
the Save as default button in the relevant window.

When you have made a configuration for the first time, you are prompted to spe-
cify whether you want to save these changes as the default setting when you
close the user view. These settings are saved as part of the ODX configuration
and are valid for all GUIs of one type.

This guarantees that ODX project-specific settings in the relevant GUIs do not
have to be started from scratch every time.

Snapshots
All current results of the service requests which you define with user views, can
be saved via a Snapshot function. You decide for each individual user view
whether its result should be included in the snapshot file. The relevant inform-
ation can be found in the configuration settings of the individual user views.

The snapshot icon – a small camera – at the very left of the title bar of each user
view window shows that the results of this user view are recorded in the snap-
shot. For more details on the snapshot function, refer to the section "Snapshots"
on page 60.

Names of User Views
If several user views of the same type but with different configurations are used
in an experiment, they can be given different names (with the exception of "Hex
Service").

To do this, selectConfigure and enter the desired name in the "Window
Name"box.
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Showing the Services in Function Classes
The services can either be displayed as a list (see left of the figure) or in func-
tional classes (shown by a folder) in a user view window (e.g. Diagnostic Ser-
vices):

To configure service display

1. SelectOptions > Users Options >Open from the INCA main menu.

The window for setting user options opens.

2. Select the "ODX" tab.

3. Select "Yes" or "No" with the option "Show Functional Classes".

A service is assigned to a functional group by the author of the ODX project data.

4.1.1 Diagnostic Services
The Diagnostic Services function allows you to send a service request to the
ECU. The service request must be defined in the diagnostic database. The ser-
vice request and its result can be shown both in clear text and in hexadecimal
notation. All clear text must be defined in the diagnostic database. The display of
the service request and the results can be configured.

The request can be executed either just once or recur periodically. The recur-
rence rate can be configured.

If the cyclical send timeframe you defined cannot be adhered to, for example
because the bandwidth of the interface is not sufficient, it is adjusted auto-
matically. In this case, the adjusted cycle time is shown with a red background.

To configure a diagnostic service

1. SelectODX > User views > Diagnostic Services.

The dialog box for selecting a service is displayed.

2. ClickConfigure..
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3. Select "General" in the left-hand window.

4. Activate the check box "Snapshot relevant" if the results of the service
request are to be recorded in the snapshot (see the section "Snapshots"
on page 60).

5. Activate the check box "Show service ID in tree view" if you want the ID of
the Diagnostic Service to be displayed next to the name.

6. Activate the option "Create Measurement Signals from Response Para-
meters" if you want to add the signal measured subsequently to the sig-
nals available in the INCA variable selection (see"Diagnostic Signals in the
INCA Variable Selection" on page 63).

7. Pressing the Save as default button makes any changes you have made
become the default setting.

8. Select "Output Configuration" in the left-hand window.

9. Activate the required options.

10. ClickOK.

Refer to the following table for details of the significance of the options.
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Option Meaning

Show tester data Service request and relevant para-
meters which were sent to the ECU

Show response status Type of response of the ECU, response
status

Showmessage bytes Response of the ECU in hexadecimal
notation

Show response parameter ASAMMCD2D-interpreted response of
the ECU

Show only last response Shows only the data of the last service
request. The data of previous service
requests is deleted

Update during cyclic execution If the cyclic repetation of the service
request is activated, the display is
updated in every cycle

To execute a diagnostic service

1. ChooseODX > User views > Diagnostic Services.

The dialog window for selecting the service will be displayed.

2. Select the service you want to execute from the top left section of the win-
dow.

The top right section of the window will show the parameters for the ser-
vice you selected.

3. In the "Values" column, select the parameter values for the service.
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4. If the service is to be repeated on a regular basis, select the "Cyclic" check
box and enter the cycle intervals.

5. Click Send.

The service request is sent to the control unit and the response from the
ECU will show up in the bottom section of the window.

The data (PDU, Protocol Data Units) sent to the ECU after the service ID has
been entered, can be modified manually. To do this, use hexadecimal notation to
enter the data in the "PDU" field. Please note that afterward, you can no longer
select the parameters for this service.

Java Jobs
The ODX data model makes it possible to run Java code. These Java jobs are
handled like diagnostic services - in particular, intermediate results can be issued
while they are run.

Java jobs are indicated with a Java icon in the list of services - when selected in
the list, both job parameters and diagnostic service parameters are shown on the
right in the window and can also be edited there.

Java jobs are started using the Send button - depending on how complex they
are these may take several seconds or even minutes to run.

Although not permissible in the ODX data model, working with Java GUIs is tech-
nically possible (see the example "JobDemo_JavaGUIs").

Note

The first time they are run, the Java windows may remain in the back-
ground! The windows are only in the foreground when they are run again.

4.1.2 Service Inspector
This function allows you to inspect all diagnostic data of an ECU or vehicle for a
specific diagnostic request. I.e. the function iterates over all requested para-
meters of a service request as defined in the diagnostic database, then sends
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the requests and displays all returned results. The result for the service request
will be displayed in clear text. The service requests and all clear text must be
defined in the diagnostic database.

Note

In former INCA versions, the "Service Inspector" dialog box was named
"ECUIdentification".

This function also allows you to configure the service request and the display of
the results.

The window can also be used to generate diagnostic signals for the INCA variable
selection (see "Diagnostic Signals in the INCA Variable Selection" on page 63).

To configure the Service Inspector

1. SelectODX > User views > Service Inspector.

2. ClickConfigure.

The service request configuration dialog box is displayed.

3. Click "General" in the left-hand window.

4. Activate the "Snapshot relevant" check box if the result of this service
request is to be recorded in the snapshot (see the section "Snapshots" on
page 60).

5. Activate the option "Create Measurement Signals from Response Para-
meters" if you want to add the signal measured subsequently to the dia-
gnostic signal list (see "Diagnostic Signals in the INCA Variable Selection"
on page 63).

The configuration is complete.

or

Click "Request Service" in the left-hand window.
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6. Select the service you want to assign to this function.

7. Click "Response Configuration" in the left-hand window.

8. Select those response parameters which are to be displayed in the display
of results of the service request.

9. ClickOK.

To execute an Service Inspector

1. SelectODX > User views > Service Inspector.

2. Click Read.

The service is executed for all service parameters defined in ODX and the
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ECU responses will be displayed.

3. Click Read to execute the service again.

4.1.3 Hex Service
The Hex Service view allows you to send any data to the ECU through one of the
defined interfaces. You select the diagnostic database for each ECU defined.

The response from the ECU is shown in hexadecimal notation.

The data you enter is stored in a history. You can use data entered within a ses-
sion as many times as required.

To execute a hex service

1. ChooseODX > User views > Hex Service.

The dialog window for specifying the request will be displayed.

2. Select a logical link in the "Location" field.

3. In the "Request" field, enter the data (service ID and PDU) for the request
that is to be sent to the ECU in hexadecimal notation.

or

Select an existing entry from the selection list of the "Request" field.

4. Click Send.
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The response from the ECU will be displayed in the "Response" field in
hexadecimal notation.

4.1.4 OBD
This user view is used to query and display OBD-relevant data. See also the sec-
tions "User Views" on page 19 and "The "OBD" User View" on page 20 for more
general information.

The OBD window provides two different views, one for OBDonCAN (SAE J1979 /
ISO 15031-5 on ISO 15765-4) and another one for OBDonUDS (SAE J1979-2 on ISO
15765-4) including ZEVonUDS (J1979-3 on ISO 15765-4).

Note

Service requests for ZEVonUDS are also covered by the OBDonUDS view
because the ZEVonUDS services are a subset of the OBDonUDS services.

To open the OBD window, clickODX > User Views >OBD. Depending on the selec-
ted ODX project for OBDonCAN or OBDonUDS, the OBD window opens in the cor-
responding view.

The global settings that you can make on the bottom of the OBD window are the
same for both views.

Global Settings

Snapshot relevant

Activate this option if you want information from this user view to be
included in the snapshot. A separate section is created in the snapshot file
for every tab.

Write Configuration to Snapshot

Activate this option if you also want the relevant configuration settings to
be included in the snapshot.

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 30

Read All before Snapshot

Activate this option if you want the Read All function to be executed
before a snapshot. This ensures that the snapshot contains up-to-date
ECU data.

The "Read All" Button and data selection

If all OBD data is to be read at the same time, click Read All at the bottom
edge of the "OBD" window. Next to the Read All button, you can select for
which tabs you want to perform the query. All selected data for PIDs, OBD-
MIDs, monitors, vehicle information data, DTCs etc. that are supported by
the connected ECUs are then read automatically according to the current
configuration settings in each tab.

As it can take some time to read all OBD data – depending on the quantity
of supported data and the number of supported ECUs – progress is shown
in a separate window.

Saved Settings
All global settings and also all settings that you can make in the tabs of the OBD
window are saved as part of the Experiment configuration.

Displaying the Results
The results of the service request are shown in the individual tabs in the form of
tables.

The individual columns of this table can be moved by Drag&Drop – the lines can
also be sorted in ascending or descending order of entries by clicking a column
heading (in the above figure, sorting takes place in ascending order in accord-
ance with the content of the "DTC" column).

For information on the detailed description of the individual user views, see the
following sections:

"OBDonCAN (SAE J1979 / ISO 15031-5 on ISO 15765-4)" on the next page

"OBDonUDS (SAE J1979-2 / SAE J1979-3)" on page 43
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4.1.4.1 OBDonCAN (SAE J1979 / ISO 15031-5 on ISO 15765-4)
This user view is used to query and display OBD-relevant data according to SAE
J1979 / ISO 15031-5 on ISO 15765-4.

See also the sections "User Views" on page 19 and "The "OBD" User View" on
page 20 for more general information.

Emission-Related Diagnostic Services (SAE J1979 / ISO15031-5)
The services $01...$0A are reserved to acquire emission-related diagnostic ser-
vices:

Service $01

Request current powertrain diagnostic data

Service $02

Request powertrain freeze frame data

Service $03

Show stored (emission-related) diagnostic trouble codes ("stored DTCs")

Service $04

Clear/reset emission-related diagnostic information

Service $06

Request on-board monitoring test results for specific monitored systems

Service $07

Request emission-related diagnostic trouble codes detected during cur-
rent or last completed driving cycle ("pending DTCs")

Service $08

Request control of on-board system, test or component

Service $09

Request vehicle information and information from In-Use Performance
Tracking.

Service $0A

Request permanently stored trouble codes ("permanent DTCs").These
emission-related trouble codes have a "permanent" status and cannot be
deleted.

Grouping into Different Tabs
The information in the "OBD" user view is distributed to different tabs for reasons
of clarity. This division does not, however, take place strictly in accordance with
the functionality of the individual services, but is user-oriented.

These are:
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"OBDonCAN "Vehicle Information" Tab" below

Information from service $09 is contained in this tab.

"OBDonCAN "System Status" Tab" on the next page

Information from service $01 is contained in this tab.

"OBDonCAN "PID Data" Tab" on page 34

Information from sercive $01 is contained in this tab, i.e. current diagnostic
data from the powertrain.

"OBDonCAN "DTCs" Tab" on page 36

Information from services $03, $04, $07, amd $0A is contained in this tab.

"OBDonCAN "Freeze Frames" Tab" on page 38

Information from service $02 is contained in this tab.

"OBDonCAN "OBDMIDS" Tab" on page 39

The OBDMonitor IDs of specially monitored systems (service $06) are quer-
ied in this tab.

"OBDonCAN "In Use Performance Tracking" Tab" on page 42

OBDonCAN "Vehicle Information" Tab
Information from service $09 is contained in this tab.

The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data for this purpose.
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ODX Database Vehicle Information: The meaning of each individual entry in the
list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

ID Identifier of the Info Type

Info Type InfoType for scaling and defining service
$09

Number ID (if INFOTYPE contains several pieces
of information)

Value Physical value of INFOTYPE

OBDonCAN "System Status" Tab
Information from service $01 is contained in this tab.

The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data for this purpose.

MIL Status: The icon of the MIL (Malfunction Indicator Lamp) is shown in this
field.

Trouble Codes: The meaning of each individual entry in the list is described in
the following table:
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Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Parameter Name of the parameter

Value Physical value of the parameter

Monitoring Tests: The meaning of each individual entry in the list is described in
the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Monitor Monitor

Supported Is the monitor supported?

Completed Was the monitor ended?

Note

If an ECU identifies itself via service $01, PID01 as a diesel ECU, the monitors rel-
evant for diesel ECUs are displayed, otherwise the monitors for gasoline ECUs.

OBDonCAN "PID Data" Tab
Information from service $01 is contained in this tab, i.e. current diagnostic data
from the powertrain.

PIDs (parameter identifiers) are the identifiers for the information supported by
the engine ECU.

To select the PIDs to be queried, clickConfiguration – the window then shows
additional fields (shown below with an *).
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The individual fields of the GUI contain the following functions and information:

*PID View - Selection and Tools: Using these buttons, you can make a kind of
global selection of the PIDs to be queried in the "PID View" list.

Select visible

Selects all PIDs visible in the "PID View" list (see "OBDonCAN (SAE J1979 /
ISO 15031-5 on ISO 15765-4)" on page 31)

Deselect visible

The selection of visible PIDs is undone

Query all PIDs

Each individual PID is addressed and then checked to see if a response is
returned

*PID View - Filter: Uses filter criteria with regard to the display in the "PID View"
list. The following options are available:

only show supported

If this option is selected, only the PIDs supported by the ECU are made
available for selection in the "PID View" list.

only show responded

If this option is selected, only the PIDs answered by the ECU afterQuery all
PIDs (see above) are made available for selection in the "PID View" list.

Tools: This field is used to read the data – click Read Data for this purpose.

*PID View: This table displays the selected PIDs. The meaning of each individual
entry in the list is described in the following table:
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Column Meaning

Select Selection of the PID

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Name Explicit name of the PID

Support Is this PID supported? (queried from
ECU)

Responded Was the query of this PID answered (via
Query all PIDs)?

Description Explanatory text (if in the database)

PID Data

This table displays the results of the query/queries. The meaning of each indi-
vidual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Parameter Explicit name as one PID can consist of
several pieces of information

Value Physical value of the parameter

Unit Unit of PID (if available)

OBDonCAN "DTCs" Tab
Information from services $03, $04, $07, and $0A is contained in this tab.
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The individual fields of the GUI contain the following functions and information:

DTC View Selection: Selection options for the display of the DTCs in the "Dia-
gnostic Trouble Codes" list. The following options are available:

Pending DTCs

All pending DTCs (service $07) are displayed

Stored DTCs

All stored DTCs (service $03) are displayed

Permanent DTCs

All permanent DTCs (service $0A) are displayed

Tools: This field is used to read the Diagnostic Trouble Codes – click Read DTCs
for this purpose.

Diagnostic Trouble Codes: This table displays the queried DTCs.

The meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

DTC DTC in hex notation (e.g. 0x143)

Vehicle System Vehicle system, e.g. powertrain, body,
chassis
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Column Meaning

Type "Pending", "Stored", or "Permanent"

DTC Name Name of the DTC (e.g. P0143)

DTC Text Explanatory text on the DTC
(e.g. "O2 Sensor Circuit Low Voltage,
Bank 1 Sensor 3")

OBDonCAN "Freeze Frames" Tab
Information from service $02 is contained in this tab.

To select the freeze-frame data to be displayed, clickConfiguration – the win-
dow then shows additional fields (shown below with an *).

The individual fields of the GUI contain the following functions and information:

*PID View - Selection and Tools: Using these buttons, you can make a kind of
global selection of the freeze frame PIDs to be queried in the "PID View" list.

Select visible

Selects all PIDs visible in the "PID View" list (see "OBDonCAN (SAE J1979 /
ISO 15031-5 on ISO 15765-4)" on page 31)

Deselect visible

The selection of visible PIDs is undone

Query all PIDs

Each individual freeze frame PID is addressed and then checked to see if a
response is returned
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*Freeze Frame PID View Filter:Uses filter criteria with regard to the display in the
„PID View" list. The following options are available:

Only show supported

If this option is selected, only those PIDs supported by the ECU are made
available for selection in the „PID View" list.

Only show responded

If this option is selected, only the PIDs answered by the ECU afterQuery all
PIDs (see above) are made available for selection in the „PID View" list.

Tools: This field is used to read the data – click Read Data for this purpose.

In the "PID View" field, you can choose between general OBD Freeze Frames and
manufacturer-specific Freeze Frames.

*PID View: In this table, the Freeze Frame PIDs to be queried are selected. The
meaning of each individual entry in the list is described in the following table:

Column Meaning

Select Selection of the PID

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Name Explicit name of the PID

Support Is this PID supported?

Responded Was the query of this PID answered (via
Query all PIDs)?

Description Explanatory text (if in the database)

Freeze Frame PID Data: This table displays the results of the query/queries. The
meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Parameter Explicit name as one PID can consist of
several pieces of information

Value Physical value of the parameter

OBDonCAN "OBDMIDS" Tab
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The OBDMonitor IDs of specially monitored systems (service $06) are queried in
this tab.

For reasons of clarity, this window is divided into several tabs:

"All OBDMIDs" tab

All OBDMIDs are displayed in this tab

"O2 Sensor OBDMIDs" tab

All OBDMIDs connected with the O2 sensor monitor are displayed in this
tab

"Misfire OBDMIDs" tab

All OBDMIDs connected with the misfire monitor are displayed in this tab

To select the OBDMIDs, clickConfiguration – the window then shows additional
fields (shown below with an *).

The individual fields of the GUI contain the following functions and information:

*OBDMID View - Selection Tools: Using these buttons, you can make a kind of
global selection of the OBDMIDs to be queried in the "OBDMID Selection" list.

Select visible

Selects all OBDMIDs visible in the "OBDMID Selection" list (see "OBDonCAN
(SAE J1979 / ISO 15031-5 on ISO 15765-4)" on page 31).

Deselect visible

The selection of visible OBDMIDs is undone

Query all OBDMIDs

Each individual OBDMID is addressed and then checked to see if a
response is returned
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*OBDMID View - Filter: Uses filter criteria with regard to the display in the
"OBDMID Selection" list. The following options are available:

only show supported

If this option is selected, only those OBDMIDs supported by the ECU are
made available for selection in the "OBDMID Selection" list.

only show responded

If this option is selected, only the OBDMIDs answered by the ECU after
Query all OBDMIDs (see above) are made available for selection in the
"OBDMID Selection" list.

Tools: This field is used to read the data – click Read Data for this purpose.

*OBDMID Selection: The meaning of each individual entry in the list is described
in the following table:

Column Meaning

Select Selection of the OBDMID

ECU Name of the logical link (ECU) from hard-
ware configuration

OBDMID On-Board Diagnostic Monitor ID

Name Explicit name of the ODBMID

Support Is this OBDMID supported?

Responded Was the query of this OBDMID
answered (viaQuery all OBDMIDs)?

Description Explanatory text (if in the database)

OBDMIM Data: The meaning of each individual entry in the list is described in the
following table:

Column Meaning

ECU Name of the logical link (ECU) from
hardware configuration

OBDMID On-Board Diagnostic Monitor ID

TID Test ID of service 08

UnitAndScalingID Unit and Scaling ID (1 Byte)

Test Value Value read from the ECU

Min Test Limit Minimum test limit
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Column Meaning

Max Test Limit Maximum test limit

OBDMID Name Explicit name of the ODBMID

Description Explanatory text (if in the database)

OBDonCAN "In Use Performance Tracking" Tab
In this tab the data of the In-Use Performance Tracking of service $09 is dis-
played.

The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data.

In Use Performance Data: This table displays the queried information of service
$09. The meaning of each individual entry in the list is described in the following
table:

Column Meaning

ECU Name of the logical link (ECU) from
hardware configuration

Name Name of the parameter

Type "General Denominator", "Counter",
"Denominator" or "Numerator"

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 43

Column Meaning

Numerator Tracks the number of times that the
vehicle has been operated in the spe-
cified conditions. These conditions are
specified for each monitored com-
ponent or system.

Denominator Tracks the number of times that all con-
ditions necessary for a specific monitor
to detect a malfunction have been
encountered

Ratio Ratio of the values above

4.1.4.2 OBDonUDS (SAE J1979-2 / SAE J1979-3)
This user view is used to query and display OBD-relevant data.

See also the sections "User Views" on page 19 and "The "OBD" User View" on
page 20 for more general information.

Diagnostic Services (SAE J1979-2 / SAE J1979-3)
The OBDonUDS standard SAE J1979-2 and ZEVonUDS standard SAE J1979-3 make
use of UDS protocol services as defined in ISO14229-1.

The following UDS services are used by the OBD user view to acquire diagnostic
data:

Service $14

Clear/Reset Emission-Related Diagnostic Information

Service $19

Request Emission-Related Diagnostic Trouble Codes with Confirmed
Status, Subfunction $42

Request Emission-Related Diagnostic Trouble Codes with Pending Status,
Subfunction $42

Request Emission-Related Diagnostic Trouble Codes with Permanent
Status, Subfunction $55

Request Powertrain Freeze Frame Data, Subfunction $04

Request Supported DTCExtendedRecord Information, Subfunction $1A

Request DTCExtendedDataRecord, Subfunction $06

Request DTCs for a ReadinessGroup, Subfunction $56

Service $22

Request Current Powertrain Diagnostic Data (PIDs $F400 - $F5FF)

Request On-Board Monitoring Test Results for Specific Monitored Systems
(MIDs $F600 - $F6FF)

Request Vehicle Information (ITIDs $F800 - $F8FF)

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 44

The additional OBDonUDS service $31 “Request Control of On-Board System,
Test, or Component Service” is not provided by the OBD user view but can be
used in the Diagnostic Services user view.

Grouping into Different Tabs
The information in the "OBD" user view is distributed to different tabs for reasons
of clarity. This division does not, however, take place strictly in accordance with
the functionality of the individual services, but is user-oriented.

These are:

"OBDonUDS "Vehicle Information" Tab" on the next page

Information from service $22 for Vehicle Information ITIDs $F800 - $F8FF is
contained in this tab.

"OBDonUDS "System Status" Tab" on the next page

Information from service $22 for Current Powertrain Diagnostic Data PID
$F501 is contained in this tab.

"OBDonUDS "PID Data" Tab" on page 47

Information from service $22 for Current Powertrain Diagnostic Data PIDs
$F400 - $F5FF is contained in this tab.

"OBDonUDS "DTCs" Tab" on page 48

Information from services $19, subfunctions $42 and $55 with Emission-
Related Diagnostic Trouble Codes with Confirmed, Pending and Permanent
Status is contained in this tab.

"OBDonUDS "DTC extended Data Records" Tab" on page 50

Information from services $19, subfunctions $1A and $06 with DTCEx-
tendedDataRecord information for all supported DTCExtendedRecords is
contained in this tab.

"OBDonUDS "DTCs by Readiness Group" Tab" on page 51

Information from services $19, subfunction $56 with DTCs for all Read-
inessGroups is contained in this tab.

"OBDonUDS "Freeze Frames" Tab" on page 52

Information from service $22, subfunction $04 with Powertrain Freeze
Frame Data for pending and confirmed DTCs is contained in this tab.

"OBDonUDS "OBDMIDS" Tab" on page 53

Information from service $22 for On-Board Monitoring Test Results for Spe-
cific Monitored Systems MIDs $F600 - $F6FF is contained in this tab.

"OBDonUDS "In Use Performance Tracking" Tab" on page 55

In this tab the data of the In Use Performance Tracking of service $22 is
dis-played for ITIDs $F808, $F80B.
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OBDonUDS "Vehicle Information" Tab
Information from service $22 for Vehicle Information ITIDs $F800 - $F8FF is con-
tained in this tab.

The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data for this purpose.

Vehicle Information: The meaning of each individual entry in the list is described
in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

ID Identifier for vehicle information

Info Type InfoType parameter name

Number Number of vehicle information (>1 if the
information occurs more than one time)

Value Physical value of INFOTYPE

OBDonUDS "System Status" Tab
Information from service $22 for Current Powertrain Diagnostic Data PID $F501 is
contained in this tab.
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The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data for this purpose.

MIL Status: The icon of the MIL (Malfunction Indicator Lamp) is shown in this
field.

Trouble Codes: The meaning of each individual entry in the list is described in
the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Parameter Name of the parameter

Value Physical value of the parameter

Monitoring Tests: The meaning of each individual entry in the list is described in
the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Monitor Monitor

Supported Is the monitor supported?

Completed Was the monitor completed?
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Note

If an ECU identifies itself via Service $22, PID $F501 as a diesel ECU, the mon-
itors relevant for diesel ECUs are displayed, otherwise the monitors for gasoline
ECUs.

OBDonUDS "PID Data" Tab
Information from service $22 for Current Powertrain Diagnostic Data PIDs $F400 -
$F5FF is contained in this tab.

PIDs (parameter identifiers) are the indentifiers for the information supported by
the engine ECU.

To select the PIDs to be queried, clickConfiguration – the window then shows
additional fields (shown below with an *).

The individual fields of the GUI contain the following functions and information:

*PID View - Selection and Tools: Using these buttons, you can make a kind of
global selection of the PIDs to be queried in the "PID View" list.

Select visible

Selects all PIDs visible in the "PID View" list (see "OBDonUDS (SAE J1979-2 /
SAE J1979-3)" on page 43)

Deselect visible

The selection of visible PIDs is undone

Query all PIDs

Each individual PID is addressed and then checked to see if a response is
returned

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 48

*PID View - Filter: Uses filter criteria with regard to the display in the "PID View"
list. The following options are available:

only show supported

If this option is selected, only the PIDs supported by the ECU are made
available for selection in the "PID View" list.

only show responded

If this option is selected, only the PIDs answered by the ECU afterQuery all
PIDs (see above) are made available for selection in the "PID View" list.

Tools: This field is used to read the data – click Read Data for this purpose.

*PID View: This table displays the selected PIDs. The meaning of each individual
entry in the list is described in the following table:

Column Meaning

Select Selection of the PID

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Name Explicit name of the PID

Support Is this PID supported? (queried from
ECU)

Responded Was the query of this PID answered (via
Query all PIDs)?

Description Explanatory text (if in the database)

PID Data

This table displays the results of the query/queries. The meaning of each indi-
vidual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

PID PID

Parameter Explicit name as one PID can consist of
several pieces of information

Value Physical value of the parameter

Unit Unit of PID (if available)

OBDonUDS "DTCs" Tab
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Information from services $19, subfunctions $42 and $55 with Emission-Related
Diagnostic Trouble Codes with Confirmed, Pending and Permanent Status is con-
tained in this tab.

The individual fields of the GUI contain the following functions and information:

DTC View - Selection:

Show DTC Status and Severity Info

If selected, all rows with DTC Status and Severity information are displayed.
Otherwise, this information is hidden.

Tools:

Read DTCs

If selected, the Diagnostic Trouble Codes are read as configured by the
DTC Reading Options.

Clear DTCs

If selected, all OBD DTCs in the vehicle will be cleared.

DTC Reading Options:

Select if confirmed, pending, and/or permanent DTCs shall be read.:

Confirmed DTCs

Pending DTCs

Permanent DTCs

Select which DTC class shall be read. Class 1 is the default for OBDonUDS:

DTC Class 0

DTC Class 1
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DTC Class 2

DTC Class 3

DTC Class 4

The meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Type of Data Type of information that is displayed in
this row and succeeding rows below

Name Name of the parameter that is displayed

Text Value of the parameter

OBDonUDS "DTC extended Data Records" Tab
Information from services $19, subfunctions $1A and $06 with DTCEx-
tendedDataRecord information for all supported DTCExtendedRecords is con-
tained in this tab.

The individual fields of the GUI contain the following functions and information:

DTC View - Selection

Show DTC Status Info

If selected, all rows with DTC Status and Severity information are displayed.
Otherwise this information is hidden.

Tools

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 51

Read Data

To read all supported extended data records, click Read Data.

The meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Type of Data Type of information that is displayed in
this row and succeeding rows below

Parameter Name of the parameter

Value Value of the parameter

Unit Unit of the parameter (if available)

OBDonUDS "DTCs by Readiness Group" Tab
Information from services $19, subfunction $56 with DTCs for all Read-
inessGroups is contained in this tab.

The individual fields of the GUI contain the following functions and information:

DTC View - Selection

Show DTC Status Info

If selected, all rows with DTC Status information are displayed. Otherwise,
this information is hidden.

Tools
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Read Data

To read the DTCs by Readiness Group, click Read Data.

The meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Type of Data Type of information that is displayed in
this row and succeeding rows below

Parameter Name of the parameter

Value Value of the parameter

OBDonUDS "Freeze Frames" Tab
Information from service $22, subfunction $04 with Powertrain Freeze Frame
Data for pending and confirmed DTCs is contained in this tab.

The individual fields of the GUI contain the following functions and information:

View - Selection

Show DTC Status Info

Tools

Read Data

to read the Freeze Frame data as configured with the reading options -
click Read Data.

Reading Options
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Select if Freeze Frame data shall be read for pending and/or confirmed DTCs:

Pending DTCs

Confirmed DTCs

Select if Freeze Frame snapshot record number $00 and/or $F0 shall be read:

Snapshot Record Number $100

Snapshot Record Number $F0

The meaning of each individual entry in the list is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from hard-
ware configuration

Type of Data Type of information that is displayed in
this row and succeeding rows below

Parameter Name of the parameter

Value Value of the parameter

Unit Unit of the parameter (if available)

OBDonUDS "OBDMIDS" Tab
Information from service $22 for On-Board Monitoring Test Results for Specific
Monitored Systems MIDs $F600 - $F6FF is contained in this tab.

For reasons of clarity, this window is divided into several tabs:

All OBDMIDs tab

All OBDMIDs are displayed in this tab
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O2 Sensor OBDMIDs tab

All OBDMIDs connected with the O2 sensor monitor are displayed in this
tab

Misfire OBDMIDs tab

All OBDMIDs connected with the misfire monitor are displayed in this tab

To select the OBDMIDs, clickConfiguration – the window then shows additional
fields (shown below with an *).

The individual fields of the GUI contain the following functions and information:

*OBDMID View - Selection Tools: Using these buttons, you can make a kind of
global selection of the OBDMIDs to be queried in the "OBDMID Selection" list.

Select visible

Selects all OBDMIDs visible in the "OBDMID Selection" list (see "OBDonUDS
(SAE J1979-2 / SAE J1979-3)" on page 43).

Deselect visible

The selection of visible OBDMIDs is undone

Query all OBDMIDs

Each individual OBDMID is addressed and then checked to see if a
response is returned

*OBDMID View - Filter: Uses filter criteria with regard to the display in the
"OBDMID Selection" list. The following options are available:

only show supported

If this option is selected, only those OBDMIDs supported by the ECU are
made available for selection in the "OBDMID Selection" list.

only show responded

If this option is selected, only the OBDMIDs answered by the ECU after
Query all OBDMIDs (see above) are made available for selection in the
"OBDMID Selection" list.

Tools: This field is used to read the data – click Read Data for this purpose.

*OBDMID Selection: The meaning of each individual entry in the list is described
in the following table:

Column Meaning

Select Selection of the OBDMID

ECU Name of the logical link (ECU) from hard-
ware configuration

OBDMID On-Board Diagnostic Monitor ID

Name Explicit name of the ODBMID
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Column Meaning

Support Is this OBDMID supported?

Responded Was the query of this OBDMID
answered (viaQuery all OBDMIDs)?

Description Explanatory text (if in the database)

OBDMID Data: The meaning of each individual entry in the list is described in the
following table:

Column Meaning

ECU Name of the logical link (ECU) from
hardware configuration

OBDMID On-Board Diagnostic Monitor ID

TID Test ID of service 08

UnitAndScalingID Unit and Scaling ID (1 Byte)

Test Value Value read from the ECU

Min Test Limit Minimum test limit

Max Test Limit Maximum test limit

Unit Unit of the physical value

OBDonUDS "In Use Performance Tracking" Tab
In this tab the data of the In Use Performance Tracking of service $22 is dis-
played for ITIDs $F808, $F80B.
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The individual fields of the GUI contain the following functions and information:

Tools: This field is used to read the data – click Read Data for this purpose.

In Use Performance Data: This table displays the queried information of service
$22 for the ITIDs $F808 and $F80B. The meaning of each individual entry in the list
is described in the following table:

Column Meaning

ECU Name of the logical link (ECU) from
hardware configuration

Name Name of the parameter

Type "General Denominator", "Counter",
"Denominator" or "Numerator"

Numerator Tracks the number of times that the
vehicle has been operated in the spe-
cified conditions. These conditions are
specified for each monitored com-
ponent or system.

Denominator Tracks the number of times that all con-
ditions necessary for a specific monitor
to detect a malfunction have been
encountered

Ratio Ratio of the values above
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4.2 Data Logging Configuration
The "Data Logging Configuration" (ODX > Data Logging Configuration) is used
to determine how snapshot data is saved. For more details on the snapshot func-
tion, refer to the sections "User Views" on page 19 and "Snapshots" on page 60.

Note

Please note that only the data of user views configured accordingly are
recorded in the snapshots. The snapshot icon at the extreme left of the
title bar of the user views indicates whether the data of the relevant user
view is recorded in the snapshot.

The settings which you specified can be exported to a file to be used later. Set-
tings exported previously can be reimported from files exported previously.

The "DataLoggingConfig" window contains two tabs:

File

settings on file name and storage location of the snapshot

Header

meta information added to the snapshot data

To configure Data Logging

1. SelectODX > Data Logging >Configuration.

2. Set the configuration to correspond to your requirements. The following
sections explain the significance of the input fields and options.

3. ClickOK.

"File" Tab
This is where you specify in which directory and with which file name the snap-
shot data is to be saved.
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Input Field or Option Meaning

Directory Directory in which the snapshot files
are saved

File name File name for the snapshot files. If you
activated the option "Create file name
automatically", you cannot enter a file
name here.

Create file name automatically The file name is created automatically

Composition of file name This is where you specify the individual
parts and composition of the file name

Vehicle name Activate this option to include the
vehicle name from the input field in the
file name created automatically.

Append incrementing number An automatically incrementing number
is added to the file name.
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Input Field or Option Meaning

Append date and time The current date and the current time
(format: "yyyymmdd_hhmmss") are
added to the file name

Append output to log file The snapshot data is appended to the
existing data in the log file. This option
is only available when the file name is
generated manually.

Open ASCII log after generation The snapshot file is opened auto-
matically

Create additional XML file An additional XML file is created with
the snapshot data

Open log file after generation The XML file is opened automatically as
HTML in your standard browser.

"Header" Tab
This is where you specify which meta information should be added to the snap-
shot data.
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Input Field or Option Meaning

Name Your name

Department Your department within your company

Logging location The location of the recorded data

Comment Notes on data recording

Vehicle List with vehicle names

Name Name of vehicle

Information Notes on vehicle

Open this dialog before every snap-
shot

Activate this option to open this dialog
box before the snapshot data is saved
to adapt the meta information for the
snapshot.

Exporting and Importing Configurations
All configuration data can be exported as XML files and then imported again. Pro-
ceed as follows:

To export Data Logging Configuration

1. SelectODX > Data Logging Configuration....

2. The "DataLoggingConfig" window opens.

3. Click Export....

A file selector window opens.

4. Enter the required file name and click Save.

To import Data Logging Configuration

1. SelectODX > Data Logging Configuration....

2. The "DataLoggingConfig" window opens.

3. Click Import....

A file selector window opens.

4. Enter the name of the file to be imported and clickOpen.

4.3 Snapshots
With the snapshot function (ODX > Snapshot), it is possible to save the current
data of ODX-LINK windows into a file.

Note

A snapshot saves the diagnostic data currently stored in all snapshot-rel-
evant ODX-LINK user views. Please ensure that the windows are updated
manually before the snapshot function is triggered!

ODX-LINK V7.5 | User Guide



4 ODX-LINK Menus and Functions | 61

Meta data you can configure is added to the data read from the ECU (see the sec-
tion "Data Logging Configuration " on page 57).

You define which data is to be recorded in a snapshot (option "Snapshot rel-
evant"). The data of the following "user views" can be recorded in snapshots:

Diagnostic Services (see "Diagnostic Services" on page 22)

Service Inspector (see "Service Inspector" on page 25)

OBD (see "OBD" on page 29)

The Snapshot icon - a small camera - at the left of the title bar of the relevant dia-
log window indicates whether the data of a user view is recorded in the snapshot.

To record a snapshot

1. Click Snapshot from the toolbar of the INCA experiment environment.

or

SelectODX > Snapshot.

If you activated the relevant option in the "Data Logging Configuration", a
dialog box for the snapshot meta data is displayed. If you did not activate
the option, the data is written immediately.
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2. Enter the relevant meta data. For further details on "Data Logging Con-
figuration", refer to the section "Data Logging Configuration " on page 57.

3. ClickOK.

The snapshot data is written. If you have set the "Data Logging Con-
figuration" accordingly, the data written is displayed accordingly.
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4.4 Diagnostic Signals in the INCA Variable Selection
The diagnostic data that can be read about the ODX project at the diagnostic
interface of an ECU can also be measured and recorded in a measure file with
INCA and ODX-LINK. The prerequisite for this is the definition of diagnostic signals
in the ODX project.

The diagnostic signals of the ODX project are described in the diagnostic signal
list (DSL) – the signals defined there can be used in the same way as standard
measure variables in INCA's "Variable Selection" window.

If users want to work with their own ODX data, it is possible to generate such sig-
nals in the INCA experiment and add them to the ODX project. This function is
available for the user views "Diagnostic Services" and "Service Inspector" (see
"Adding Diagnostic Signals" on page 65).
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When you install ODX-LINK, the ODX projects "OBDonCAN_ETAS_SAEJ1979<Ver-
sion>.pdx" and "OBDonUDS_ETAS_SAEJ1979<Version>.pdx" already con-
tains one DSL file. When using this ODX project, the "Variable Selection" window
in INCA features an additional diagnostic device with the diagnostic signals of the
OBDSignalList.dsl file contained.

The diagnostic device is named in accordance with the following conventions:

<Device name>#<Logical Link>#Diagnostics

4.4.1 Definitions in the Variable Selection Dialog Box
The diagnostic signals in the Variable Selection dialog box are divided into the fol-
lowing signal groups in the OBDonCAN_ETAS_SAEJ1979<Version>.pdx project
(with the included signal list):

Mode1_PIDs

In the signal group "Mode1_PIDs", you find information from service $01
(see "OBDonCAN "PID Data" Tab" on page 34), i.e. up-to-date diagnostic
data from the powertrain.

Mode2_FreezeFrame_PIDs

In the signal group "Mode2_FreezeFrame_PIDs", you find information from
service $02 (see "OBDonCAN "Freeze Frames" Tab" on page 38).

Mode3_DTCs
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In the signal group "Mode3_DTCs", you find signals that are saved and can
be deleted again with service $03 (see "OBDonCAN "DTCs" Tab" on
page 36).

Mode7_DTCs

In the signal group "Mode7_DTCs", you find trouble codes discovered dur-
ing the current or last completed driving cycle (see "OBDonCAN "DTCs"
Tab" on page 36).

Mode9_IUMPR

Mode9_IUMPR_compression

Mode9_IUMPR_spark

In the signal group "Mode9_IUMPR", you find signals from In-Use Per-
formance Tracking (see "OBDonCAN "In Use Performance Tracking" Tab"
on page 42).

ModeA_DTCs

In the signal group "ModeA_DTCs", you find signals that have the status
"permanent" and cannot be deleted (see "OBDonCAN "DTCs" Tab" on
page 36).

Note

In generated signal lists, the functional groups are called "ModeX" (with
the ETAS OBD project) or "ServiceXY" (with other ODX projects).

4.4.2 Adding Diagnostic Signals
To make diagnostic signals available for use in the Variable Selection dialog box,
proceed as follows:

To add diagnostic signals

1. Open the experiment.

2. SelectODX > User views > Diagnostic Services.

The "Diagnostic Services" window opens.

3. SelectConfigure.

4. Select the option "Create Measurement Signals from Response Para-
meters".
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5. ClickOK.

Note

Signals are created for the logical link (and thus also only for the cor-
responding device in the Variable Selection dialog box) for which you
have selected the service!

Note

The selection of this option only applies for the services sent sub-
sequently within the current experiment session and is not saved in
Save as default!

6. Select the service and the parameter you want to measure (and thus add
to the DSL).
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7. Click Send.

One signal is added to the DSL for every numeric value (Integer/Float) in
the response.

8. Close the experiment.

A note is displayed explaining that the ODX project has been modified (as
new signals have been defined) (the diagnostic signal list is saved with the
ODX project in the INCA database) and asking whether you want to save
the ODX project.

9. Select Yes to save the new signals.

10. Open the experiment again.

11. Select Variables > Variable Selection.
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The added diagnostic signals are displayed (here in group "Mode1").

12. Select the signal in the list and right-click it.

13. Select Add to > Layer_1 > New >Measure Window to display the signals
and clickOK.

14. SelectMeasurement > Start Visualization.

The measured diagnostic signals are displayed.

15. Stop the measurement.

16. To include signals for all data that can be called up using this service in the
list of diagnostic signals, selectODX > User views > Service Inspector.

The "Service Inspector" window opens.

17. ClickConfigure.

18. Here too, activate the option "Create Measurement Signals from Response
Parameters".
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19. Select (on the left-hand side of the window) "Request Service" and then
the required service on the right-hand side of the window.

20. If you need to configure the response, select "Response Configuration"
and configure the response accordingly.

21. ClickOK.

22. Click Read in the "Service Inspector" window.
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One signal is added to the DSL for every numeric value (Integer/Float) in
the response.

23. Close the experiment.

A note is displayed explaining that the ODX project has been modified (as
new signals have been defined) (the diagnostic signal list is saved with the
ODX project in the INCA database) and asking whether you want to save
the ODX project.

24. Select Yes to save the new signals.

25. Open the experiment again.

26. Select Variables > Variable Selection.

The added diagnostic signals are displayed (here in group "Mode6").
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27. Select the signals in the list, add them (as above) to a measure window
and start the measurement.

4.4.3 Storage Location of the DSL File
The DSL file is stored in the INCA database in the ODX project. This means the sig-
nals are available in all workspaces/experiments that use this ODX project.

These can also be transferred to other INCA databases by exporting/importing.
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5 ODX-LINK Tutorial

In this tutorial, you will learn the major operational procedures for ODX-LINK.

This tutorial assumes that you have installed INCA and ODX-LINK. For
information on installing ODX-LINK, see Chapter "Installation " on page 16.
This tutorial also assumes that you are familiar with basic INCA oper-
ations.

The tutorial consists of the following lessons:

"Creating an INCAWorkspace " on the next page

In this lesson, you will create a new INCA workspace for working with ODX-
LINK.

"Preparing an INCA Experiment for ODX without Hardware Connection" on
page 76

In this lesson, you will prepare the INCA experiment for using ODX without
any external hardware. The ECU will be simulated, as in the previous les-
son.

"Working with ODX User Views " on page 78

In this lesson, you will use the ODX user views to perform diagnostics and
to display the responses from the ECU.

"Preparing an INCA Experiment for ODX with Real Hardware" on page 82

In this exercise, you will get an INCA experiment ready for working with your
ECU. You need an A2L file and a HEX file for your ECU.

"Configuration of ODX User Views " on page 85

In this lesson, you will modify the configurations for Diagnostic Services,
Service Inspector, and Diagnostic Trouble Code.

"Using OBDonCAN (SAE J1979) with ODX-LINK" on page 87

In this lesson, you will configure INCA for using the OBD protocol SAE J1979
with the OBDonCAN implementation and you will use the ODX-LINK OBD
database for OBD diagnostic communication with a real ECU.

"Using OBDonUDS (SAE J1979-2) with ODX-LINK" on page 92

In this lesson, you will configure INCA for using the OBD protocol SAE
J1979-2 with the OBDonUDS implementation and you will use the ODX-LINK
OBD database for OBD diagnostic communication with a real ECU.

"Working with the "OBD" User View" on page 97

In this lesson, you will work with the OBD user view.

"Using Diagnostic Signal in the Experiment" on page 100

In this lesson you will learn how diagnostic signals can be used in an exper-
iment.

ODX-LINK V7.5 | User Guide



5 ODX-LINK Tutorial | 73

"Measuring OBD Data on the Vehicle" on page 102

In this lesson, you measure diagnostic signals on the vehicle and generate
additional ECU-specific measurement signals.

5.1 Creating an INCAWorkspace
In this lesson, you will create a new INCA workspace for working with ODX-LINK.

You do not need any additional devices for this lesson. The "K-Line Test Device"
will simulate the ECU in this lesson.

To create a top folder

1. Start INCA.

2. Choose Edit > Add > Add top folder.

3. Enter ODXTutorial and press ENTER.

To create an INCA workspace

1. Choose Edit > Add >Workspace.

2. Enter Lesson1 and press ENTER.

To add an ECU project

1. Select Edit > Add > ECU-Project (A2L)...

A window opens in which you can select the project file.

2. Select the
\ETASData\INCA7.5\Data\Demo\

ODXTestDevice.a2l file and clickOpen.

A further window for selecting files opens.

No ECU program file is required for simulating the ECU.

3. ClickCancel.

The ECU project is added to the top folder you selected.
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To add an ODX project

1. Change to the INCA main window and select the ODXTutorial folder.

2. Select Edit > Add >ODX Project....

A file selector window opens.

3. Select the file
\ETASData\ODX7.5\Projects\

ODXTestDeviceTutorial.pdx

and clickOpen.

The ODX project is added.

To add a new device

1. Select the "Lesson1" workspace.

2. Click theConfigure Hardware icon.

The hardware configuration window opens.

3. Select Device > Insert.

A window for selecting the hardware opens.

4. Extend the TS test system item.

5. Select "ODX test device" and clickOK.

The window for selecting the project opens.
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6. Select the "ODXTestDevice" project and clickOK.

A file selector window opens.

7. Select the TestDeviceConfig.tdev file (in the
ETASData\INCA7.5\ODX\TDEV folder).

8. ClickOpen.

This concludes the hardware configuration.

9. Close the "Hardware: >Lesson1<" window.

To add an experiment

1. Choose Edit > Add > Experiment.

2. Enter Experiment1 and press ENTER.

3. Double-click Experiment1.

Now the dialog window for selecting the workspace will appear.

4. Select Lesson1 and clickOK.
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This concludes the hardware and workspace configuration.

5. Close the "Experiment >Experiment1<" window.

In this lesson, you have created a new INCA workspace, added an ECU project, an
ODX project and hardware definition and created an experiment.

5.2 Preparing an INCA Experiment for ODX without Hardware
Connection
In this lesson, you will prepare the INCA experiment for using ODX without any
external hardware. The ECU will be simulated, as in the previous lesson.

The settings you created in Lesson "Creating an INCAWorkspace " on page 73
are prerequisites for this lesson.

To open an ODX configuration

1. Switch to the INCA main window.

2. Open the ODXTutorial folder.

3. Select the workspace Lesson1.

4. Click theConfigure Hardware icon.
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The hardware configuration window opens.

5. Choose Hardware >Configure ODX.

The dialog window for selecting the ODX configuration is displayed.

6. Select the ODXTestDeviceTutorial project file and clickOK.

The dialog window for logical link mapping is displayed.

7. Select "ECU".

8. Click the left arrow.
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9. ClickOK.

10. Close the hardware configuration window.

In this lesson, you have opened an INCA experiment, opened an ODX con-
figuration and assigned a logical link of the ODX project to an INCA device.

5.3 Working with ODX User Views
In this lesson, you will use the ODX user views to perform diagnostics and to dis-
play the responses from the ECU.

Since in this lesson you will not be working with external hardware either, all
responses from the ECU will be simulated. The simulated ECU responses are
defined in the TestDeviceConfig.tdev file.

The settings you created in Lesson "Preparing an INCA Experiment for ODX
without Hardware Connection" on page 76 are prerequisites for this lesson.
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To display the Service Inspector

1. Double-click the workspace "Lesson1".

The experiment "Experiment1" is opened.

2. ChooseODX > User views > Service Inspector.

The dialog window for the Service Inspector will be displayed.

3. Click Read.

The service request to query the Service Inspector is sent to the ECU. The
contents of the service request and the ECU response are displayed in the
bottom section of the window.

4. Close the dialog window.

Note

After installation, this function is assigned the "[1A] readService
Inspector" service identification from the KWP2000 protocol. You can,
however, assign any service identification to this function. For further
information, see "Configuration of ODX User Views " on page 85.
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To execute a diagnostic service

1. ChooseODX > User views > DiagnosticServices.

The dialog window for the diagnostic services is displayed.

2. Select the [1A]readECU-Identification service.

3. In the "Value" column, click the first entry in the "Parameters" field. In the
selection list, click the "VIN - Vehicle Identification Number" entry.

4. Click Send.
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The service request is sent to the simulated ECU. The contents of the ser-
vice request and the ECU response are displayed in the bottom section of
the window.

Note

Some settings for this window are configurable. For further information,
see "Configuration of ODX User Views " on page 85.

To execute a diagnostic service on a regular basis

1. Select the "Cyclic" option.

2. Enter 1500 as the cycle time.

3. Click Send.

The service request will be sent to the ECU every 1.5 seconds. The con-
tents of the service request and the ECU response are displayed in the bot-
tom section of the window.

4. Click STOP.

This stops the cyclic sending of the service request.

5. Close the window.

To execute a freely configurable service request

1. ChooseODX > User views > Hex Services.

The dialog window for the freely configurable diagnostic services is dis-
played.

2. In the "Request" field, enter the service request in hexadecimal notation:
Type in 1A 90.

3. Click Send.

The ECU response is displayed in the "Response" field.

4. Close the dialog window.

In this lesson, you have worked with the user views Service Inspector, Dia-
gnostic Services and Hex Service. You have sent the predefined service
request for identifying the ECU, a service request from the ODX database, a
freely configurable service request to the ECU, and have monitored the response
from the ECU.

If you have not connected any additional hardware to your system, go on to "Con-
figuration of ODX User Views " on page 85.
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5.4 Preparing an INCA Experiment for ODX with Real Hard-
ware
In this exercise, you will get an INCA experiment ready for working with your ECU.
You need an A2L file and a HEX file for your ECU.

To create a top folder and INCA workspace

1. Start INCA.

2. Create a new top folder. Choose Edit > Add > Add top folder.

3. Type in ODXTutorial2 and press ENTER.

4. Add a new workspace. Choose Edit > Add >Workspace.

5. Type in Workspace2 and press ENTER.

To add a new device

1. Choose Device >Configure hardware.

The Hardware Configuration Editor is opened.

2. Choose Device > Insert and select the device you are using.

In the example here, an ES581 with UDS via CAN has been selected. For
your own ECU, you may have to select a different device.
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3. ClickOK.

The dialog window for selecting the project is displayed.

4. Select a project or clickCancel.
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Note

The ODX configuration parameters can be determined from the ODX pro-
ject - an A2L file is not required!

To configure ODX

1. Select Hardware >Configure ODX from the Hardware Configuration
Editor.

2. Select your ODX project file and clickOK.

The ODX project opens.

3. Select the logical link and assign it to the diagnostic device using the arrow
button.

4. ClickOK.

The hardware is now configured.

5. Close the "Hardware: >Workspace2<" window.

To add an experiment

1. Switch to the "INCA" window and select ODXTutorial2.

2. Choose Add > Experiment.

3. Type in Experiment2 and press ENTER.

4. Double-click Experiment2.

A dialog window for selecting the workspace now appears.

5. Select Workspace2 and clickOK.

The experiment is opened.

6. ClickClose.

This concludes the configuration of the hardware and the workspace.

7. Close the "Experiment >Experiment2<" window.

In this exercise, you have created an INCA experiment for working with your own
ECU, have thus created a new INCA workspace, added your hardware com-
ponents and a new experiment.
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5.5 Configuration of ODX User Views
In this lesson, you will modify the configurations for Diagnostic Services, Service
Inspector, and Diagnostic Trouble Code.

The following lessons are prerequisites for this lesson:

"Creating an INCAWorkspace " on page 73

"Preparing an INCA Experiment for ODX without Hardware Connection" on
page 76

"Working with ODX User Views " on page 78

To open an INCA experiment

1. Switch to INCA.

2. Open the "ODXTutorial" folder.

3. Double-click "Lesson1".

The experiment opens.

To configure "Diagnostic Services"

1. ChooseODX > User views > Diagnostic Services.

2. ClickConfigure..

3. Select "Output Configuration".

The configuration dialog window for the display will open.

4. If you have not already done so, please make the following settings:
l Select "Show tester data" to enable the service request to be displayed.
l Select the "Show response status" check box to enable a plain text dis-
play of the ECU response.

l Select the "Showmessage bytes" check box to enable the „response
messages" to be displayed.

l Select the "Show response parameter" check box to enable the inter-
preted response to be displayed.

l Select "Update during cyclic execution" to refresh the display whenever
the service request is periodically repeated.

5. ClickOK.

Your settings are saved.
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To configure "Service Inspector"

1. ChooseODX > User views > Service Inspector.

2. ClickConfigure.

The dialog window for configuring the service for identifying the ECU will be
displayed.

3. Select "Request Service" in the left-hand window.

4. Select the service to be used for reading the Service Inspector.

Note

You can as well select any other service – the output always displays the
ECU responses of the selected service.

5. Select "Response Configuration" in the left-hand window.
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6. Select the options you want to read from the ECU.

ClickOK.

Your settings are saved

In this lesson, you have configured the "Diagnostic Services","Service Inspector".

5.6 Using OBDonCAN (SAE J1979) with ODX-LINK
In this lesson, you will configure INCA for using the OBD protocol SAE J1979 with
the OBDonCAN implementation and you will use the ODX-LINK OBD database for
OBD diagnostic communication with a real ECU.

Note

You can only do this lesson if you have connected one of the hardware
components supported by ODX-LINK (e.g. ES592, ES595, ES582, ES910)
and an ECU.

For this lesson, you need an ECU which supports OBD communication in accord-
ance with ISO15765-4 on CAN or ISO15031-5/SAE J1979.

To configure INCA for OBDonCAN

1. Start INCA.

2. Create a new top folder with Edit > Add > Add top folder.

3. Enter "OBD Tutorial" as top folder name and press ENTER.

4. Add a new workspace using Edit > Add >Workspace.

5. Enter "OBDLesson" as the name and press ENTER.

To add an ODX project for OBD

1. Change to the "INCA" window and select "OBD Tutorial".

2. Select Edit > Add >ODX Project.

3. A file selector window opens for selecting the project or ODX/PDX file(s).
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4. Navigate to the
\ETASData\ODX7.5\Projects folder.

5. Select the file OBDonCAN_ETAS_SAEJ1979<Version>.pdx

6. ClickOpen.

The ODX project is added.

To configure hardware

1. Select the "OBDLesson" workspace.

2. Select Device >Configure Hardware.

The hardware configuration window opens.

3. Select Hardware > Search for OBD ECUs.

4. From the list, select the interface types to be searched for and clickOK.

A search takes place for connected hardware with OBDonCAN support.

The result is shown in the "Search for OBD ECUs" window and can be selec-
ted there.

5. Select an OBDonCAN ECU found and clickOK.

6. Select the corresponding ODX project from the following window and click
OK.
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The "ODX Logical Link mapping Dialog" window opens.

7. Select the required logical link and assign it to the diagnostic device by
clicking the arrow pointing left.

8. ClickOK.
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Parameters such as CAN-ID (in brackets beside the device name) and baud
rate are generated and configured automatically.

9. Select Hardware > Initialize Hardware to test the parameters set.

Once successfully initialized, hardware configuration is completed.

Note

Like every INCA device, an "OBDonCAN" device can only communicate
with one ECU at a time. If you need to communicate with several ECUs
simultaneously, you have to create and configure an individual OBD
device for each one.

10. Close the "Hardware >OBDLesson<" window.

To add an experiment

1. Select Edit > Add > Experiment.

2. Enter "OBDExperiment" and press ENTER.

3. Double-click "OBDExperiment".

A dialog box for selecting the workspace opens.

4. Select "OBDLesson" and clickOK.

The INCA experiment window opens.

To send OBD Service requests with ODX-LINK

1. SelectODX > User views > Diagnostic Services.

The diagnostic services dialog box containing all the OBD services is dis-
played.

2. ClickConfigure….

The "Diagnostic Services Configuration" window for configuring the OBD
service IDs display opens.
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3. Check the "Show service ID in tree view" check box and clickOK.

The diagnostic services dialog box displays the service IDs.

4. Select the service "[0x1] etas_requestCurrentPowertrainDiagnosticData".

5. Select the PID "supportedPIDs($01-$1F)" and click Send.

The service is sent and the response of the ECU shown in the output field.

Note

Your ECUmay only support some of the possible PIDs and OBD services.
If you select a PID or service which is not supported, the ECUmay not
respond at all resulting in a timeout error message in the INCA Monitor
window.

Note

ODX-LINK makes ODX configurations available for OBDonCAN,
OBDonUDS, and the ODX test device as part of INCA export files in the
ETASData\INCA7.5\Export\ODX folder. The ODX-LINK window con-
figurations contained correspond to the relevant diagnostic databases
and can be used immediately.
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5.7 Using OBDonUDS (SAE J1979-2) with ODX-LINK
In this lesson, you will configure INCA for using the OBD protocol SAE J1979-2 with
the OBDonUDS implementation and you will use the ODX-LINK OBD database for
OBD diagnostic communication with a real ECU.

Note

You can only do this lesson if you have connected one of the hardware
components supported by ODX-LINK (e.g. ES592, ES595, ES582, ES910)
and an ECU.

For this lesson, you need an ECU which supports OBD communication in accord-
ance with SAE J1979-2 and ISO15765-4 on CAN..

To configure INCA for OBDonUDS

1. Start INCA.

2. Create a new top folder with Edit > Add > Add top folder.

3. Enter "OBD Tutorial" as top folder name and press ENTER.

4. Add a new workspace using Edit > Add >Workspace.

5. Enter "OBDLesson" as the name and press ENTER.

To add an ODX project for OBD

1. Change to the "INCA" window and select "OBD Tutorial".

2. Select Edit > Add >ODX Project.

3. A file selector window opens for selecting the project or ODX/PDX file(s).

4. Navigate to the
\ETASData\ODX7.5\Projects folder.

5. Select the file OBDonUDS_ETAS_SAEJ1979<Version>.pdx.

6. ClickOpen.

The ODX project is added.

To configure hardware

1. Select the "OBDLesson" workspace.

2. Select Device >Configure Hardware.

The hardware configuration window opens.

3. Select Hardware > Search for OBD ECUs.

4. From the list, select the interface types to be searched for and clickOK.

A search takes place for connected hardware with OBDonCAN and
OBDonUDS support.

The result is shown in the "Search for OBD ECUs" window and can be selec-
ted there.
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5. Select an ODBonUDS ECU found and clickOK.

6. Select the corresponding ODX project from the following window and click
OK.

The "ODX Logical Link mapping Dialog" window opens.

7. Select the required logical link and assign it to the diagnostic device by
clicking the arrow pointing left.
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8. ClickOK.

Parameters such as CAN-ID (in brackets beside the device name) and baud
rate are generated and configured automatically.

9. Select Hardware > Initialize Hardware to test the parameters set.

Once successfully initialized, hardware configuration is completed.

Note

Like every INCA device, an "OBDonCAN" device can only communicate
with one ECU at a time. If you need to communicate with several ECUs
simultaneously, you have to create and configure an individual OBD
device for each one.

10. Close the "Hardware >OBDLesson<" window.

To add an experiment

1. Select Edit > Add > Experiment.

2. Enter "OBDExperiment" and press ENTER.

3. Double-click "OBDExperiment".

A dialog box for selecting the workspace opens.

4. Select "OBDLesson" and clickOK.

The INCA experiment window opens.

To send OBD Service requests with ODX-LINK

1. SelectODX > User views > Diagnostic Services.

The diagnostic services dialog box containing all the OBD services is dis-
played.

2. ClickConfigure….
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The "Diagnostic Services Configuration" window for configuring the OBD
service IDs display opens.

3. Check the "Show service ID in tree view" check box and clickOK.

The diagnostic services dialog box displays the service IDs.

4. Select the service "RequestCurrentPowertrainDiagnosticData".

5. Select the PID "HybridEVBatteryTemperatureData" and click Send.

The service is sent and the response of the ECU shown in the output field.

Note

Your ECUmay only support some of the possible PIDs and OBD services.
If you select a PID or service which is not supported, the ECUmay not
respond at all resulting in a timeout error message in the INCA Monitor
window.

Note

ODX-LINK makes ODX configurations available for OBDonCAN,
OBDonUDS, and the ODX test device as part of INCA export files in the
ETASData\INCA7.5\Export\ODX folder. The ODX-LINK window con-
figurations contained correspond to the relevant diagnostic databases
and can be used immediately.
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5.8 Working with the "OBD" User View
In this lesson, you will work with the OBD user view.

Note

From INCA V7.4.4, you can use the the OBD window also for OBDonUDS and for
the ODX projekt ETASData\ODX7.4\Projects\OBDonUDS_ETAS_
SAEJ1979<Version>.pdx.

You will use the results from lessons "Creating an INCAWorkspace " on page 73
and "Preparing an INCA Experiment for ODX without Hardware Connection" on
page 76 for this purpose, but have to use a different ODX project (see "User
Views" on page 19).

To add an OBD-ODX project

1. Change to INCA.

2. Open the "ODXTutorial" folder.

3. Select Edit > Add >ODX Project.

A file selector window opens for selecting the project or ODX/PDX file(s).

4. Navigate to the \ETASData\ODX7.5\Projects folder.

5. Select the file OBDonCAN_ETAS_SAEJ1979<Version>.pdx.

6. ClickOpen.

The ODX project is added.

To add an ODX configuration

1. Select the "Lesson1" workspace.

2. Select Device >Configure hardware.

The hardware configuration window opens.

3. Select Hardware >Configure ODX.

The window for selecting the ODX project opens.

4. Select the ODX project "OBDonCAN_ETAS" and clickOK.

The logical link mapping window opens.

5. Select the logical link "7E8" and add it to the ODX test device by clicking on
the button with the arrow pointing left.
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6. ClickOK.

7. Close the hardware configuration window.

8. Select Database > Save from the main INCA window.

To query vehicle information and DTCs

1. Double-click the workspace Lesson1.

The experiment is opened.

2. SelectODX > User views >OBD.

The "OBD" user view opens.

3. Select the "Vehicle Information" tab.
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4. Click Read Data.

The information is queried and displayed in the "Vehicle Information" field.

In the "Additional Information" field, additional information on the OBD
requirements of the vehicle (PID $1C) are displayed.

5. Select the "DTCs" tab.

6. Click Read DTCs.

The DTCs are displayed in the "Diagnostic Trouble Codes" field.

ODX-LINK V7.5 | User Guide



5 ODX-LINK Tutorial | 100

5.9 Using Diagnostic Signal in the Experiment
In this lesson you will learn how diagnostic signals can be used in an experiment.

The diagnostic signals are selected in the variable selection dialog and are indic-
ated in the experiment in measuring windows; a measurement is recorded and
viewed in the MDA. For this, use the results from Lesson "Working with the "OBD"
User View" on page 97.

Opening the INCA Experiment

1. Open the folder "ODXTutorial".

2. Double-click the workspace "Lesson1".

The INCA experiment is opened. In the next step select the diostic signals
in the variable selection dialog and assign them to different measuring win-
dows.

Selecting diagnostic signals in the variable selection dialog

1. Select the Variables > Variable Selection.

The variable selection dialog is opened.

2. Select the source
ODX test device:1#7E8#Diagnostics
and open the tree structure.

3. Select under Groups the group Mode7_DTCs.

The diagnostic signals of the group Mode7_DTCs will be displayed.

4. Select the diagnostic signals pendingDTC_01- pendingDTC_04.
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5. Select in the context menu Add to > Layer_1 > New >Measure Table.

6. ClickOK.

The diagnostic signals are displayed in the experiment in a measuring
table.

Indicating diagnostic signals

1. Click the Start Visualization symbol.

The diagnostic signals are displayed in the measuring table.

2. Click the Stop Measuring symbol.

The display will be stopped. In the next step, the diagnostic signals are
recorded in the experiment.

Note

The indicated values of the diagnostic signals are simulated by the use
of the ODX-Test-Device and, hence, remain constant.

Recording diagnostic signals

1. Click the StartRecording symbol.

The measurement will be recorded with a standard recorder.

2. Wait for approx. 10 seconds.

3. Click the Stop Measuring symbol.

The dialog windowOutput File Properties is opened.
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4. Click Save.

The measurement file is stored.

5.10 Measuring OBD Data on the Vehicle
In this lesson, you measure diagnostic signals on the vehicle and generate addi-
tional ECU-specific measurement signals.

To create a main directory and workspace

1. Create a main directory called "OBD Tutorial2".

2. Create an "OBDLesson2" workspace in this directory.

To import the ODX project

Add a diagnostic project
(\ETASData\ODX7.5\Projects\OBDonCAN_ETAS_SAEJ1979<Ver-
sion>.pdx)
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To configure the hardware

1. Select the "OBDLesson2" workspace.

2. Select Device >Configure hardware.

The Hardware Configuration Editor opens.

Note

Make sure that your measurement hardware (ES581, ES595, etc.) is con-
nected to the ECU or vehicle via a CAN port!

3. Select Hardware > Search for OBD ECUs.

4. In the following dialog box, select the interfaces where you want to search
for hardware (e.g. Ethernet, USB etc.).

The list of OBD ECUs found is displayed.

ODX-LINK V7.5 | User Guide



5 ODX-LINK Tutorial | 104

5. Select the OBD ECU that you want to use for hardware configuration and
clickOK.

The relevant OBDonCAN devices are created and configured automatically.

Note

If no ECU is found, the ECU or the vehicle either does not support
OBDonCAN or is not connected correctly with the hardware.

6. Select the ODX project OBDonCAN_ETAS_SAEJ1979_2021-04.
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7. In the "ODX Logical Link mapping Dialog" assign every OBDonCAN device
from the hardware configuration a corresponding logical link from the ODX
project (corresponding to the CAN-ID in the device name and in the name
of the logical link) and clickOK.

8. Close the Hardware Configuration Editor.

To create an experiment and open OBD windows

1. Create an experiment "OBDExperiment2".

2. Open the experiment and select the "OBDLesson2" workspace.

3. SelectODX > User views >OBD.

The "OBD" user view opens.

4. Click Read All to read out all supported OBD data from the connected
ECUs once.

5. SelectODX > Snapshot.

or

Click the snapshot icon.

6. Enter the required data and options in the "DataLogging Configuration" win-
dow in the tabs "File" and "Header" (see "Data Logging Configuration " on
page 57).

7. ClickOK.

The snapshot is taken and opened as a text or HTML file in the relevant
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editors.

To select measurement signals

1. Select Variables > Variable selection.

The Variable Selection dialog box opens.

2. Select the signals to be measured (e.g. PIDs).
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3. Close the Variable Selection dialog box withOK.

The selected signals are shown in a measure window.

To start measuring

1. SelectMeasurement > Start visualization.

2. The measure values of the selected diagnostic signals are displayed.

3. Stop measuring withMeasurement > Stop Measuring.

To generate additional ECU-specific measurement signals for the OBD Mode 6
test results

1. SelectODX > User views > Service Inspector.

The "Service Inspector" user view opens.

2. ClickConfigure.

The configuration window opens.
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3. Select "General" and activate the option "Create Measurement Signals
from Response Parameters".

4. Select "Request Service".

5. Activate the service "[0x6] .... 1MID".

6. ClickOK.

7. Click Read.

All OBD Mode 6 MIDs are queried and the results shown.

In the background, a diagnostic signal is created for each of the para-
meters displayed.

8. Close the experiment.

A note is displayed explaining that the ODX project has changed as new sig-
nals have been generated with a query about whether you want to save
the changes.

9. Confirm withOK or Yes.

10. Open the experiment again.

11. Open the Variable Selection dialog box via Variables > Variable Selection.

12. From the "Variables" field, select "ODX test device: 1#7E8#Diagnostics".

The new signals are in the "Mode6" group and can be selected for meas-
urement there.
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6 ODX-LINK Troubleshooting

6.1 Errors When Adding an ODX Project to the Database

6.2 Errors When Opening the ODX Project

6.3 Errors When Starting a Measurement

6.4 Errors During the Measurement

6.1 Errors When Adding an ODX Project to the Database

Error Message Error Description Remedy

Unable to create ODX
project. The MVCI
Server is in use.

The applications "Tool
X" and ODX-LINK, and
the adding of an ODX
project to the data-
base cannot take
place simultaneously.

End "Tool X" or ODX-LINK
respectively.

ODX file import failed
due to one of the fol-
lowing reasons: some
ODX files or files ref-
erenced by the selec-
ted ODX files (e.g. java
code) are missing.

An error was reported
by the MVCI Server dur-
ing the conversion or
verification of the ODX
project.

Check the reference files of
the project to be imported.

ODX file import failed
due to one of the fol-
lowing reasons: the
ODX files are not ODX
V2.0.1 or V2.2 com-
pliant.

Create the ODX project and
the relevant ODX files in
accordance with the ODX
V2.0.1 or V2.2 specification.

ODX file import failed
due to one of the fol-
lowing reasons: the
ODX files are incon-
sistent and violate
ASAM ODX checker
rules.

Check whether the ODX files
conform to the ASAM-ODX
rules.

Reinstall ODX Add-on
Installation.

Necessary directories
or files of the ODX
Add-on installation are
missing.

Install ODX Add-on again.
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Error Message Error Description Remedy

Can't save ODX project
to file '*'.

There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

The ODX project is
inconsistent. It con-
tains no project file
(*.prj)

There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

The database object
for the ODX project is
not valid.

Generate a new database
object using the ODX files.

Decompressing failed There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

Can't create tem-
porary directory '*'

There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

Can't remove tem-
porary directory

INCA cannot remove a
file from the ETAS
temp temporary dir-
ectory.

INCA is still accessing
this file.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

Another process is still
accessing this file.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.
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Error Message Error Description Remedy

Can't copy file '*' to '*' There is too little stor-
age space in the ETAS
temp folder.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

Close ODX-LINK The applications "Tool
X" and ODX-LINK, and
the adding of an ODX
project to the data-
base cannot take
place simultaneously.

End "Tool X" or ODX-LINK
respectively.

Error accessing MVCI
Server

An error occurred
when trying to access
the MVCI Server.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

Can't remove the file '*' INCA cannot remove a
file from the ETAS
temp temporary dir-
ectory.

INCA is still accessing
this file.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

Another process is still
accessing this file.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.
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Error Message Error Description Remedy

Can't load ODX project
'*'

An error occurred
when adding an ODX
project to the INCA
database

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

It may be necessary to reboot
your PC.

The file * is missing. A necessary file of the
ODX Add-on install-
ation is missing.

Install ODX Add-on again.

The ODX project is
inconsistent. It con-
tains no file '*'

There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

The database object
for the ODX project is
not valid.

Generate a new database
object using the ODX files.

The directory * is miss-
ing..

A necessary directory
of the ODX Add-on
installation is missing.

Install ODX Add-on again.

The ODX project is
inconsistent. File '*' is
not readable

There is too little stor-
age space in the ETAS
temp folder.

Delete the contents of ETAS
temp and reboot INCA.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

The database object
for the ODX project is
not valid.

Generate a new database
object using the ODX files.
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Error Message Error Description Remedy

Can't delete temporary
ODX project in file '*'

INCA cannot remove a
file from the ETAS
temp temporary dir-
ectory.

INCA is still accessing
this file.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

It may be necessary to reboot
your PC.

Another process is still
accessing this file.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

Can't delete temporary
file '*'

INCA cannot remove a
file from the ETAS
temp temporary dir-
ectory

INCA is still accessing
this file.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

It may be necessary to reboot
your PC.

Another process is still
accessing this file.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.
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Error Message Error Description Remedy

Can't delete temporary
file '*'

INCA cannot remove a
file from the ETAS
temp temporary dir-
ectory

INCA is still accessing
this file.

Shut down INCA, delete the
contents of ETAS temp and
reboot INCA.

It may be necessary to reboot
your PC.

Another process is still
accessing this file.

End all other applications
which could be accessing the
ETAS temp directory.

It may be necessary to reboot
your PC.

You do not have the
necessary user rights.

Contact your system admin-
istrator.

Error in TP_BLOP gen-
eration: Sending a
Tester Present Mes-
sage is required for *

The ODX-COM
PARAMs define a
"tester present" mes-
sage without para-
meters. KWPOnCAN
does not support this.

Set the value of the "CP_
TesterPresentHandling" para-
meter to 1 or set the byte size
of the "CP_Tester-
PresentMessage" parameter
to a value > 0.
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6.2 Errors When Opening the ODX Project

Error Message Error Description Remedy

Diagnostic signal description
file error: {Error, Line, Pos-
ition}

A syntax error is contained in
the description file (DSL file).

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Failed to open DiagSig-
nalListSchema.xsd.

The file DiagSig-
nalListSchema.xsd was not
found.

Check whether
the file lies in the
correct folder
(ETAS\INCA
7.5\ODX) and is
properly named.
If the file was not
revised, instal
ODX anew.

Failed to open Vir-
tualDeviceTemplate.a2l.

The file Vir-
tualDeviceTemplate.a2l was
not found.

Check whether
the file lies in the
correct folder
(ETAS\INCA
7.5\ODX) and is
properly named.
If the file was not
revised, instal
ODX anew.

Logical Link '{logical link}' not
found inside the diagnostic
signal description.

The logical link which you
have assigned to a hardware
is not described in the DSL
file. This means that no dia-
gnostic signal is available to
you with this logical link.

Assign the hard-
ware another
logical link, if
necessary.

No valid request found in DSL
file for signal: '{signal name}'

An appropriate request
(inquiry) is missing or the ref-
erenced request is faulty for
a diagnostic signal in the DSL
file. A faulty Request is loc-
alized by one of the following
error messages (see below).

Exchange the
DSL file or have
the programmer
correct the DSL
file.
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Error Message Error Description Remedy

Request: '{request name}'
doesn't contain a parameter
with name: '{parameter
name}'

The Request contains no
parameters with the appro-
priate name in the DSL file.

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Request: '{request name}'
incorrect: value missing

In the DSL file, the applicable
value is missing by a para-
meter with this Request.

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Request: '{request name}'
incorrect: short namemiss-
ing.

In the DSL file, the appro-
priate short name is missing
by a parameter with this
Request.

.

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Request: '{request name}'
incorrect: type not 'const'.

In the DSL file, the Request
does not have the correct
type ('const') for the above
signal.

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Request: '{request name}'
incorrect: type for parameter
'{parameter name}' isn't 'vari-
able' or 'field'.

In the DSL file, the Request
does not have the correct
type ('variable'or 'field') for
the above signal .

Exchange the
DSL file or have
the programmer
correct the DSL
file.

Request: '{request name}'
doesn't contain a valid PDU: '
{incorrect PDU}'

The data input in the DSL file
for the PDU is missing or is
faulty.

Exchange the
DSL file or have
the programmer
correct the DSL
file.
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6.3 Errors When Starting a Measurement

Error Message Error Description Remedy

Failed to create dia-
gnostic service for sig-
nal: '{signal}'

In the DSL file, a dia-
gnostic service is per-
formed which does not
exist in the ODX Project.

Correct the ODX Project.

Exchange the DSL file or
have the programmer cor-
rect the DSL file.

{signal name} getting
TrgtSvr-Sink: '{sink
name}'

The signal does not
receive a Target Server
Object.

Start the measurement
anew.

Load the experiment
anew.

Unavailable parameter '
{parameter name}' for
Request with ID '
{request ID}'.

Failed to create dia-
gnostic service for sig-
nal: '{signal name}'

In the DSL file, a request
is performed whose para-
meter does not exist in
the ODX Project.

Correct the ODX Project.

Exchange the DSL file or
have the programmer cor-
rect the DSL file.
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6.4 Errors During the Measurement

Error Message Error Description Remedy

Service for the following
diagnostic signals repor-
ted execution state:
'{list of signals}'

Execution state: '{text}'

Description of the error: '
{text}'

Vendor description of
the error: '{text}'

The response of a dia-
gnostic service has not
been answered "pos-
itively". All signals which
could not be measured
are listed in the error
message. If no signals
could be measured, the
link to the hardware may
not work correctly.

Remove the signals
which are not supported
by the control device.
Check the connection
with the hardware and ini-
tialize the hardware
anew.

No response received for
signal:
'{signal name}'

In the response of the
diagnostic service, no
reply is present for the
signal. Possibly, the con-
trol device does not sup-
port all diagnostic
signals, which are
included in the DSL file.

Remove the signals
which are not supported
by the control device.
Check the connection
with the hardware and ini-
tialize the hardware
anew.

Parameter for the fol-
lowing diagnostic signal
has an error: '{signal}'

Description of the error: '
{text}'

Vendor description of
the error: '{text}'

In the response, a para-
meter for the signal is
faulty and could not be
evaluated. This means
that no physical value
could be calculated. This
could have been caused
by a faulty ODX data
input or a faulty
response from the con-
trol device.

Correct the ODX Project
or exchange it.
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Error Message Error Description Remedy

Service for the following
diagnostic signals has an
error: '{list of signals}'

Description of the error: '
{text}'

Vendor description of
the error: '{text}'

In the answer, either a
response or a parameter
of the response is faulty.

This could have been
caused by a faulty ODX
data input or a faulty
response from the con-
trol equipment.

Correct the ODX Project
or exchange it.

Exception by updating
value for signal '{signal
name}': '{exception}'

The conversion of a data
type of the D-server in a
data type, which INCA
understands, has failed.
This could have been
caused by a faulty ODX
data input or a faulty
answer from the control
device.

Correct the ODX Project
or exchange it.

{signal name}writing
value:'{exception}'

A value of the signal
could not be written into
the target server.

Start the measurement
anew.

ODX-LINK V7.5 | User Guide



7 ODX Communication Parameters | 121

7 ODX Communication Parameters

The communication parameters are used to initialize the devices used in dia-
gnosis ia ODX and are stored in the ComparamSpec section of the ODX project
(odx-c).

Based on the existing ODX parameters, an ASAP2 TP_BLOP is generated which is
required to generate the ASAP1b driver.

The following sections explain the ODX parameters supported.

Note

ODX-LINK can work with the parameters from the ASAP2 file.
The following rule applies: If an ASAP2 project was assigned to a dia-
gnostic device during hardware configuration, initialization takes place
via the parameters from ASAP2 (as was the case so far) – if, however, no
ASAP2 file was assigned, initialization takes place via the parameters of
the ODX project.

7.1 A2L Structure: TP_BLOP
This structure is required for the following protocols:

KWPOnCAN

UDSOnCAN
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A2L
Para-
meter

ODX
Para-
meter

Value
Range

Con-
version
(ODX(x)
→ A2L(y))

Default
Value

Comment

blob ver-
sion

- - - KWPOnCAN:
0x201;

UDSonCAN:
0x301

The default value is
always used.

Protocol
version

- - - KWPOnCAN:
VDA_1996;

UDSonCAN:
ISO14229_
1_2003

The default value is
always used.

byte order - - - KWPOnCAN:
MSB_FIRST;

UDSOnCAN:
BYTEORDE-
R_MSB_
FIRST

This parameter is
only required for
meas-
uring/calibration
jobs. The default
value is used for dia-
gnostic jobs.

7.2 A2L Structure: CAN
This structure is required for the following protocols:

KWPOnCAN

UDSOnCAN

A2L Para-
meter

ODX Para-
meter

Value
Range/Un-
it

Conversion
(ODX(x) >→
A2L(y))

Defaul-
t Value

Com-
ment

Baudrate CP_Baudrate [0x0;
0xFFFFFFF-
F]

Unit: baud

-

sample
point

CP_
BitSamplePoin-
t

[0; 100] y = x -

sample-
count per
bit

CP_
SamplesPerBit

[0; 1] 0=>1;1=>3 -
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A2L Para-
meter

ODX Para-
meter

Value
Range/Un-
it

Conversion
(ODX(x) >→
A2L(y))

Defaul-
t Value

Com-
ment

BTL_
CYCLES

- - Is generated
using a "Best
Match"
algorithm from
"CP_
BitSamplePoin-
t" and "CP_Syn-
cJumpWidth".

-

SJW length CP_Syn-
cJumpWidth

[0; 100] y = round(CP_
Syn-
cJumpWidth *
BTL_CYCLES) /
100)

-

SYNC_
EDGE

CP_INCA_
SYNC_EDGE

[0; 2] y = x1) 0 The
default
value is
always
used.

1) This is an optional INCA-specific parameter. If it is not defined, the value
defined in the "Default Value" column is used.
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7.3 A2L Structure: CAN Address
This structure is required for the following protocols:

KWPOnCAN

UDSOnCAN

A2L Para-
meter

ODX Parameter Value
Range

Con-
version
(ODX(x) →
A2L(y))

Defaul-
t Value

Com-
ment

CAN_ID
ECU

CP_
CanRespUSDTId

CP_
CanRespUSDTForm-
at

[0x0;
0x1FFFFFF-
F]

[0x4;
0x0F]

4) -

CAN_ID
tester

CP_CanPhysReqId

CP_
CanPhysReqFormat

[0x0;
0x1FFFFFF-
F]

[0x0;
0x3F]

5) -

TGT_ECU CP_CanPhysReqEx-
tAddr

CP_
CanPhysReqFormat

0x0; 0xFF]

[0x0;
0x3F]

6) -

TGT_
tester

CP_
CanRespUSDTEx-
tAddr

CP_
CanRespUSDTForm-
at

[0x0;
0xFF]

[0x4;
0x0F][

7) -

4) y = CP_CanRespUSDTId | ((CP_CanRespUSDTFormat & 0x02) << 30)

5) y = CP_CanPhysReqId | ((CP_CanPhysReqFormat & 0x02) << 30)

6) if ((CP_CanPhysReqFormat & 0x08) == 0x08): y = CP_CanPhysReqExtAddr
otherwise no value is written

7) if ((CP_CanRespUSDTFormat & 0x08) == 0x08): y = CP_CanPhysReqEx-
tAddr otherwise no value is written
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7.4 A2L Structure: CAN TesterPresentOptions
This structure is required for the following protocols:

KWPOnCAN

A2L Para-
meter

ODX Parameter Value
Range

Con-
version
(ODX(x)
=> A2L(y))

Default
Value

Comment

tester
present

CP_Tester-
PresentHandling,

CP_Tester-
PresentReqRsp,

CP_Tester-
PresentMessage

[0; 1]

[0; 1]

Each
byte:
[0x0;
0xFF],

Byte
length:
1 .. 12

See con-
version
parameters

Conversion parameters:
if (CP_TesterPresentHandling = 0) or (bytesize of CP_TesterPresentMessage =
0): 3 1)

if (bytesize of CP_TesterPresentMessage = 1): TesterPresent_WithoutPara-
meter

if (bytesize of CP_TesterPresentMessage > 1 and CP_TesterPresentReqResp =
0):
TesterPresent_WithParameter_NoResponseRequired

if (bytesize of CP_TesterPresentMessage > 1 and CP_TesterPresentReqResp =
1):
TesterPresent_WithParameter_ResponseRequired

1) This does not conform to KWP2000 AML but is supported by the ETAS ASAP1b-
driver
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7.5 A2L Structure: SESSION TesterPresentOptions
This structure is required for the following protocols:

UDSOnCAN

A2L Para-
meter

ODX Parameter Value
Range

Con-
version
(ODX(x)
=> A2L
(y))

Defaul-
t Value

Com-
ment

tester
present

CP_Tester-
PresentHandling,

CP_Tester-
PresentReqRsp,

CP_Tester-
PresentMessage

[0; 1]

[0; 1]

Each byte:
[0x0;0xF-
F],

Byte
length: 1 ..
12

See con-
version
para-
meters

Conversion parameters:

if (bytesize of CP_TesterPresentMessage = 1): Error: "Sending a Tester Present
Message without parameters is not allowed"

if (CP_TesterPresentHandling = 0 or bytesize of CP_TesterPresentMessage =
0): NoTesterPresent

if (CP_TesterPresentHandling != 0 and bytesize of CP_TesterPresentMessage
!= 0 and CP_TesterPresentReqResp = 0): TesterPresent_WithParameter_NoRe-
sponseRequired

if (CP_TesterPresentHandling != 0 and bytesize of CP_TesterPresentMessage
!= 0 and CP_TesterPresentReqResp = 1): TesterPresent_WithParameter_
ResponseRequired
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7.6 A2L Structure: CAN NETWORK_LIMITS
This structure is required for the following protocols:

KWPOnCAN

UDSOnCAN

A2L Para-
meter

ODX Parameter Value
Range

Con-
version
(ODX(x)
=> A2L
(y))

Defaul-
t Value

Com-
ment

WFT_
MAX

CP_
CanMaxNumWaitFra-
mes

[0; 1027] y = x -

XDL_MAX CP_INCA_XDL_MAX [0x0;
0xFFFFFFF-
F]

y = x1) 500 The
default
value is
always
used.

1) This is an optional, INCA-specific parameter. If it is not defined, the value
defined in the "Default Value" column is used.
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7.7 A2L Structure: DIAG_BAUD
This structure is required for the following protocol:

KWPOnCAN

A2L Para-
meter

ODX Parameter Value
Range/Uni-
t

Con-
version
(ODX(x)
=> A2L(y))

Default
Value

Comment

Baudrate CP_INCA_
DIAG_BAUD
_Baudrate

[0x0;
0xFFFFFFF-
F]

Unit: baud

y=x 1), 2) 10400
(default
baud
rate)

The
default
value is
always
used.

diagnostic
mode

CP_INCA_
DIAG_BAUD
_Dia-
gnocsticMode

[0;0xFF] y=x1) 0x86 (=
default
session)

The
default
value is
always
used.

BD_PARA CP_INCA_
DIAG_BAUD
_BD_PARA

Each byte:
[0x0;0xFF],

Byte
length:1 .. 12

y=x 1) 0x06
0x00
0x28
0xA0

The
default
value is
always
used.

1) This is an optional, INCA-specific parameter. If it is not defined, the value
defined in the "Default Value" column is used.

2) With this parameter, it is assumed that "baud" is the unit used. No deviating
unit can be defined in ODX.
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7.8 A2L Structure: TIME_DEF USDTP_TIMING
This structure is required for the following protocols:

KWPOnCAN

A2L Para-
meter

ODX Para-
meter

Value
Range/Unit

Conversion
(ODX(x) =>
A2L(y))

Default
Value

Comment

As CP_As [0;
20000000]
Unit: µs

y = round
(x/1000) 3)

-

Bs CP_Bs [0;
20000000]
Unit: µs

-

Cr CP_Cr [0;
20000000]
Unit: µs

-

p2Min CP_P2Min [0; 250000]
Unit: µs

p2Max CP_P2Max [0;
125000000]
Unit: µs

p3Min CP_P3Min [0; 250000]
Unit: µs

p3Max CP_
P3Max_Ecu

[0;
100000000]
Unit: µs

3) With this parameter, it is assumed that "µs" is the unit used. No deviating unit can be defined in
ODX.
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7.9 A2L Structure: USDTP_TIMING_DEFAULTS
This structure is required for the following protocols:

UDSOnCAN

A2L Para-
meter

ODX Parameter Value
Range/Uni-
t

Con-
version
(ODX(x)
=> A2L(y))

Default
Value

Comment

As CP_As [0;
20000000]
Unit: µs

y = round
(x/1000)3)

-

Bs CP_Bs [0;
20000000]
Unit: µs

-

Cr CP_Cr [0;
20000000]
Unit: µs

-

p2Min CP_P2Min [0;
250000]
Unit: µs

-

p2Max CP_P2Max [0;
12500000-
0] Unit: µs

-

p3Min CP_P3Phys [0;
12500000-
0] Unit: µs

-

p3Max CP_Tester-
PresentTime

[0;
30000000]
Unit: µs

-

3) With this parameter, it is assumed that "µs" is the unit used. No deviating unit can be defined in
ODX.
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7.10 A2L Structure: SESSION
This structure is required for the following protocols:

UDSOnCAN

A2L Para-
meter

ODX
Parameter

Value
Range

Con-
version
(ODX(x)
=> A2L
(y))

Default
Value

Com-
ment

session
identifier

CP_INCA_
UDSSes-
sionIdentifier

char
length:
1 .. 99

1) "UDSSes-
sion"

The
default
value is
always
used.

dia-
gnostic
mode

CP_INCA_
USDSDia-
gnosticMode

[0;0xF-
F]

y=x 1) 0x01 (=
default ses-
sion)

The
default
value is
always
used.

1) This is an optional, INCA-specific parameter. If it is not defined, the value
defined in the "Default Value" column is used.
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7.11 A2L Structure: ADDRESS_AND_LENGTH_FORMAT_
IDENTIFIER
This structure is required for the following protocols:

UDSOnCAN

A2L
Parameter

ODX
Parameter

Value
Range

Conversion
(ODX(x) =>
A2L(y))

Default
Value

Comment

AALFI general
setting

- - - 0x13 These para-
meters exist
for reasons
of com-
patibility to
TP_BLOP and
should not be
used by the
ASAP1b driver
for diagnostic
jobs.

AALFI_FOR_
CHECKSUM
_
CALCULATION

- - - 0x13

AALFI_FOR_
ERASE_
MEMORY

- - - 0x13

AALFI_FOR_
WRITE_
MEMORY
_BY_ADDR

- - - 0x13

AALFI_FOR_
READ_
MEMORY
_BY_ADDR

- - - 0x13

AALFI_FOR_
DYNAMICALLY
_DEFINE_
DATA_ID

- - - 0x13

AALFI_FOR_
REQUEST
_DOWNLOAD

- - - 0x13
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7.12 A2L Structure: SESSION SessionOpeningOrder
This structure is required for the following protocols:

UDSOnCAN

A2L Para-
meter

ODX Parameter Value
Range

Con-
version
(ODX(x)
=> A2L(y))

Default
Value

Com-
ment

session
opening
order

CP_INCA_
UDSSes-
sionOpeningOrder

[0; 2] 1) 2 The
default
value is
always
used.

1) This is an optional, INCA-specific parameter. If it is not defined, the value defined in the "Default
Value" column is used.

7.13 A2L Structure: CAN Transport Protocol Version
This structure is required for the following protocols:

UDSOnCAN

A2L
Parameter

ODX
Parameter

Value
Range

Conversion
(ODX(x) =>
A2L(y))

Default
Value

Comment

transport
protocol ver-
sion

- - - ISO15765_
2_2003

The default
value is
always
used.
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8 Contact Information

Technical Support

For details of your local sales office as well as your local
technical support team and product hotlines, take a look at
the ETAS website:

www.etas.com/hotlines

ETAS offers trainings for its products:

www.etas.com/academy

ETAS Headquarters
ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany Internet: www.etas.com
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Glossary

D
Diagnostic database

The diagnostic database contains all services, their parameters and the possible ECU
responses in hexadecimal and plain text notation. The diagnostic database is stored in
a file with the ".pdx" or ".odx" extension.

E
ETAS temp folder

The ETAS temp folder contains temporary ETAS files. During the initial installation of an
ETAS software product, you have defined the location where the ETAS temp folder is
stored.

O
ODX project

An ODX project combines all components required for communicating and interpreting
data. This includes, for example, the diagnostic database and interface definition.

ODX project file

The ODX project file contains the following information: - A pointer to the database with
the services that have been defined for your ECU. This database contains all the ser-
vices, their parameters and the possible ECU responses in hexadecimal and plain text
notation. - The hardware interface configuration - The definitions for the links between
logical and physical interfaces The ODX project file has the ".prj" file extension.

P
PDU

Protocol Data Unit. The data transmitted to the ECU after the service ID. The PDUs spe-
cify the parameters and the associated values for each service.
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Figures

Fig. 2-1: ISO Standards and ASAM Specifications 11
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