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1 Introduction

1.1 Intended Use
The ES820 Drive Recorder hardware together with the Drive Recorder Service
Pack software and the Drive Recorder Configurator software is designed for the
following purposes:

Configuration via the Drive Recorder Configurator software for automatic
execution of recording jobs on the basis of INCA export files

Use in a vehicle for the purpose of test drives as well as use in the labor-
atory

Integration into existing vehicle instrumentation, replacing the INCA PC

Signal recording from ECUs, buses, networks, and measuring instruments

Data transfer via USB and FTP

The Drive Recorder software consists of two components:

Drive Recorder Configurator

Drive Recorder Service Pack

To be able to operate the ES820 Drive Recorder, the Drive Recorder Configurator
has to be installed on your local PC.

The Drive Recorder Service Pack is installed on the ES820 Drive Recorder already
upon receipt of the device and can be updated regularly. The Drive Recorder Ser-
vice Pack includes INCA installation files.

The Drive Recorder software also includes a Display App, which is designed to
access the Drive Recorder by a touch screen monitor. For further information and
the intended use of the Display App, read the ETAS Drive Recorder Display App -
User Guide.

The ES820 Drive Recorder and the Drive Recorder Configurator software must
only be used by qualified personnel as defined in "Target Group" below, under
consideration of the "Safety Information" on page 3 , and for the purposes that
are described in the corresponding user documentation. ETAS GmbH cannot be
made liable for damage that is caused by improper use and not adhering to the
safety instructions.

1.2 Target Group
The ES820 Drive Recorder together with the Drive Recorder Service Pack and the
Drive Recorder Configurator is designed for engineers working in the field of
measurement and calibration. Experience with the ETAS software INCA is neces-
sary.

Test drivers may use the ES820 Drive Recorder after instruction and under super-
vision of a responsible calibration engineer.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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This document addresses tool coordinators and also all those who manage their
own device.

1.3 Classification of Safety Messages
Safety messages warn of dangers that can lead to personal injury or damage to
property:

DANGER

DANGER indicates a hazardous situation that, if not avoided, will result in death
or serious injury.

WARNING

WARNING indicates a hazardous situation that, if not avoided, could result in
death or serious injury.

CAUTION

CAUTION indicates a hazardous situation that, if not avoided, could result in
minor or moderate injury.

NOTICE
NOTICE indicates a situation that, if not avoided, could result in damage to
property.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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1.4 Safety Information

1.4.1 Hardware

For safe connection and operation of the ES820 Drive Recorder,
read the "ETAS ES800 Measurement, Calibration, and Prototyping
System - User Guide" and the "ETAS ES800 System - Safety Advice".

1.4.2 Software

Observe the ETAS Safety Advice, which is displayed when starting
the Drive Recorder Configurator software.

Drive Recorder Configurator
Additionally, observe the following safety messages when configuring the device
settings. You can access the Device Settings in the Hardware Configuration
window of the Drive Recorder Configurator.

WARNING

Risk of unexpected vehicle behavior

If the Drive Recorder is operated in combination with an ETK, an ECU reset is
possible. An ECU reset can result in engine shutdown, which can cause unex-
pected vehicle behavior.

Even if Allow ETK Reset is turnedOFF, the ETK and the ECU can be reset by
executing the command Run selected recording job with risk of ECU reset
or Run selected experiment with risk of ECU reset.
l Only modify the test setup when the vehicle is stationary.
l Only load experiments when the vehicle is stationary.
l Only update the software when the vehicle is stationary.
l Only start recording jobs when the vehicle is stationary.
l Before driving, always wait until the MEAS LED of the Drive Recorder is per-
manently lit.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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Display App
If using the Display App, additionally pay attention to the following safety mes-
sage:

WARNING

Risk of unexpected vehicle behavior

If the Drive Recorder is operated in combination with an ETK, an ECU reset is
possible. An ECU reset can result in engine shutdown, which can cause unex-
pected vehicle behavior.
l Only modify the test setup when the vehicle is stationary.
l Only start recording jobs when the vehicle is stationary.
l Before driving, always wait until the Recorder Statuswindow of the Display
App shows green side bars.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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1.5 Data Protection
If the product contains functions that process personal data, legal requirements
of data protection and data privacy laws shall be complied with by the customer.
As the data controller, the customer usually designs subsequent processing.
Therefore, he must check if the protective measures are sufficient.

1.6 Data and Information Security
To securely handle data in the context of this product, see the next sections
about data and storage locations as well as technical and organizational meas-
ures.

1.6.1 Data and Storage Locations
The following sections give information about data and their respective storage
locations for various use cases.

Licensing
When using the ETAS License Manager in combination with user-based licenses
that are managed on the FNP license server within the customer's network, the
following data are stored for license management purposes:

Data

Communication data: IP address

User data: Windows user ID

Storage location

FNP license server log files on the customer network

When using the ETAS License Manager in combination with host-based licenses
that are provided as FNE machine-based licenses, the following data are stored
for license management purposes:

Data

Activation data: Activation ID
l Used only for license activation, but not continuously during license
usage

Storage location

FNE trusted storage
C:\ProgramData\ETAS\FlexNet\fne\license\ts

File Transfer
When configuring automated file transfer via FTP, the ES820 Drive Recorder
stores the following data:

Data

User data: FTP file transfer User ID and password

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration



1 Introduction | 6

When configuring automated file transfer to a Windows share, the ES820 Drive
Recorder stores the following data:

User data: Windows User ID and password

Storage location

User-defined, see Drive Recorder Configurator help

End-to-End-Encryption
If you want to use end-to-end-encryption, you have to store the following data
on the Drive Recorder hard disk:

Data

Encryption algorithms

Storage location

..\ETASData\Drive Recorder Con-

figurator<Version>\Security

For more information see "Using End-to-End Encryption" on page 34

Measurement and Analysis
When using the Drive Recorder for measurement, it stores the following data on
the Drive Recorder hard disk:

Data

Measurement data

Additional data for the purpose of measurement analysis

Additional data can be collected when using the Drive Recorder with other soft-
ware components. Your organization can determine which data are collected
when configuring the measurement system. These data are stored in the meas-
urement files and you can only delete them by deleting the respective meas-
urement files. Possible examples for additional data are the vehicle identification
number (VIN), number plate, GPS data video data, audio data, and further meas-
urement data.

Storage location

..\ETASData\Drive Recorder Con-

figurator<Version>\Measure

1.6.2 Technical and Organizational Measures
We recommend that your IT department takes appropriate technical and organ-
izational measures, such as classic theft protection and access protection to
hardware and software.

Encryption Features
By default, the ES820 Drive Recorder does not encrypt data that is stored on the
Drive Recorder hard disk. For file transfer security settings, SFTP is set by default.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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To protect data that is stored on the ES820 Drive Recorder hard disk or trans-
mitted via a network, the Drive Recorder Configurator software provides features
for data encryption. The following features can be accessed and applied via the
Drive Recorder Configurator Hardware Configurationwindow:

Hard disk encryption

FTP security settings

End-to-end encryption for file transfer

You can find a detailed description about how to configure and apply the security
settings in the section "Managing Data Security" on page 30.

System Recovery
The possibilities for system recovery are described in "Resetting the Drive
Recorder System to Factory Settings" on page 21

Decommissioning
In case of decommissioning or before deploying a Drive Recorder for a new pro-
ject, you can delete all data on the ES820 Drive Recorder hard disk, related ES820
Memory Modules, and related USB Rescue Sticks.

Follow the instructions in "Decommissioning" on page 37.

Internet Connectivity
The ES820 is directly connected to the Internet via a USB dongle.

The current PANTARIS solution has no direct connection to the Internet. There-
fore no special protection measures are required.

PANTARIS will be replaced by a successor solution in the future. As soon as the
successor solution is active, the following protective measures are applied if the
ES820 is configured for PANTARIS mode:

The integrated Ethernet interfaces, i.e. the Host and GE port, are assumed
to be in a trusted network and their firewall profile is set to private without
further restrictions.

The firewall profile for external interfaces that are connected by the user is
set to public, blocking all incoming TCP and UDP traffic except for the ports
required for the VPN connection to the cloud.

If the ES820 is not configured for PANTARIS mode, there are no protective meas-
ures, neither for an integrated nor for external interfaces.

You can configure the PANTARIS mode in the Device Options on the left side of
the Drive Recorder Configurator Hardware Configurationwindow.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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2 Finding out More

Apart from this document, you can find more information on the Drive Recorder in
the following user documentation:

ETAS ES800 Measurement, Calibration, and Prototyping System - User
Guide

ETAS ES800 System - Safety Advice

ETAS Drive Recorder Display App - User Guide

Drive Recorder Configurator - Online Help

INCA - Online Help

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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3 Installation

To install the Drive Recorder software components, take into account the over-
view of the Drive Recorder package contents, the system requirements, and
necessary preparations as described in this chapter.

You get information on how to download the installation files and how to install
the software components in the correct order.

3.1 Package Contents
The Drive Recorder software consists of three installation packages with the lis-
ted components:

Drive Recorder Configurator
l Drive Recorder Configurator software
l Documentation:

Online Help

Manuals in PDF format

Release Notes

What's New

Drive Recorder Service Pack
l Drive Recorder Control Software
l Drive Recorder Configurator
l INCA including basic add-on:

INCA Drive Recorder Add-On
l INCA licensed add-ons:

INCA EIP Add-On

INCA LIN Add-On

INCA FlexRay Add-On

INCA ODX-Link Add-On

INCA Vector Hardware Add-On

Drive Recorder Image
l The Drive Recorder Image contains all necessary system software for
resetting the Drive Recorder system to factory settings by use of the
USB Rescue Stick. For more information, read "Resetting the Drive
Recorder System to Factory Settings" on page 21.

3.2 System Requirements
The following system requirements are necessary to install and run the Drive
Recorder Configurator software on your PC and to connect to the Drive
Recorder:

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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Minimum Requirements

Processor Intel® Core™ i5
8 GB RAM

Operating System Windows 10 / Windows 11

Ethernet Free Gigabit Ethernet RJ45 connector

USB Free USB port (USB 3.0 recommended)

You may install INCA on the same PC. In this case, also take the system require-
ments for INCA into account. You can find the system requirements for INCA in
the ETAS INCA - Installation Guide.

3.3 Version Compatibility
If you already have a Drive Recorder Configurator installation on your local PC,
you must observe the following version compatibility requirements:

3.3.1 Drive Recorder Software
It is possible to have both installation versions Drive Recorder Configurator V7.5
and Drive Recorder Configurator V7.3 on your local PC at the same time. For oper-
ation, the versions of the Drive Recorder Configurator and the Drive Recorder Ser-
vice Pack must match. In case of mismatch, a warning message is displayed.

To find out your current Drive Recorder Configurator version

In the menu bar of the Drive Recorder Configuratorwindow, click Help >
About.

The Drive Recorder Configurator version is displayed in the Aboutwindow.

To find out the installed Drive Recorder Service Pack version

In the menu bar of the Drive Recorder Configurator, click Tools > Install or

click .

The Installation dialog window opens. You can see the available EXE files in
the Available Installationswindow area and the installes Service Pack ver-
sion in theCurrently installed versionwindow area.

3.3.2 INCA
The Drive Recorder Service Pack version also indicates the INCA version that is
included in the Drive Recorder Service Pack. Thus, best compatibility is given
when you always use the same version of the INCA Service Pack, the Drive
Recorder Service Pack, and the Drive Recorder Configurator. For more inform-
ation on compatibility, read the Drive Recorder - Release Notes.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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3.3.3 HSP
The Drive Recorder replaces the INCA PC in the measurement setup. Therefore it
is necessary to use the same INCA and Drive Recorder Service Pack versions and
to regularly update the firmware of the connected devices to the compatible HSP
version.

You can either perform the HSP update from the local PC that is connected to the
Drive Recorder or directly from the Drive Recorder.

3.3.3.1 HSP Update from the Local PC
The Drive Recorder must be connected to your local PC via the HOST connector
and via the Drive Recorder Configurator.

All hardware that is relevant for the HSP update must be connected to the Drive
Recorder.

To perform HSP via the Drive Recorder from your local PC

1. Switch the Drive Recorder into the passive mode.

To switch between the active mode and the passive mode, press the Drive
Recorder power button. In the passive mode, the ON LED is blinking with a
50% duty cycle. In the active mode, the ON LED is lit permanently.

2. Download the installation ZIP file for the appropriate HSP version from the
ETAS Download Center.

3. To install the HSP Update Tool on your local PC, unzip the HSP ZIP file and
double-click on setup.

4. Open the HSP Update Tool.

5. To perform the firmware update for the connected ETAS hardware, refer to
the information provided on the ETAS Download Center and in the HSP
Update Tool – Online Help.

3.3.3.2 HSP Update from the Drive Recorder
The Drive Recorder must be connected to your local PC via the HOST connector
or remotely.

To install the HSP Update Tool on the Drive Recorder

1. Download the installation file for the appropriate HSP version from the
ETAS Download Center to your local PC and copy the ZIP file to
..\ETASData\DriveRecorder<Version>\Installations.

2. On your local PC, open the Drive Recorder Configurator and click File >Con-
nect to Drive Recorder.

3. Click Tools > Enter Service Mode.

4. Click Tools > File Transfer from/to Drive Recorder.

The File Transferwindow opens.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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5. On the left hand side of the File Transferwindow, click + to open the Install-
ations folder, select the ZIP file, and click to transfer it to the Drive
Recorder.

6. ClickClose.

7. Connect to the Drive Recorder remotely as described in "Using Remote
Desktop Connection" on page 28

8. On the Drive Recorder, open the File Explorer, and navigate to
..\ETASData\DriveRecorder<Version>\Installations\.

9. Unzip the HSP ZIP file and double-click on setup.

A wizard leads you through the installation. When the installation is fin-
ished, the HSP Update Tool icon appears on the remote desktop.

10. In the Drive Recorder Configurator, click Tools >Quit Service Mode.

The Drive Recorder restarts and automatically reconnects to the local PC.

11. To update the firmware on the connected devices, continue with the next
section.

To perform HSP update from the Drive Recorder

The Drive Recorder must be remotely connected to your local PC as described in
"Using Remote Desktop Connection" on page 28.

1. On the Drive Recorder, open the HSP Update Tool.

2. Click Functions > Search for Hardware.

All devices that are connected to the Drive Recorder are listed.

3. Click Functions > Perform Update.

The firmware on the connected devices is updated and a message is dis-
played when the update is finished.

4. Close the HSP Update Tool and the Remote Desktop connection.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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3.4 Installing the Drive Recorder Configurator
To be able to install the Drive Recorder Service Pack on the Drive Recorder, you
must install the Drive Recorder Configurator on your local PC first.

You might have acquired a single license, which you can install by yourself by
download from the ETAS Download Center. Alternatively, your company may
provide a network installation. Ask your tool coordinator or administrator how to
proceed.

3.4.1 Installing via the ETAS Installation Wizard
To install the Drive Recorder Configurator on your local PC via the ETAS Install-
ation Wizard

1. From the ETAS Download Center, download the Drive Recorder Con-
figurator ZIP file to your local PC.

Depending on your company-specific regulations, the installation files
might alternatively be provided on DVD or on a network drive.

2. In theWindows File Explorer, select the downloaded ZIP file, right-click and
select Properties.

3. On the General tab, at the Security option, disable the Unblock button.

4. Unzip the file on your local PC.

5. Double-click DriveRecorder Configurator_<version>.exe.

A wizard leads you through the installation.

Note

Selecting the Program FilesWindows standard folder for Drive Recorder
data files may lead to problems in the Drive Recorder Configurator since the
access to the program folder depends on theWindows user rights.

Do not save Drive Recorder data files in the Program Files folder. Select a
folder in a data area where all users have read and write access rights.

Note

The language that you select during installation changes the global language
settings of all ETAS software that is already installed on your PC.

3.4.2 Customizing the Installation
This section is intended for tool coordinators or administrators.

To provide the users with the installation files, you can copy the data from the
ETAS Download Center or the DVD to a network drive. A network installation has
the advantage of allowing you to adjust the installation files even before actually
installing the software on the computer. This allows you to set company-specific
defaults.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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Customizing the installation is possible via the
InstallationDefaultSettings.xml configuration file. The settings made in
this XML file can be used for installation via command line arguments.

To customize the Drive Recorder Configurator installation

1. From the ETAS Download Center, download the Drive Recorder Con-
figurator ZIP file to your local PC

2. Unzip the file on your local PC.

3. Open the InstallationDefaultSettings.xml file in a text editor.

4. In the XML file, customize the parameter settings according to the table
below and save your changes.

5. Copy the installation files together with the Install-
ationDefaultSettings.xml file to your desired location.

6. According to your company-specific regulations, run the automated install-
ation or advise users how to install the software via command line argu-
ments. Follow the description in "Setting the Installation Behavior via
Command Line Arguments" below.

Adjustable parameters in the InstallationDefaultSettings.xml file:

Parameter Comment

PRODINSTDIR Path for the installation files directory

PRODDATAINSTDIRALL Path for the data files directory

Parameters other than PRODINSTDIR and PRODDATAINSTDIRALL must not be
changed in the InstallationDefaultSettings.xml file.

3.4.3 Setting the Installation Behavior via Command Line Argu-
ments
This section is intended for tool coordinators or administrators.

After the customization of the InstallationDefaultSettings.xml file, you
can use command line arguments to start and set up an installation routine. This
means that the installation is carried out in silent mode and neither dialog win-
dows nor commands are displayed on the users' PCs during the installation
routine. For example, you can use this option to install the Drive Recorder Con-
figurator without interrupting the users' work.

This is an example for a silent installation initiated by command line arguments:

DriveRecorder Configurator_7.5.exe /Silent /Un-

installPreviousVersion /AllowRestart /EULAAccepted

/SafetyHintsAccepted /DefaultSettings <full path>/In-

stallationDefaultSettings.xml

An explanation as well as a list of the available commands and error codes is
given in the setup.pdf file that is delivered together with the installation files.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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3.5 Files and Folders
After the installation of the Drive Recorder Configurator, installation files and
data files are stored on your local PC.

The installation files, data files, log files, and temp files are stored in different dir-
ectories. If you uninstall or upgrade the software later, only the installation files
are deleted or overwritten, respectively. The data files are still available.

The following folders contain files and folders for special use cases:

"Data Folders" below

"Manuals Folder" on the next page

"PANTARIS Folder" on the next page

3.5.1 Data Folders
The data files are stored in the following subfolders of ..\ETASdata\DriveRe-
corder<Version> by default:

Data Folder Content

Archives Drive Recorder Archive files (*.dra) with multiple con-
tent, e.g. INCA export files, recording job configuration
files, hardware configuration files, Seed&Key files, etc.)

Configurations Hardware configuration files (*.xml)

Export INCA export files (*.exp and *.exp.wsmd)

ExternalTools Software installation files (*.exe) for external applic-
ations

Installations Drive Recorder Service Pack files (*.exe)

Licenses ETAS license files (*.lic)

LogFiles Log files (*.log) created by the Drive Recorder and
INCA

Measure Measurement files (*.mf3 or *.mf4)

Supported measurement file formats:

MDF 3.0, MDF 3.3, MDF 4.0, MDF 4.1

RescueStickCreator Installation files to create a USB Rescue Stick

Subfolder for the Drive Recorder image file

Runtime Firmware components for the Drive Recorder

Security Customer-specific files for end-to-end encryption: .Net
DLL files for the file encryption algorithms, subfolder
Certificates for XML file for the public key

Seed&Key files

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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On the Drive Recorder, the same folders exist. You can access them via the Drive
Recorder Configurator for file transfer between your local PC and the Drive
Recorder as described in the Drive Recorder Configurator - Online Help. This kind
of file transfer is also used for "Installing the Drive Recorder Service Pack" on
page 20.

NOTICE
Risk of data loss in case of resetting the device to factory settings
l Transfer your measurement data to a different storage location regularly.
l Make a backup of the following subfolders of ...\ETASdata from the
Drive Recorder: Configurations, Runtime, LogFiles, Licenses, and
Security.

3.5.2 Manuals Folder
The Manuals folder contains user documentation in PDF format. You can find it
at the following default location:

c:\ETAS\DriveRecorder<Version>\Manuals

In the Drive Recorder Configurator, you can access the Manuals folder via Help >
Manuals.

3.5.3 PANTARIS Folder
The PANTARIS folders are available on the Drive Recorder if the relevant
PANTARIS software for the Drive Recorder is installed on the device.

The default locations are as follows:

D:\PANTARIS\Download

D:\PANTARIS\Upload

Note

If you want to use PANTARIS with your Drive Recorder, contact the ETAS sup-
port for help with the installation of the relevant software components on the
Drive Recorder, see "Contact Information" on page 1.

You can enable or disable the PANTARIS option via the Drive Recorder Con-
figurator in the Hardware Configurationwindow under Device Options > Gen-
eral Settings > PANTARIS.

If PANTARIS Mode is enabled, file transfer between the PANTARIS backend
and the Drive Recorder is enabled.

If both, PANTARIS Mode and Process Drive Recorder Archives after
transfer, are enabeld, the archives transferred to the PANTARIS Download
folder are applied to the Drive Recorder after the currently active recording
job is finished.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration
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The files in the PANTARIS Download folder are temporary. According to their file
extensions, they are distributed to the "Data Folders" on page 15.

PANTARIS Folder Content

D:\PANTARIS\Download Drive RecorderArchive files (*.dra) with multiple
content, e.g. INCA export files, recording job con-
figuration files, hardware configuration files,
Seed&Key files, etc., deployed via PANTARIS

D:\PANTARIS\Upload Measurement files (*.mf3 or *.mf4), Log files
(*.zip) if requested by PANTARIS

3.6 Preparing to Install Software on the Drive Recorder
To be able to install software on the Drive Recorder, you have carried out the
instructions of "Installing the Drive Recorder Configurator" on page 13. When prop-
erly connected, you can install software on the Drive Recorder from your local PC
via the Drive Recorder Configurator. Read how to connect the Drive Recorder to
your local PC in the next sections.

3.6.1 Connecting the Drive Recorder Hardware to the Local PC
To install software on the Drive Recorder, the device must be connected to a suit-
able power supply and to your local PC. The permissible supply voltage range is 6
V to 32 V.

For safe connection and operation of the ES820 Drive Recorder,
read the "ETAS ES800 Measurement, Calibration, and Prototyping
System - User Guide" and the "ETAS ES800 System - Safety Advice".

To connect the Drive Recorder hardware to your local PC

1. Establish the connection of the ES820 Drive Recorder hardware to a suit-
able power supply as well as the Ethernet connection between Drive
Recorder and your PC. For this purpose, follow the instructions in the
"ETAS ES800 Measurement, Calibration, and Prototyping System - User
Guide" and use cables and a power supply as described therein.

2. Turn on the Drive Recorder and wait until the ON LED is lit permanently.

3. If you connect to the Drive Recorder from your local PC for the first time,
see how "To configure the network settings on your local PC" on the next
page.

3.6.2 Configuring the Network Settings on the Local PC
The default Drive Recorder IP address is 192.168.40.228. To be able to establish
an Ethernet connection between your local PC and the Drive Recorder, you must
adapt the network settings on your local PC.
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To configure the network settings on your local PC

The Drive Recorder must be connected to your local PC and turned on as
described in"Connecting the Drive Recorder Hardware to the Local PC" on the
previous page. When the ON LED of the Drive Recorder is permanently lit, you can
proceed with the following steps:

1. From theWindows Start menu , select Settings > Network & Inter-
net > Network and Sharing Center.

The Network and Sharing Centerwindow is displayed.

2. Click according to the sequence in the image below.

After click 4, the Internet Protocol Version 4window opens.

3. In the Alternate Configuration tab of the Internet Protocol Version 4win-
dow, make the following User Configured entries, according to the image
below:
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l IP adress: 192.168.40.99
l Subnet mask: 255.255.255.0

4. After you have confirmed the settings withOK, you can close the Network
and Sharing Center.

3.6.3 Connecting to the Drive Recorder via the Drive Recorder Con-
figurator
According to the previous sections, you have connected the Drive Recorder hard-
ware to your local PC, turned on the Drive Recorder, and made the appropriate
network settings on your local PC.

To connect to the Drive Recorder from your local PC via the Drive Recorder Con-
figurator

Make sure that the ON LED of the Drive Recorder is lit permanently.

1. Start the Drive Recorder Configurator on your local PC.

2. In the menu bar, click File >Connect to Drive Recorder or click .

TheConnect Device dialog window opens.

3. To connect your local PC to the Drive Recorder, do one of the following:

a. Enter the following IP address under Device:
192.168.40.228

or

b. Enter the device name with suffixed serial number SN under Device:

ES820SNXXXXXXX

For example, if the serial number is SN1300464, the device name would
be ES820SN1300464.
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4. Optionally, enable the Automatically open configuration from device
option to open the current hardware configuration in the Drive Recorder
Configurator.

5. ClickConnect.

The device connects to the Drive Recorder Configurator on your PC.

Now you can use the Drive Recorder Configurator for "Installing the Drive
Recorder Service Pack" below or "Installing 3rd Party Software" on page 28.

3.7 Installing the Drive Recorder Service Pack
Before you begin to install the Drive Recorder Service Pack on the Drive Recorder,
make sure that you have finished all steps described in "Preparing to Install Soft-
ware on the Drive Recorder" on page 17.

Note

In order to transfer files and to install software, the Drive Recorder must be
turned on and connected to your local PC.

To transfer the Service Pack EXE file to the Drive Recorder

Download the Service Pack EXE file from the ETAS Download Center and store
the EXE file on your local PC at the following location:

..\ETASdata\DriveRecorder<Version>\Installations

Make sure that the ON LED of the Drive Recorder is lit permanently.

1. In the menu bar of the Drive Recorder Configurator, click Tools > File Trans-

fer from/to Drive Recorder or click .

The File Transferwindow opens. You can see the folder structure on the
local PC and on the Drive Recorder in the left and right part of the window,
respectively.

2. To open the installation folders on both sides, click +. Select the EXE file
that you want to transfer.

3. Click to transfer the EXE file to the installations folder on the Drive
Recorder.
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To install the Service Pack on the Drive Recorder

Make sure that the ON LED of the Drive Recorder is lit permanently.

1. In the menu bar of the Drive Recorder Configurator, click Tools > Install or

click .

The Installation dialog window opens. You can see the available EXE files in
the Available Installationswindow area and the installed Service Pack ver-
sion in theCurrently installed versionwindow area.

2. In the Available Installationswindow area, select the corresponding EXE
file.

3. Click Run installation.

The selected software is installed on the Drive Recorder. The installation
and the rebooting of the Drive Recorder takes some time.

When the ON LED is permanently lit again, the installation of the Service
Pack is finished and your Drive Recorder is ready for operation.

3.8 Resetting the Drive Recorder System to Factory Settings
To upgrade or to downgrade your Drive Recorder, or to repair your Drive Recorder
installation, you have the option to create a USB stick for flashing. This option is
called USB Rescue Stick.

Note that downgrading is allowed from V7.5 to V7.3, but not from V7.5/V7.3 to V7.2.

By default, the USB Rescue Stick solution is provided in the following folder,
together with your installation files:

..\ETASData\DriveRecorder<Version>\RescueStickCreator

3.8.1 Saving the License and the Data

NOTICE
Risk of Data Loss

If you reset the Drive Recorder to the factory settings by the USB Rescue Stick,
all your measurement data on the Drive Recorder hard disk are lost. From the
..\ETASdata\DriveRecorder<Version> data folder, only data in the Con-
figurations, Runtime, LogFiles, Licenses, and Security folders are pre-
served. These data are stored on the USB Rescue Stick. The corresponding
files are copied to the Drive Recorder hard disk again by flashing.

For an encrypted Drive Recorder, data in the above listed folders are lost as
well.
l Transfer your measurement data to a different storage location regularly.
l Make a backup of the following Drive Recorder subfolders of ..\ETASdata:
Configurations, Runtime, LogFiles, Licenses, and Security.

l Make sure that you have a backup USB Security Key for your Drive Recorder.
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3.8.2 Creating the USB Rescue Stick
To create the USB Rescue Stick with a system recovery image for your Drive
Recorder on it, you need the following prerequisites:

USB stick with a required memory size of at least 16 GB

USB 3.0 is recommended.

Recovery image for your Drive Recorder

to be downloaded (see below)

To create the USB Rescue Stick

1. Download the Drive Recorder image on your Drive Recorder from the ETAS
Download Center.

2. To install the recovery image on your Drive Recorder, copy the image from
the Download Center to the images folder.

The default location for this folder is: ..\ETASData\DriveRe-
corder<Version>\RescueStickCreator\images

3. Connect the USB stick to your local PC.

4. In the RescueStickCreator folder, double click start.bat.

The Administrator: Windows Power Shellwindow opens.

5. In the Administrator: Windows Power Shellwindow, proceed according
to the following screenshot and the further steps listed below:
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6. Select the USB drive that you want to convert into the USB Rescue Stick
and press <ENTER>. This means, according to the above example, enter "1".

7. Select the image that you copied from the Download Center and press <
ENTER>. This means, according to the above example, enter "1".

8. Confirm that you want to proceed with the USB Rescue Stick creation.

9. Wait until the Administrator: Windows PowerShellwindow displays the
message that the USB Rescue Stick has successfully been created and
press <ENTER>.

10. The creation of your USB Rescue Stick is finished. You can continue with
"Flashing the Drive Recorder via the USB Rescue Stick" below.

3.8.3 Flashing the Drive Recorder via the USB Rescue Stick
As a prerequisite, you need a prepared USB Rescue Stick, see "Creating the USB
Rescue Stick" on the previous page.

Before flashing your Drive Recorder, note the following:

If the Drive Recorder hard disk is not encrypted, a backup of the license file
is generated on the USB Rescue Stick and restored on the Drive Recorder
during the flashing procedure. The same applies for hardware con-
figuration files..

If the ...\Configuration\ES720Settings.xml hardware settings file
on the USB Rescue Stick is company-specific, the hardware settings file on
the USB Rescue Stick overwrites the device-specific hardware settings file
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on your Drive Recorder.

Otherwise, the device-dependent hardware settings file on your Drive
Recorder remains unchanged.

1. Place the created USB Rescue Stick into a USB port of your Drive Recorder.

The preferred port is 3.0.

2. Unplug all other stacked or connected devices and cables.

3. Restart the Drive Recorder.

Flashing of the Drive Recorder starts. It takes about 15 minutes.

4. Wait until flashing is finished, which is the case when the Drive Recorder
enters the low power standby mode.

5. Unplug the USB stick and activate the Drive Recorder.

The restart scripts are launched.

6. Wait until the firmware update is finished.

An ongoing firmware update is indicated by the ON LED and the MEM LED
blinking synchronously. When the firmware update is finished, both LEDs
stop blinking.

The Drive Recorder reboots.

When the ON LED is ON permanently, rebooting is finished.

NOTICE
Risk of system breakdown

If you interrupt the ongoing firmware update, it is possible that flashing fails in
such a mode that the Drive Recorder system cannot be recovered even by
restarting the flashing procedure.

In this case, use the "Contact Information" on page 39 and send your Drive
Recorder to ETAS for repair.

3.9 Upgrading and Downgrading

3.9.1 Drive Recorder Configurator
To upgrade the Drive Recorder Configurator, follow the same steps as described
in "Installing the Drive Recorder Configurator" on page 13. Downgrading is pos-
sible in the same way.

In case of upgrading, the current Drive Recorder Configurator version is auto-
matically deleted first. An exception is upgrading from Drive Recorder Con-
figurator V7.2 to Drive Recorder Configurator V7.3 and from V7.3 to V7.5. In this
case, the older version also remains on your PC.

The data files on your local PC remain unchanged upon upgrading or down-
grading.
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3.9.2 Drive Recorder Service Pack
Upgrading from V7.3.x to V7.3.(x+n) and from V7.3 to V7.5 is possible by following
the instructions in "Installing the Drive Recorder Service Pack" on page 20. All files
in the "Data Folder" on page 15 are preserved upon upgrading.

Upgrading from V7.2 to V7.3 as well as downgrading from any version is only pos-
sible by using the Drive Recorder image with the corresponding version. Follow
the steps described in "Resetting the Drive Recorder System to Factory Settings"
on page 21. In case the hard disk is encrypted, use the USB Security Key to unlock
the hard disk first. Then the files in the Configurations, Runtime, LogFiles,
and Security folders are preserved upon upgrading or downgrading. For more
information about these folders, see "Data Folder" on page 15.

3.10 Licensing
A valid license is required to use the software. You can obtain a license in one of
the following ways:

from your tool coordinator

via the self-service portal on the ETAS website at www.etas.-
com/support/licensing

via the ETAS License Manager

To activate the license, you must enter the Activation ID that you received from
ETAS during the ordering process.

For more information about ETAS license management, see the ETAS License
Management FAQ or the ETAS License Manager help.

To open the ETAS License Manager help

The ETAS License Manager is available on your computer after the installation of
any ETAS software.

1. From theWindows Start menu, select E > ETAS > ETAS License Manager.

The ETAS License Manager opens.

2. Click in the ETAS License Manager window and press F1.

The ETAS License Manager help opens.

The licensing process has changed to an FNE (FlexNet Embedded) licensing pro-
cess. The FNE license also includes an INCA version. To handle FNE licenses, see
"Activating, Migrating, Renewing, and Returning Licenses on the Drive Recorder"
on the next page

For INCA add-ons, you can purchase an additional license for each add-on. The
Drive Recorder LIN add-on and the Drive Recorder FlexRay add-on are already
included in the license for the Service Pack.

Note

Store the activation IDs at a save location. You need the activation ID again
after returning a license to reactivate the license on a device later.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration

https://www.etas.com/support/licensing
https://www.etas.com/support/licensing
https://www.etas.com/en/downloadcenter/37717.php
https://www.etas.com/en/downloadcenter/37717.php


3 Installation | 26

3.10.1 Activating, Migrating, Renewing, and Returning Licenses on
the Drive Recorder
This section is valid for FNE licenses.

The Drive Recorder Configurator has an Interface to the ETAS License Manager.

In theManage Licenseswindow, you have the following options:

Activate

With this option, you can activate available licenses. For this purpose, you
also need your activation ID.

Renew

This option allows reactivating licences when the maintenance time has
expired.

Migrate

With this option, you can migrate your MAC-based licenses to the new FNE
licenses. This is important for renewing the licenses in future when the
maintenance time is expired.

Return

With this option, you can return a license if the respective Drive Recorder is
not needed any more or if you want to reset the device to factory settings.

Note

You must adapt the internet proxy settings in the ETAS License Manager to the
network environment in which the ETAS License Manager is working. For this,
open the ETAS License Manager and click Device > Settings. You can adjust
the internet proxy settings in the Internet Proxywindow area.

The default setting for the Proxy Mode is Auto.

If there is no proxy, set the Proxy Mode to None.

Otherwise, set the Proxy Mode toManual and adapt the proxy address in the
first line of the Internet Proxywindow area.

To activate, migrate, renew or return licenses on the Drive Recorder

Your local PC must be connected to the Internet.

1. To connect the Drive Recorder to your local PC, open the Drive Recorder
Configurator and click File >Connect to Drive Recorder. Enter the IP
192.168.40.228 and click OK.

2. Click Tools > Enter Service Mode.

3. Click Tools >Manage Licenses.

The License Managerwindow opens.

All licenses that are stored on your Drive Recorder are listed.

4. Depending on your desired action, select the respective licenses and click
one of the following: Activate, Renew,Migrate, or Return.
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A context window opens.

5. In case of activating licenses, insert the activation ID into the context win-
dow. In all other cases, the activation ID is already displayed.

6. Click Activate, Renew,Migrate, or Return.

7. Close the context window

The states of the licenses on the Drive Recorder are now updated.

3.11 Uninstalling
To uninstall the Drive Recorder Configurator

1. In theWindows Start menu , select Settings > Apps.

The Apps and Featureswindow opens.

2. In the Apps and Features, select the Drive Recorder Configurator and click
Uninstall.

The Drive Recorder Configurator is uninstalled from your local PC.
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4 Administration

4.1 Installing 3rd Party Software
If you want to install 3rd party software on the Drive Recorder, the steps in "Pre-
paring to Install Software on the Drive Recorder" on page 17 must be finished.

To install 3rd party software on the Drive Recorder, like drivers or 3rd party hard-
ware configuration tools, follow the steps in "Using the Service Mode" below.

Note

In this document, only the general procedure for the installation of 3rd party
software is described.

You can find product-specific installation and configuration instructions in the
Drive Recorder Configurator - Online Help, in the sections "Configuring 3rd
Party Hardware" and "Drive Recorder Display App".

4.2 Using Remote Desktop Connection
For certain tasks, such as installing 3rd party software on the Drive Recorder, you
must establish a remote connection.

To connect to the Drive Recorder from your local PC via Remote Desktop Con-
nection

Make sure that the ON LED of your Drive Recorder is lit permanently and that you
are connected to the Drive Recorder by the Drive Recorder Configurator.

1. On your local PC, open the Remote Desktop ConnectionWindows App.

2. Enter the following IP adress and User Name:

Computer: 192.168.40.228

User Name: DriveRecorder

Password: etasdr

3. ClickConnect.

TheWindows Securitywindow opens.

4. In theWindows Securitywindow, enter the following login data:

Password: etasdr

ClickOK.

You are remotely connected to the Drive Recorder.

4.3 Using the Service Mode
The service mode allows carrying out installations and/or configurations on the
Drive Recorder in such a way that they are preserved on the Drive Recorder even
after a power cycle (ON/OFF), after wake-up, and after reconnecting the Drive
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Recorder.

Note

The service mode replaces the "persist" option of Drive Recorder V7.2. For some
features, like hard disk encryption, the service mode is automatically applied by
the Drive Recorder. In these cases, a dialog window is displayed for information.

The following tasks are possible in the service mode:

Installing drivers

Connecting 3rd party hardware

Creating hardware configuration files

Creating recording job configuration files

Encrypting and decrypting the hard disk

In this case, the service mode is entered automatically.

Transferring files from the Drive Recorder to the local PC and vice versa

The following tasks are not possible in the service mode:

Applying a hardware configuration

Applying a recording job

Running a recording job or an experiment

Installing a Service Pack

Applying an archive

Automatic file transfer

To use the service mode

1. To connect the Drive Recorder to your local PC, open theDrive Recorder
Configurator and click File >Connect to Drive Recorder. Enter the IP
192.168.40.228 and click OK.

2. Make sure that the Drive Recorder is in the active idle state, which is the
case when the ON LED is lit permanently.

3. In the menu bar, click Tools > Enter Service Mode.

The Drive Recorder performs a restart. Wait until the ON LED and the MEM
LED are both blinking. Then, the device is in the service mode.

4. If you want to install 3rd party software on the Drive Recorder and make
configuration chages in 3rd party software, connect to the Drive Recorder
from your local PC via Remote Desktop Connection.

For other use cases, you can skip this step.

i. On your local PC, open the Remote Desktop ConnectionWindows App.

ii. In theComputer field, enter the following IP adress:

192.168.40.228

iii. Click Connect.

TheWindows Securitywindow opens.
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iv. In theWindows Securitywindow, enter the following login data:

Password: etasdr

ClickOK.

You are remotlely connected to the Drive Recorder.

5. On the Drive Recorder, make the installations or configuration changes
that shall persist.

6. In the menu bar, click Tools >Quit Service Mode.

The Drive Recorder restarts and quits the service mode. The device
reboots. Wait until the ON LED is lit permanently again. The installation of
software is finished and the settings you have made remain on the Drive
Recorder. You can now continue to use the device as usual.

4.4 Managing Data Security
To protect data that are stored on the hard disk of the Drive Recorder, the fol-
lowing measures are available from Drive Recorder V7.3:

4.4.1 Encrypting the Hard Disk and Creating the USB Security Key

4.4.2 Using the USB Security Key

4.4.3 Replicating a USB Security Key

4.4.4 Decrypting the Hard Disk

4.4.5 Using FTPS or SFTP

4.4.6 Using End-to-End Encryption

4.4.7 Internet Connectivity

You can access the security options via the Drive Recorder Hardware Con-
figurationwindow and save the security settings in the Drive Recorder hardware
configuration.

If you lose the USB Security Key for your device, a way to reaccess the hard disk
is to reset the Drive Recorder to the factory settings by using the USB Rescue
Stick.
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NOTICE
Risk of Data Loss

If you reset the Drive Recorder to the factory settings by the USB Rescue Stick,
all your measurement data on the Drive Recorder hard disk are lost. From the
..\ETASdata\DriveRecorder<Version> data folder, only data in the Con-
figurations, Runtime, LogFiles, Licenses, and Security folders are pre-
served. These data are stored on the USB Rescue Stick. The corresponding
files are copied to the Drive Recorder hard disk again by flashing.

For an encrypted Drive Recorder, data in the above listed folders are lost as
well.
l Transfer your measurement data to a different storage location regularly.
l Make a backup of the following Drive Recorder subfolders of ..\ETASdata:
Configurations, Runtime, LogFiles, Licenses, and Security.

l Make sure that you have a backup USB Security Key for your Drive Recorder.

4.4.1 Encrypting the Hard Disk and Creating the USB Security Key
When the Drive Recorder Configurator and the Drive Recorder Service Pack are
installed, you can encrypt the Drive Recorder hard disk. During this process, a
device-specific USB Security Key is created. ETAS recommends creating a
backup USB Security Key for each encrypted Drive Recorder as well.

To encrypt the hard disk of your Drive Recorder

To create the device-specific USB Security Key and a backup USB Security Key,
you need two USB sticks.

1. Connect one of the USB sticks to an appropriate USB port of your Drive
Recorder.

2. To connect the Drive Recorder to your local PC, open the Drive Recorder
Configurator and click File >Connect to Drive Recorder. Enter the IP
192.168.40.228 and click OK.

3. Open an existing hardware configuration on the connected Drive Recorder.
To do this, proceed as follows:
l In the menu bar, select File >Open from Device >Open Hardware Con-
figuration From Device.

The Hardware Configuration dialog window opens with the stored
properties.

4. Click Device Options > Hard Disk Encryption > Encrypt Disk.

A wizard leads you through the hard disk encryption process. It takes about
30 minutes.

Additionally, the USB stick now serves as a device-specific USB Security
Key for your Drive Recorder.
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5. To create a backup USB Security Key, insert the other USB stick into an
appropriate USB port of your Drive Recorder.

6. ClickCreate USB Security Key.

A backup USB Security Key is created for your device.

NOTICE
Risk of data loss
l Do not interrupt the hard disk encryption. Interruption leads to data cor-
ruption.

l The encryption process assigns the USB Security Key the name ETAS-
SECURE-KEY. You must not change this name, otherwise the security key
does no longer work.

4.4.2 Using the USB Security Key
To access the data of an encrypted Drive Recorder hard disk, you need the
device-specific USB Security Key.

Connect the USB Security Key to an appropriate USB port of the Drive
Recorder.

You can insert the USB Security Key either before you connect or after you
have connected to the Drive Recorder from your local PC. Now you can
access the data on the encrypted Drive Recorder hard disk.

Note

The USB Security Key unlocks the Drive Recorder hard disk for one power-up
period after wake-up. After wake-up, you can disconnect the USB Security Key.
If the Drive Recorder is switched off or falls into the standby mode, you must
insert the USB Security Key again to make the Drive Recorder hard disk access-
ible after the next wake-up.

4.4.3 Replicating a USB Security Key
To create a backup USB Security Key for a specific device, you need the already
encrypted Drive Recorder, the device-specific USB Security Key and another
USB stick.

1. Connect the USB Security Key to an appropriate USB port of your Drive
Recorder.

2. To connect the Drive Recorder to your local PC, open theDrive Recorder
Configurator and click File >Connect to Drive Recorder. Enter the IP
192.168.40.228 and click OK.

3. Wait until the ON LED is permanently lit. The hard disk of the Drive Recorder
is then accessible. Now you can remove the USB Security Key.

4. Connect the USB stick that is considered as backup.

ES820 Drive Recorder Configurator and Service Pack V7.5 - Installation and Administration



4 Administration | 33

5. Open an existing hardware configuration on the connected Drive Recorder.
To do this, proceed as follows:
l In the menu bar, click File >Open from Device >Open Hardware Con-
figuration From Device.

The Hardware Configuration dialog window opens with the stored
properties.

6. Click Device Options > Hard Disk Encryption >Create USB Security Key.

The USB stick now serves as an additional device-specific USB Security
Key for your Drive Recorder.

NOTICE
Risk of data loss
l Do not interrupt the replication process. Interruption leads to data cor-
ruption.

l The encryption process assigns the USB Security Key the name ETAS-
SECURE-KEY. You must not change this name, otherwise the key does no
longer work.

4.4.4 Decrypting the Hard Disk
To decrypt the hard disk of your Drive Recorder, you need the device-specific
USB Security Key.

1. Connect the USB Security Key to an appropriate USB port of your Drive
Recorder.

2. To connect the Drive Recorder to your local PC, open theDrive Recorder
Configurator and click File >Connect to Drive Recorder. Enter the IP
192.168.40.228 and click OK.

3. In the menu bar, select File >Open from Device >Open Hardware Con-
figuration From Device.

The Hardware Configuration dialog window opens with the stored prop-
erties.

4. Click Device Options > Hard Disk Encryption > Decrypt Disc.

A wizard leads you through the decryption process. It takes about 30
minutes.

NOTICE
Risk of data loss

Do not interrupt the hard disk decryption. Interruption leads to data corruption.

4.4.5 Using FTPS or SFTP
To encrypt data during transmission via FTP, you can select FTPS or SFTP.
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To select the security option for FTP

1. Open the Drive Recorder Configurator.

2. In the menu bar, click File >Open from Device >Open Hardware Con-
figuration from Device.

The Hardware Configurationwindow opens.

3. In the Hardware Configurationwindow, click File transfer settings.

4. In the Server settingswindow area, select the Security type None, FTPS,
or SFTP.

5. Click Apply on Drive Recorder.

Note

If you apply FTPS or SFTP, the data is only encrypted during transmission. To
protect the data also at the receiving location or on intermediary servers, use
the end-to-end encryption feature which is described in the next chapter

4.4.6 Using End-to-End Encryption
To transfer your data securely and to protect it on intermediary servers, you can
select the option for end-to-end encryption in the File transfer settings of the
Hardware Configurationwindow. You can save this option in your Drive
Recorder hardware configuration and apply it to the Drive Recorder. For this pur-
pose, see "To apply end-to-end encryption for file transfer" on the next page.

A hybrid encryption method is used, which combines symmetric encryption of the
data and asymmetric encryption of the symmetric key. The asymmetric encryp-
tion uses the public key / private key method.

At the sender's end, a random, unique key is generated for each file trans-
fer session. This key is used as the symmetric key to encrypt the files. For
secure transmission to the receiver, the symmetric key is encrypted by a
public key. Then each encrypted file is transmitted along with the encryp-
ted symmetric key. For this purpose, the encrypted symmetric key is
copied for each file and the file name is adapted as follows:
l Encrypted file: <filename>.enc
l Encrypted symmetric key: <filename>.key

The receiver uses his private key to decrypt the symmetric keys. Then the
receiver can decrypt each file by its respective symmetric key.

To provide the public key and algorithms for key encryption and file encryption

The public key has to be provided by your company. The Drive Recorder supports
the XML file format. The PEM file format is not supported.

ETAS provides the RSA algorithm for key encryption and the AES-256 algorithm
for file encryption by default. You can use your own algorithms as well. A .Net DLL
file is needed that references the following file:
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C:\ETAS\DriveRecorder<Version>\Etas.Cryp-

tography.Contracts.dll

Implement the interface ISymmetricCryptographyAlgorithm for the file
encryption algorithm and IAsymmetricCryptograhpyAlgorithm for the key
encryption algorithm.

To transfer the security files from your local PC to the Drive Recorder, in
the Drive Recorder Configurator, click Tools > File Transfer and use the
File transferwindow to copy the files to the appropriate directories:
l Store the XML file for the public key on your Drive Recorder at the fol-
lowing location:

..\ETASData\DriveRecorder<Version>\Se-

curity\Certificates

l Store the .Net DLL file for the key encrypion algorithm at the follwing loc-
ation:

..\ETASData\DriveRecorder<Version>\Security

l Store the .Net DLL file for the file encryption algorithm at the following
location:

..\ETASData\DriveRecorder<Version>\Security

Note

If you have questions about the implementation of the public key and encryp-
tion algorithms, use the "Contact Information" on page 39 to ask ETAS for help.

To apply end-to-end encryption for file transfer

The Drive Recorder must be connected to your local PC.

1. In the Drive Recorder Configurator, open the Hardware Configurationwin-
dow by one of the following options:
l Click File > New > New Hardware Configuration
l Click File >Open from File >Open Hardware Configuration from File
l Click File >Open from Device >Open Hardware Configuration from
Device

The Hardware Configurationwindow opens.

2. On the left, click File transfer settings > Encryption (E2E) .

3. In the right part of the window, make the following selections:
l Select End-to-end encryption.
l Select the Path to public key from the drop-down menu. This is your
public key.

l Select the Key Encryption Algorithm from the drop-down menu.
l Select the File Encryption Algorithm from the drop-down menu.
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4. To select the file types that shall be encrypted, click File transfer settings
> Automatic transfer settings. Select the file types and the option To
Share.

5. To save your settings to the Drive Recorder hardware configuration, click
Safe to File and Close or Apply to Drive Recorder, depending on whether
you have opened the hardware configuration from a file or from the device.

End-to-end encryption is now saved to the current hardware con-
figuration. After clicking Apply to Drive Recorder, end-to-end encryption
is applied to all file types that are selected in the Automatic transfer set-
tings.

At the receiving location, the file names for the encrypted files and the
respective keys are as follows:
l Encrypted file: <filename>.enc
l Encrypted symmetric key: <filename>.key

The receiver can use the private key to decrypt the symmetric keys. Each
file can then be decrypted by its respective symmetric key.

4.4.7 Internet Connectivity
The current PANTARIS solution has no direct connection to the Internet. There-
fore no special protection measures are required.

PANTARIS will be replaced by a successor solution in the future. As soon as the
successor solution is active, the following protective measures are applied if the
ES820 is configured for PANTARIS mode:

The integrated Ethernet interfaces, i.e. the Host and GE port, are assumed
to be in a trusted network and their firewall profile is set to private without
further restrictions.

The firewall profile for external interfaces that are connected by the user is
set to public, blocking all incoming TCP and UDP traffic except for the ports
required for the VPN connection to the cloud.

If the ES820 is not configured for PANTARIS mode, there are no protective meas-
ures, neither for an integrated nor for external interfaces.

You can configure the PANTARIS mode in the Device Options on the left side of
the Drive Recorder Configurator Hardware Configurationwindow.

See also

"Hardware Configuration Dialog Window" on page 1
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5 Decommissioning

When decommissioning an ES820 Drive Recorder or when deploying an ES820
Drive Recorder for a new project, ETAS recommends to delete all unnecessary
data on the Drive Recorder as well as on all related ES820 Memory Modules and
USB Rescue Sticks. This allows having enough memory for newmeasurements in
future projects as well as deleting user data that might be stored in files, such as
measurement files and log files.

For decommissioning, the following actions are recommended:

Resetting the Drive Recorder to factory settings by the USB Rescue Stick

Formatting the related ES820 Memory Modules by a PC using the ES820
Docking Station

To reset the Drive Recorder to factory settings

You need a USB 3.0 stick.

1. Connect to the Drive Recorder by the Drive Recorder Configurator.

2. Return the license file according to "Activating, Migrating, Renewing, and
Returning Licenses on the Drive Recorder" on page 26.

3. Perform the steps described in "Creating the USB Rescue Stick" on
page 22 and "Flashing the Drive Recorder via the USB Rescue Stick" on
page 23.

All data in the Drive Recorder Data folders including user data on the Drive
Recorder is now deleted.

4. Format the USB Rescue Stick to delete remaining data that might contain
user data, like log files and hardware configuration files.

Your Drive Recorder is now decommissioned.

To format related ES820 Memory Modules

You need the "ETAS ES800 System - User Guide" and an ES820 Docking Station
for ES820 Memory Module.

1. Insert the ES820 Memory Module into the Docking Station for the ES820
Memory Module according to the description in the "ETAS ES800 System -
User Guide".

2. Connect the ES820 Docking Station to a PC by USB 3.0.

The hard disk of the ES820 Memory Module is now visible in theWindows
File Explorer.

3. Format the hard disk of the ES820 Memory Module.

All data is now removed from the ES820 Memory Module.

To delete data on the built-in ES820 Memory Module

If you want to delete data on the built-in ES820 Memory Module without remov-
ing it from the Drive Recorder, you can do this via the File Transferwindow of the
Drive Recorder Configurator.
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1. Connect to the Drive Recorder by the Drive Recorder Configurator.

2. Click Tools > File transfer from/to Drive Recorder.

The File Transferwindow opens. In the right window area, the Measure
files on Memory Module folder is displayed.

3. Delete all files in the Measure files on Memory Module folder by click-

ing .

The remaining data including user data is now deleted from the built-in
ES820 Memory Module.
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6 Contact Information

Technical Support

For details of your local sales office as well as your local
technical support team and product hotlines, take a look at
the ETAS website:

www.etas.com/hotlines

ETAS offers trainings for its products:

www.etas.com/academy

ETAS Headquarters
ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany Internet: www.etas.com
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